Can't Load Grain To A Train?


Well-known member
On my second day trying to load a grain car from a grain facility. Tried various grain loading industries, trains and drivers.

As soon as I Start the session I get a red symbol error, as follows:

- <kuid2:68787:1449:10> : DriverCharacter.NavigateToIndustry> unable to find industry track 'out_track0' (file
; <kuid2:68787:1449:10> : Script class: DriverCharacter
; <kuid2:68787:1449:10> : Object: ScriptableObject{0x1c2bc0068; asset:SpecReference{<kuid2:68787:1449:10> "Marc"}, class:GSClass{0x25b673f8: DriverCharacter}, refcount:15}
; <kuid2:68787:1449:10> : Script callstack
; <kuid2:68787:1449:10> : function $bool@DriverCharacter::NavigateToIndustry(Industry,string), line -1
; <kuid2:68787:1449:10> : function $bool@NavigateToScheduleCommand::UpdateExecute(DriverCharacter), line 136
- <NULL> : File, Line 162, ER_Exception
; <NULL> : Script callstack
; <NULL> : function $bool@NavigateToScheduleCommand::UpdateExecute(DriverCharacter), line 136

Used several different drivers, grain facilities, trains, track, etc in a separate test track to no avail.
Yesterday's Trainz22 update completed. Problem preceeded the update.

Tried in TS2018 and similar thing occurred, but with no error symbol on-screen.
Last edited:
What are you using that is 'NavigateToScheduleCommand' or ''

If I can see the script maybe I can help. I can't find the asset that references that scrip. What is it?
Neither - no schedule involved. The operation should begin at the start of session.

I use similar commands for coal loading and unloading and that works.
Okay, what command, or string of commands do you give the driver to load at the industry. It must be on some schedule if it bugs out when you load the session
At the session start:

Drive To the loading asset.
Load the grain car

That simple sequence loads coal cars at mines. I would expect the same to work for grains.
One other thing - I assume that the word GRAIN(S) is a common word for all grains
I wonder that by using the grain term instead of " wheat" I am in trouble.

After 2 days I have tried many things with one common failure. I can't waste any more time
on this. Coal works and is a major product in this route. Grain is another but produce
is at that same production level. So I will drop my quest for grain and switch to produce.

The problem is undoubtedly in my application of instructions. Since coal works it is a mystery.
Vegetable items may also work or fail. I'll alter all of the wheat fields to various produce/vegetable items.

Thanks for your attention and help.
Last edited:
Make sure the car and the industry are using the same GRAIN product. There are 21 Grain commodits list on the DL.
This is the code that is failing:

public bool UpdateExecute(DriverCharacter driver)
if (!m_data.m_industryID)
// We have no ID, likely meaning the targeted industry has been removed from
// the world. Don't emit a schedule, return true to prevent the command
// being treated as complete. This will result in an error state for the
// driver and force the player to manually fix things (which is what we want).
return true;

One suggestion is to use a long wait before you issue the command. Everything is not loaded at once when a route or session is invoked.
I tried the same scenario in TS-2019. Similar results. The common denominator is the operator.

So, please close the thread with THANKS to all who attempted to assist me!