Cannot get steam engine to move forward


New member
I am trying to help my son get his steam engine (USRA Light Pacific 1) to move forward and nothing seems to work. I've went back to basics and followed all of the steps for running a steam engine from start (, and still nothing happens.

I have tried every option on every link possible in an attempt to upload a screenshot of the settings, and I am dumbfounded that the support forum does not include any method to upload an image (and I have no link under my TrainZ login that allows me to upload a screenshot as the articles on the TrainZ site suggest should be there). Any advice would be greatly appreciated!

1. Regarding the screenshot, click on the MyTrainz Link at the top of any forum page. Then at the extreme top of the page (up near your ceiling, above the MyTrainz Logo and right next to where it says "Welcome back chadcham") is a link labeled Trainz Gallery. Click it.

Just above the top row of images is a link login. Click it and enter your forum username and password.

Click the tab Add Media to upload an image. PS: It will not appear immediately, it can take some time.

Once it does appear, move you mouse onto it and select either QuickView or Full Image. When the selected image appears right mouse click on it and select Copy Image Link.

Go back to this forum, start a post and select the Insert Image icon from the post tools icons above the text entry box. Paste the link into the URL box.

2. Regarding the uncooperative loco there are a few obvious questions (these may sound insulting but it is best to ask them to eliminate the obvious)

Are you in Driver mode?
Are you in Basic Manual Driver mode (with the speed dial on the bottom right)? Click on the driver icon on the bottom left of the screen and select the driver and loco by clicking on the eye icon above the loco name and thumbnail - depending on how many locos you have you may have to scroll up/down the list to find it. Alternatively, select any of them.

Now try the W (forward) and X (backward) keys to move the loco.

PS - if the name of the loco does not appear then it may not have been added to the Driver List in the Session Rule - so check there first. It is also possible that the loco is a "dummy" (i.e. is not driveable - I have a few of those as static locos in some of my layouts).
Last edited:
Another idea for the screenshot, some use imgur as a photo host server, and its instant. you can even get the proper BB code to past into the message in the forums.

Apparently, all engines will not move now

2. Regarding the uncooperative loco there are a few obvious questions (these may sound insulting but it is best to ask them to eliminate the obvious)

Sorry for the delay in responding back - I failed to turn email notifications for this post on so I was unaware that any post had been made. I've discovered the issue of the engine not moving is happening on every engine on TrainZ. I have uninstalled and reinstalled, and everything worked well until a certain point, and now engines will not move. I have included a screen shot from IMGUR as the other user recommended if that helps. My son has only installed assets from the download manager, but other than that nothing has changed. I have included all of the images you referred to in your reply, but I cannot see any reason that this train won't move?

Any advice would be greatly appreciated (and I have email notifications turned on this time).


OK, thanks for the screenshot, it answers a lot of questions and poses some possibilities.

From the lever controls on the bottom extreme right of the screen, you are in Advanced Driver Mode. This is a mode that I, after 20+ years, have not yet mastered.

To the right of that are three small vertical dots. Clicking the dots will cycle the Driver Mode between its 3 different states - Basic, AI and Advanced. The first click (from Advanced) will take you to AI Mode where you must enter Driver Commands. The second click will take you to Basic Mode where you can use keystrokes and the mouse to move and stop the train.

Go to Basic mode. The top dot of the three will be coloured and you will see a large control speed dial wheel to its left.

To move the train forward (this is not always the direction with the loco at the front - see instructions below) you can drag the little white arrowhead pointer in the speed dial to the left or press the W key. To move the train backwards drag the pointer to the right or press the X key. To stop the train move the pointer back to the centre (not always as easy as it sounds) or press the S key or click the black Stop hand icon.

The forward and reverse directions of the train are controlled by clicking the Circle icon on the tool bar just above the speed dial. This will swap and briefly reveal green (forward) and red (reverse) arrows above the train.

Hope this helps.
And if you do want to use the Advanced Driver Controls, you need to remember to Bail the Brakes (D key) to dump pressures from the brake cylinder. When that turns to Zero - and the Train and Engine Brakes are also Off, then the loco will move forward or in reverse as desired.
Last edited:
Definitely start with what pware says above. I don't have 2022 so can't advise on the tutorials (Learn to Drive), but if they are similar to T:ANE and TRS19 I highly recommend going through all of them. Especially in your case, the first one on "Easy Mode", Number 07 on "Realistic Mode" for Diesels, and Number 10 for "Steam". They are great challenges and fun to go through and learn. All of the other tutorials have great learning points as well!
I can reproduce this behavior using some of the built-in sessions for the KSC2 TRS22 route. The BC value does not seem to drop to 0 as it should by using the visual control panel. You can hold the "d" as mentioned above to bring it to 0 and the loco should start to move.
That is sad to hear. They had that problem clear back in T:ANE, and I thought they fixed it in SP4 there, but it sounds like it is back. Come to think, I did see something like that in TRS19 as well. I hope thy have this on their fix list!
I just tried Tutorial 07 (Realistic Mode for diesels) on Trainz Plus/TRS22 and can confirm that it works. The loco moves, accelerates, decelerates and stops using the Advanced Driver Mode controls.

EDIT: The same is true for Tutorial 10 (Steam). So all the Advanced Driver Mode controls are working.
Last edited:
Thank you for the feedback and suggestions. I initially started with Basic controls and only switched to Advanced to drill down into variables that might be producing the attributes that might have been keeping the train from moving. I have tried all of the recommendations in this thread and the engine will ramp up (audio) as though it is going to move, however it never does.

I tested several other routes including the Kickstart Country 2 (TRS22), and none of the train engines will move. All have the same behavior with all engines not moving. I used the Basic controls on all attempts to eliminate any configuration issues. I have already uninstalled and reinstalled once and the trains initially moved, but just like the first install all trains have stopped moving again. I am at a loss. We have TRS 2019 and it still works great, but I feel we have wasted $ on TRS 2022. If you have any other recommendations I will be more happy to try them!

Thank you again,
Here's what gets me: you have both the automatic brake, and the independant brake off, yet the brake cylinder still shows 65 PSI. That's enough to keep that loco from going anywhere... I have messed around with that same GP40, and I cannot get it to show that BC pressure with the brakes off. So your loco thinks the brakes are on.


Did you try moving the brake levers up and down once or twice?

your air pressure numbers should look more like this to be able to move:

Did you put the loco into F (Forward) or R (Reverse) before adding throttle? And release all Train and Engine Brakes and Dump BC pressure (D) so it shows 0 pressure?
Are the tracks actually connected to the turntable?
What happens in another scenario - say a single loco on a straight piece of track? Can you get it to move?
Have you changed any of the Driver mode keypad settings?
Have your released the Pause (P) button?
Last edited:
Once you eliminate the impossible, whatever remains, no matter how improbable, must be the truth.
S. Holmes (aka Arthur Conan Doyle)

Lets look at a possible hardware issue. Are you using a bluetooth or wireless keyboard?
Just to restate the facts as given.
Issue seen in both DCC mode and CAB mode.
After a re-install of program, trains move for a while but then stop moving but the engine sound and smoke indicates the loco is effected by the throttle settings.
Issue seen on different routes with different locos.
Some locos work normally????
Are you re-installing the game with a fresh local data folder or are you pointing to the old data folder after the re-install?
Does a database rebuild cause the locos to work for a while?
Does the stalling happen when the loco is moving or just after it has stopped or changed direction?
Does the stalling happen on any type of track configuration or just on switches, curves or straight sections?
Does flipping over to Surveyor and then back to Driver have any effect?
Does the stalling effect only trains under manual control or if you set a loco to just drive does it eventually stall as well?
Does stopping at a red signal have anything to do with triggering stalling? Dave Snow reported this behavior.