Can not register at site

your not the only one I can't either and contacting them is impossible i get 404 if i click on the contact link sounds like either they're having a problems with their email and have called in their IT and he's or she slower than anything or else they lost their IT and can't fix the problem themselves at any road they're either aware and don't care or not aware and the only thing that interested them is the bottom line.
I've a feeling the Contacts page issue is to do with a site switchover they had not too long ago. Also, check your spam/junk folder.

I have a feeling there's an internal problem going on because for about a week now I can't access the site either. Just get the 404 error.
Ahh ok, let me check that. If it's broke the chances are pretty high I had something to do with it.

Just gave that contact form a try to see if it would email us and it definitely does.

dcitrigno- I'm pretty sure you emailed us about this and i manually approved your account at that point. We also hunted down the current problem affecting registrations and such at the same time so this should no longer be an issue. It WAS an issue for a few days( fixed it late 3/17 or early 3/18) while we troubleshooted the problem but anyone that emails us at support typically will get a reponse from me. Not sure out of that whole thing you think we dont me we do.
I was having problems logging in and recieved a quick response from Kevin! Thanks again guys for the quick support.
Last edited:
May be your browser? Works fine over here and im on Firefox.
Well, here's what it looks like on my end on Chrome; it looks the same on Firefox.

I just tried on 4 browsers and 2 different PC's, all good here. I don't see any others having this issue yet either, I see that you are also not logged in. You need to be logged in.


I've noticed something strange, after getting into the site for instance today I went to redownload the freeware KCS SD60 and when I clicked on it I got the 404 message. I noticed at that time the www was gone in the address so I typed it in manually and the page showed up just fine. I'm no where near a website expert but it's a way I have found to get around the 404 manually.