.
Results 1 to 5 of 5

Thread: KUID Help

  1. #1
    Join Date
    Jun 2009
    Location
    Duna? Or was it Alaska?
    Posts
    1,174
    Blog Entries
    2
     

    Default KUID Help

    I have a problem, CM says when I try to commit a Protrainz AC4400 I cloned and repaired, but i get this error :
    Error: Unable to commit changes to asset <kuid:460023:100362> as the config file contains the wrong KUID

    here is the config:
    origin "USA"
    bogey <kuid2:113556:622220:1>
    bogey-1 <kuid2:113556:2222900:1>
    interior <kuid:113556:3000112>
    cabinsway 1
    engine 1
    name "UP 6746 - GE AC4400cw"
    mass 105890
    company "Union Pacific"
    kind "traincar"
    enginespec <kuid:52779:50002>
    enginesound <kuid:-1:42003000>
    hornsound <kuid:52779:54000>
    smoke_shade 0.3
    smoke_random 2.5
    smoke_slowlife 12
    smoke_fastlife 0.8
    smoke_height 2.3
    smoke_fastspeed 1.6
    description:
    "This is the AC4400 CW by General Electric. This engine is for heavy-haul applications. The AC4400 is powered by a 16 cylinder, turbo-charged engine that produces 4,500 hp. The traction system uses a computer-controlled inverter for each axle to regulate the AC traction motors.
    The first AC4400 was delivered to Union Pacific in 1994. Modeled for use in TrainZ by Mark Hoffman."

    mesh-table
    {
    default
    {
    mesh "ftruck.im"
    auto-create 1
    position 0,0,-0.04
    }

    shadow
    {
    mesh "shadow.im"
    position 0,0,-0.04
    }

    }

    region "United States"
    trainz-build 1.3
    category-class "AL"
    category-region-0 "US"
    category-era-0 "1990s"
    light_color 255,252,170
    asset-filename "AC44_6746"
    username "Union Pacific AC4400CW 6746"
    author "Mark Hoffman"
    organisation "Digital Roundhouse"
    contact-email "markhosf3d@directvinternet.com"
    contact-website "www.digitalroundhouse.com"
    license "This content is copyright 2002 Mark Hoffman, all rights reserved.

    Logos are the property of the copyright holders.

    This content is for personal use only. This content may not be sold, modified or redistributed in any way.

    This content is provided 'as is' and as such is not guaranteed to work on your computer. The author takes no responsibility for any damage this content may cause.

    By installing this content you agree to the provisions of this agreement."

    kuid-table
    {
    0 <kuid:52779:114>
    1 <kuid2:113556:622220:1>
    2 <kuid2:113556:2222900:1>
    3 <kuid:113556:3000112>
    4 <kuid:52779:50002>
    5 <kuid:52779:54000>
    6 <kuid:-1:42003000>
    }
    kuid <kuid:460023:100362>
    I looked over it but cant find the KUID thats wrong, can anyone help? Words in bold were added.
    Last edited by qassaquyangli; August 8th, 2012 at 02:01 AM.
    It's good to be back here...

  2. #2
    Join Date
    Nov 2006
    Location
    United Kingdom, Worcestershire
    Posts
    30,796
    Blog Entries
    22
     

    Default

    In such a circumstance, I'd advise you copy the contents of the asset folder to a folder on the desktop, revert the installed version, then use Import Content to overwrite the installed version with the modified version you have in the folder on the desktop.

    Shane

    P.S. The KUID it is referring to is at the bottom of the file.
    Shane Turner
    Technical and DirectX Advisor - Not affiliated with N3V

    My Forum -- PevSoft Tools -- Tutorial List (inc DirectX) -- My Utilities --TrainzTutorials.com

  3. #3
    Join Date
    Nov 2006
    Location
    Leyland, lancs
    Posts
    6,549
     

    Default

    sureshot's 114 kuid is not in the loco, should it be ? The one at the bottom, is that the asset kuid.

  4. #4

    Default

    Take the cloned folder out of trainz onto your desktop and then import it.

  5. #5
    Join Date
    Jun 2009
    Location
    Duna? Or was it Alaska?
    Posts
    1,174
    Blog Entries
    2
     

    Default

    I got it fixed, I just removed the mesh table since it's supposed to be in the bogey, not the loco. decided to clone the originals bogeys and darken them to make em' look better. Also CM was a bit late, after a few commits, the error didn't show anymore. But thanks anyways guys!
    It's good to be back here...

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •