.
Page 2 of 2 FirstFirst 12
Results 16 to 25 of 25

Thread: Windows 10 version 1903 - How is it working?

  1. #16
    Join Date
    Dec 2011
    Location
    United States of America, Florida and Illinois
    Posts
    768
     

    Default

    I have version 1803 and was updated on May 21st 2019. What is the difference of 1803 to 1903? They both seem to be current. I have Windows 10 Pro.

    BTW, I have no issues with the update I got on the 21st. Everything seems the same in regards to Trainz.
    If it's not broke, don't fix it.


  2. #17
    Join Date
    Nov 2008
    Location
    Crewe, Cheshire, UK
    Posts
    14,760
     

    Default

    Cumulative updates, which if you are on 1803 is what you got, is not an updated OS which is what 1903 is. 1803 expires November 12, 2019 after that it will receive no security or cumulative updates. Each build, for non business users lasts for 18 months before it's support is withdrawn.

    1809 is better than 1803 and 1903 is better again than both, plus 1903 gives you control better control over your updates for both Home and Pro.
    Malc


  3. #18
    Join Date
    Dec 2011
    Location
    United States of America, Florida and Illinois
    Posts
    768
     

    Default

    Quote Originally Posted by clam1952 View Post
    Cumulative updates, which if you are on 1803 is what you got, is not an updated OS which is what 1903 is. 1803 expires November 12, 2019 after that it will receive no security or cumulative updates. Each build, for non business users lasts for 18 months before it's support is withdrawn.

    1809 is better than 1803 and 1903 is better again than both, plus 1903 gives you control better control over your updates for both Home and Pro.
    This page supports your comments and is time sensitive for future visitors to this forum;

    https://docs.microsoft.com/en-us/win...e-information/

    This page seems to state that in June I will get 1903 in June automatically;

    https://blogs.windows.com/windowsexp...VXb6OMKfZfh.97

    So I guess I will spend tomorrow backing everything up and then move forward. Thank you for pointing this out, I obviously missed this one.
    If it's not broke, don't fix it.


  4. #19
    Join Date
    Nov 2006
    Location
    New Zealand
    Posts
    2,888
     

    Default

    Finally moved my desktop test rig over to Version 1903 and ran subsequent updates/ patches offered to update to the very latest build.
    The interim Windows Insider fixes for the USB/ internal drive issue obstinately failed to work for me, so I ended up disabling all the drives and USB peripherals except for the boot drive SSD and updated the OS on that.
    Gave the entire case and interior a thorough clean during the process, so now I feel supremely smug and satisfied.
    Took a while as I have been away at conferences and rather busy with a couple of projects.
    Since I had already upgraded my laptop to 1903, there wasn't the incentive of curiosity about what goodies the new version would bring, so the task was relegated to a lower priority and until spare time allowed.
    That said - I love it - and highly recommend this new build of Windows 10 to anyone still on 1803/ 1809 etc.

  5. #20
    Join Date
    Mar 2008
    Location
    United States of America, NJ, Ocean City
    Posts
    1,718
     

    Default

    What USB problem? I have 1903 and do not seem to have a problem with the USB ports.
    TS06, TS09, TS10, TS12, New Era SP3

  6. #21
    Join Date
    Nov 2006
    Location
    New Zealand
    Posts
    2,888
     

    Default

    Old, long story. In March, some of the Windows Insider Build updates failed when users had multiple external and internal disk drives and USB peripherals.
    Now fixed by Microsoft, so you were spared this anguish.

  7. #22
    Join Date
    Nov 2006
    Location
    Canberra, ACT, Australia
    Posts
    7,877
    Blog Entries
    30
     

    Default

    I installed 1903 a week ago and it works fine. Only issue I have had is occasional dropouts in bluetooth audio. No idea if this is an Windows issue, hardware or signal interference.

    Paul


  8. #23
    Join Date
    Nov 2008
    Location
    Crewe, Cheshire, UK
    Posts
    14,760
     

    Default

    Quote Originally Posted by pcas1986 View Post
    I installed 1903 a week ago and it works fine. Only issue I have had is occasional dropouts in bluetooth audio. No idea if this is an Windows issue, hardware or signal interference.
    Probably this known problem with 1903 https://www.tenforums.com/windows-10...on-1903-a.html

    Unable to discover or connect to Bluetooth devices

    Microsoft has identified compatibility issues with some versions of Realtek and Qualcomm Bluetooth radio drivers.
    Malc


  9. #24
    Join Date
    Nov 2006
    Location
    Canberra, ACT, Australia
    Posts
    7,877
    Blog Entries
    30
     

    Default

    Quote Originally Posted by clam1952 View Post
    Probably this known problem with 1903 https://www.tenforums.com/windows-10...on-1903-a.html
    I saw that mentioned somewhere else but those problems don't match my experience. The bluetooth connection works as before but there are occasional sub second dropouts that interfere with the audio. TBH its so intermittent that I haven't bothered investigating further.

    Paul


  10. #25
    Join Date
    Nov 2006
    Location
    United Kingdom, Cheshire,
    Posts
    1,014
     

    Default

    Working fine here since last week.

    Only problem was that I had to remake the macros for my old, but briliant, MS Sidewinder keyboard, but, every major update to WIN 10 has done that so it is expected.
    Easily solved by using MS Mouse and Keyboard app.

    I've yet to try the new Edge, having had past issues with MS browsers I need convincing first
    Graham,

    A member of TCWW

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •