Strange Content Errors


Bump on a log
I have a feeling this is going to turn into a book if I don't control myself so hopefully I can keep it as short as possible...

Let's jump back to the beginning of June this year. After about a month and a half of hearing terrible things about SP1 I finally got gutsy and decided to download the service pack and hotfix 1. Everything ran much more smoothly than I was expecting and fixing my favorite faulty content only took a few hours, which frankly was much shorter than I thought it would take. Unfortunately only a week later our computer's motherboard decided to die on us. Finding a new one that fit all of the components we already owned was troublesome but we finally managed to get one on Ebay. While looking on Newegg the day before however, there was an amazing deal on a combo they had for a better computer than we already owned. It was too good to pass up so we ordered it and by the second week of July everything was set up.

Next came the process of copying everything from our old hard drive to the new one. First was all of the vital stuff such as the operating system, antivirus software, and the like. Next we decided to install Simcity to see how it ran. (previously it could only be played on the lowest settings because our old motherboard didn't support the latest DirectX which contained the shader model the game required; but that's a story for another day) It ran perfectly. So perfect in fact that even if shaders were present before it wouldn't have ran so well. I was ecstatic to try out Trainz but of course we had two, one week vacations planned back to back. So I had to wait.

Now we get to yesterday. Because of all of the content I have installed plus some old JR orders that the emails mysteriously disappeared from, we decided that a clean install wouldn't be the best choice of action. The only other choice was to copy all of the folders over from the old hard drive and hope that everything made it safely. It worked. I messed around for about an hour to see how the game ran and if the content was intact then went to bed.

Finally onto my predicament. Today I got around to installing hotfix 3. After that was done I started up the game and loaded the route I'm currently working on. Like I usually do before I quit working, I plopped a train down to ride along some of the new sections I finished. First was a NS SD60; everything was as it should be. Next came a SD40-2. This is where the problems started to roll in. Despite the name not showing up red in surveyor it couldn't be placed, which wasn't the case the previous day. I got curious, quit surveyor and went into railyard. Now all of the JR content I owned was invisible even though nothing is faulty. (I figured that out by looking in CMP) I tried an extended database repair which appeared to work until I noticed none of the units had running numbers. Confused I redownloaded all of the SP1 updates from the website and overwrote them. The strange thing was it wouldn't let me commit any of the assets. I kept getting an error stating that they were unable to be read. I reverted them and conducted another database repair, then opened trainz again. Now none of the builtin stuff and a few other engines were working. Strangely though the Santa Fe GP60M and B unit showed up in railyard and had running numbers. Extremely confused by this point I deleted the SP1 updates entirely assuming this was the problem and reinstalled them. Yet it still wouldn't let me commit them; now it gave me a error claiming that multiple of those assets with the same kuid existed, which didn't make any sense at all. After another revert and database repair everything was still the same. Of course there was a simple solution, delete the install of TS12 on the new hard drive and copy the old one again. The problem with that was (I feel ridiculously stupid for doing this) I accidentally installed hotfix 3 onto the old hard drive before the new one since it is still plugged in. Now I can't make a "clean" install.

I spent all of today trying to get the content to work but to no avail. Posting this on the forum is my only option left.

Currently these are the assets that aren't working:
-all builtin JR rolling stock and engines (besides the GP60M & B)
-BNSF C44-9W and SD70MAC
-NS C40-8, low hood SD40-2, SD80MAC, and SW1500

Like mentioned above, none of them show up faulty in CMP and it appears that only JR content is at stake here. While I attempted to put the pieces together the only thing I could figure these have in common is that they are fairly new and the fact that they all use JR enginespecs, etc... (by new I mean being released in or after TS12 was) I'm not sure this has anything to do with it but so far I'm not liking hotfix 3.

As you can imagine I am very, very confused at the moment and any help would be massively appreciated. If it is needed I will gladly take pictures/screenshots to further clarify things.
Also, sorry to make all of you read this wall of text. I had to mention everything...
That appeared to do the trick except for one thing. The running numbers still don't exist even though all of the engines and rolling stock appear.

I'm not entirely certain but I'm pretty sure this has to do with the "exists in multiple locations" error. Still don't know how to fix that.

Thanks for solving one piece of the puzzle though.