Lead locomotive missing attachments in session, when I move to another train

In case you're wondering, I still haven't solved this problem. I reduced the mesh by 10,000 polygons, but that didn't do anything. In "Preview Asset," the problem only seems to occur after manually selecting "LOD Distance" and manually going from 10,000m all the way to 0, then switching back to "Auto." Here's what it says about the locomotive with everything loaded up:

triangle count: 189,061
animation count: 5
bone count: 19
Mesh Object count: 5
attachment points: 27
attachments visible: 27
Renderable count: 16

With the bogies and pantographs not loaded in:

triangle count: 33,549
animation count: 1
bone count: 3
Mesh Object count: 5
attachment points: 27
attachments visible: 27
Renderable count: 2

I'd quite like an answer for what's causing this. There are other trains I'd like to make, but it's pointless if the game randomly decides not to load the bogies or pantographs for some arbitrary reason.
Other possible (elimination) tests:
-use another panto temp
-use another bogey temp
-remove your highest lod temp (adjust lm)

Tested here many times, the .lm.txt file does not exact what you write in there
FI: lets say you have a loco with, 2 bogey, 2 wipers, 2 fans
from these 6 attachments only 1 gets removed with the "attachmentCutoff = ?,?"
thereby for me impossible to get below 500 poly often.

Passengers only go at around 1km, no idea about the driver, the viewer don't show it
which means the viewer is not exact like the game.

Then the effect of cache in a session, there is no guarantee, if you change anything on your content
then play the session again all new things are implemented,
Which means, its best to completely remove it from session then place again after changes.
hope you find it
greetings GM
I replaced the bogies and pantographs with the ones for VBG's AEM-7 and they worked, so the issue is apparently with the bogies and pantographs, but I don't know why. Neither the bogies, nor the pantograph trigger any errors, so I don't no why they wouldn't work.
Good job janathan,
Now you know, the base loco is probably ok (most work is in that one)
next step is compare your panto and bogey, with the current working replacements
again a step by step elimination
The only difference I can see is my bogies having more polygons, but when I edited them to only load the third lod mesh, which has far fewer polygons than most bogies I've made, the issue still happens. I even tried swapping the bogies for ones that I made in the past, and the glitch still happens. The only other difference is that the bogies are made with .fbx files (verses the ones from VBG), but I don't know why that would be a problem, since the other bogies and pantographs I've made were also using .fbx files, but work fine, when not attached to the AEM-7. It only seems to work with very old assets. We're talkin' build 2.9.
Okay, so I've discovered something weird. Changing the mesh-table-lod-transition-distances from "1000" (which is the number I chose for all of my assets) to 200000000 seams to have fixed the problem for some reason?:confused: Odder still, if you set it to 200000000000, it automatically gets set to -187000000000 and the object will be unloaded from the start.
The "mesh-table-lod-transition-distances" tag (float array) determines the distances in meters at which each mesh-table LOD level ends (from the wiki)

Don't think those crazy high numbers should be used
if that
mesh-table-lod-transition-distances don't work try a simple .lm file
See, that's one thing I never understood. Why is it that even if I'm using a .lm file, I still need the "mesh-table-lod-transition-distances" tag? Don't they both do the same thing, but in different ways? Even if I use an .lm file, it still throws an error saying that that tag is required for build 4.6 and up.
Never used mesh-table-lod-transition-distances, for trains (yet) I do use it for splines
but think its either that or .lm.txt, both tell Trainz what LOD to use at which distance
Using both at same time can lead to contradictions, so just choose 1 system
Okay, it looks like if you use a .lm file, you can leave "mesh-table-lod-transition-distances" blank. It still needs to be there, but no data has to be entered. When leaving it blank, the problem seems to be fixed.
Good job !
Never give up is the key, there is always a solution.
hope you can finish it now :)