I'm going to be in a lot of trouble! RE: update problem


New member
Please can someone tell me what i've done wrong...?

I successfully installed an update patch last night taking my son's trainz12 build from 46957 to 47059.
Feeling a bit gung-ho, I thought I'd carry on updating it until I'd achieved the most up to date I could make
it, as he loves train simulators and spends alot of time on it. Also, I'd recently made a couple of purchases
in the Steam shop (in error thinking I was buying railworks products - which are much easier for me to cope with!)
and I haven't been able to get them running on trainz 12, so I thought maybe it was time to pay attention and

I've recently upgraded the computer and it's running windows 8 and has 8GB ram on board.

So, my problem is this, when I tried to open the Trainz12 programme, I just got a small bar accross the top of the screen, with a series of numbers running, which go up to about 200 and start again.

I tried getting rid of the latest patches files which didn't help matters, and I also restarted the computer.

My son gets out of school in about an hour. If anyone can tell me how to put this right, I'd be very grateful!
I confess, I don't really know what I'm doing. I have very little knowledge, but, I really need to sort this out as soon
as possible, or I'm going to be in a lot of trouble! :'(

Many thanks!
I will see if I can help...

It sounds like the resolution settings for your version may be incorrect. Click the Options button on the Launcher and click the Display Options tab (or similar), then make sure that the resolution shown matches the monitor's resolution, and that Fullscreen is ticked.

Also be aware that Trainz must be run as administrator - I have a tutorial for that at http://trainz.shaneturner.co.uk/tutorials/?page=running-as-administrator.


If that does not fix it, I have a wealth of technical knowledge where Trainz is concerned.


P.S. If you want to check whether it's up-to-date, check the 5-digit number on the Launcher - for most versions, it's 49922, although the Steam version is 53xxx.
I'd just be brave and have a few hours in the pub, pain is relieved by being leathered. You haven't got enough time to get yourself out of this one.
The 200 numbers I guess is fraps running, ignore.
You can't "get rid" of patches.
Have you used the launcher icon on screen, then select start, then any saved session. See if it runs, if so fine. If not revert to my first suggestion and be quick he'll be home any time.
ok, this is cool....
The screen options were running at 1024 x 768, but my computer was set to 1366x768, and the full screen wasn't ticked either...
So, now I've done that, I can get back into the programme (my life is spared! - thanks Shane!)
I don't know if I'm (my son) running it as an administrator, so I will have a look at that tutorial. And my build is still out of date, so maybe if you have
a tutorial for that I'd best keep learning and watch that one too! Thanks so much for helping me out here.
Actually, I can advise on that, but will need to verify what the 5-digit number is your Launcher (and yes, I do have a patching tutorial - it's in the thread that can be found in my signature).

thanks Shane, the number is 47059 - do I have to do updates in the order they were released, or is there a one patch remedy?
They will need to be done in order, but there is an automatic patcher available that may help.

To use this, click Options on the Launcher, then click Planet Auran. Check that your username and password are entered then click the Patch Trainz button (if available). You will then be able to click Run Patcher.

Once the patcher appears, check that the folder shown at the top matches the folder where TS12 is installed, then click Apply Patch.

It will take approx 30-45 minutes to install the patches.

Best backup - open Windows Explorer, browse to wherever you have it installed, EG C:\Program Files\N3V\TS12. Select the TS12 folder, copy the entire thing to a backup folder. If the patch screws it up you can delete the C:\Program Files\N3V\TS12 folder and copy the backup in so you don't have to start over. Each stage in the patching process make a new backup folder.
Shane, you are a genius!!!! I feel as though someone has waved a magic wand in my direction! You have no idea how much trouble and distress you have saved me.
The automatic patcher is busy, so I will let it do it's thing and report back.
Meanwhile, I am very grateful for your help this afternoon! :)
If it throws up an error, let me know ASAP. Errors can be identified by red text followed by the words Patching Aborted.

..so far, so good. It's happily (fingers crossed) patching from 47059 to 48249. Im off to collect my train enthusiast from school and will leave it doing it's patching...
If I get back and there's any red words I will let you know in an instant! :)
thanks Shane.
No problem - by the time you get back it should be up to 49922, at which point you should have a 'Patching Completed' message and a Close button to click.

It's done it!!!!!! I'm on version 49922! Wow. And the aerotrain which I bought him 6 months ago has appeared as if by magic!
You have no idea how long and hard I tried to install that. I'm not sure that the Duchess has arrived... I will get Fab (son) to do a
check on the trains that have turned up (he will know in an instant).
I have 1,303 content updates required, I don't suppose there's something easy I can do there to get that up to date whilst I'm on such
a successful mission is there? :D
The is actually. Click the Content Updates button on the main menu, then click the Download All button. Once the screen appears, click the Download All button that appears, then click the _ button (minimise) and let it complete (which will take a while unless you have a First Class Ticket). Once you have minimised the window, click the Return to Main Menu button - to check on progress there will be a button at the top of the screen called Asset Download that you can click.

um...Hi again Shane! I've gone onto the main menu and clicked on Content, and this takes me to Content Manager V3.6. Lots of 'assets' (is that the right word?) turn up in a long list, but there's no button (that I can see) that says download all... Am I in the right place?
And yes, I do have a first class ticket! I decided this morning that I needed to take action and get some sort of a grip on the Trainz situation ...a new year's resolution! So, I have speed on my side for now.
Might as well take some time to learn content manager, especially the filters;


You definitely don't want to download everything since it's unlikely a single hard drive could hold it all, and you'll never use 90% of it. For example I'm a Yank who likes US trains, late steam and first generation diesels, so I wouldn't have any use for all the 7 plank wagons, British steam locos, or even American modern stuff like SD70s and intermodal cars, so why download them?
Thanks Sniper, and Shane... I made an elementary error. I got a bit mixed up with 'content update' and 'content'. (And there's a big difference!) But I'm back on track and the content update is now underway (its very slow though, so without the 1st class ticket I think it may well have been the new years resolution that would have lasted a whole year to fulfil!).
As the end of the content update, will there be any more trains available? ...Or is content update to do with something else?