Healsville 2019 missing VR files? Problem Solved: how to repair route issues.


RR Mod Maker
OK i have a set of files missing from Healsville which i paid for when i bought 2019 Trainz, why are they listed as payware and missing?

<kuid:1854:53174> VR 2pos sem FT Bracket Timber T1 LHS
<kuid:1854:53181> VR 2pos sem FT Bracket Timber T1 RHS
<kuid2:103475:28029:2> VR 30ft Coal Stage
<kuid:1854:53457> VR Timber Bridge 6' DT Pier
<kuid:103475:28049> VR 30ft Coal Stage - 2
<kuid:103475:28095> VR 70ft 1rd BG Hand Operated Turntable
<kuid2:103475:28031:1> VR Platform 160m x 10m 1t
<kuid:1854:53455> VR Olinda Creek Timber Bridge
<kuid2:103475:28035:1> VR Platform 60m x 10m 1t
<kuid2:103475:28033:1> VR Platform Coldstream
<kuid2:103475:28040:2> VR Platform Healesville
<kuid2:103475:28036:2> VR Platform Lilydale Island
<kuid2:103475:28034:1> VR Platform Yering
<kuid:103475:23011> VR point indicator DT
<kuid:103475:23012> VR point indicator Slip
<kuid:103475:28044> VR Stockyard Cattle Race - 1
<kuid:1854:53458> VR Timber Bridge 13' DT Pier
<kuid:1854:53456> VR Timber Bridge 15ft Doubletrack Deck
<kuid:1854:53459> VR Timber Bridge DT 80lb Ballast Fill
<kuid:1854:53434> VR Timber Bridge Yering Humped
<kuid:103475:28192> VR Unballasted 80lb Track 130m
<kuid:103475:203> VR V class Compound - Dead

thanks for any help on this i have been able to download all of the rest of the files
They`re listed as Payware because you paid for them when you bought Trainz 2019.

I don`t know why they`re listed as Missing, but it might have something to do with the sudden rash of complaints about large numbers of assets suddenly showing as out-of-date. Have you downloaded any updated assets today? If not, do you suddenly have a lot of them showing as out of date or obsolete when they didn`t yesterday?

Edit: have a look at this: VR Healesville - 1913-1920 TRS19 I don`t know if it relevant, but it certainly concerns the same route.
Last edited:
Hi and thanks i already saw that thread and posted there, it looks like there may be a new DLC version to download? not sure. I am having the same issue with all of the other routes that came with 2019, stuff showing as payware and not downloaded, or faulty. I am sad to see this continues to happen with Trainz which i enjoy but sure takes work to get things sorted out after being away for a w hile. Many of the red entries i cant do anyting to, cant re download payware as i have heard you should be able to no entry in the selections in the Content manager screen shows up to do that. I am be stuck removing 2019 again :) hope not.
thanks for replying. still is a mystery why those files dont show i am trying a data base rebuild.
and now i cant log into the store to check as it wont accept my credentials. I think giving up may be more and more attractive. :)

Click on the Content Store button of your Launcher window, if Trainz19 has one. I`ve got Trainz22PE, but I don`t know when that button first appeared. That`s how people with Trainz22 get their packaged content.
I tried to get into the store but it refuses to accept my log in ..and i was just able to purchase a First Class Ticket a day ago. sigh thanks for the reply.
i can get into the store now but the store wantrs to resell all of the default routes to me again. not going to do that sorry Trainz. ah well thanks guys. Trainz better clean house soon or I am out of here.
The obvious question to ask here is have you changed your login details?

Or have you set your login details in TRS19? Even if you think you have it is still worthwhile opening the Trainz Setting window from the launcher, click MyLogin and re-enter your username and password then wait for the confirmation. Close the Launcher and try the Content Store again.
it looks like there may be a new DLC version to download? not sure.
I have both routes, only ever loaded up Healesville 1910's to see what the map looked like! Never driven the routes at all.

Healesville 1910's
VR Healesville 1913-1920 TRS19TRS22

One of them I purchased for TRS19, because I required it for a route that I needed to get working ;) I just can't remember which one and one came with TRS22 when I purchased it, that's why I have 2 versions of the route. However, I'm not 100% sure if both routes are identical or not!

I would suggest uninstalling the route, restart Trainz, reinstalling the route 'hopefully error free', rebuild Trainz database and that should resolve the missing assets. With a little luck!!
Hello all thanks for replying and the crisis is over and all my routes how show working or with the small amber icon for some issues. The solution was as some have suggested.

First a full deep data base repair which is done by holding down the control Key on PC keyboard while choosing data base repair on the Content manger. Then after that there were were still six routes showing the red icon. On the advice of the admirable Administrator and Leader of TrainzItalia Forum, Carlo, i reverted all of the red text assets and all returned to normal and all of the routes now show working. That was a not fun day of work to get it all up and running. The error about logging into the store was noted and a notice was on the site ...i didnt have to change my password which I have used here for many years and it works fine now. so all is well thanks again for the many replies and maybe my topic may help others with similar issues. I had not thought or realized that many of the routes depend on other routes for the assets so they all need to be active in the end to work well and be happy. I am sorry for any blunt words I may have used about Traiinz i was a bit frustrated, and apologize. Trainz has unique features and potential among all of the railroad sims, and I will continue to enjoy working on routes and making assets for it. thanks again. This is a very nice and supportive Community