Faulty Cab Mech


Active member
I have several Dash 8 locos installed in TANE, TRS19 and TRS22 and I have become increasing frustrated by the faulty cab mech display because the TANE version works perfectly.

The Locos are: -
<kuid2:45324:100210:1> BNSF C40-8W H2
<kuid2:45324:100202:1> ATSF C40-8W
<kuid2:45324:100326:1> ATSF C44-9W
<kuid2:45324:100213:1> BNSF C40-8W H3
<kuid2:45324:100220:2> CN C40-8W
<kuid2:45324:91152:3> CN CW40-8 cab shell
<kuid2:473973:100763:3> GE ES44AC CP 8760-8961
<kuid2:45324:100271:1> SP Dash 9-44CW
<kuid:348207:100859> UP C44-9W Ex-SP Patched

The cab Mech is Built In and is <kuid2:45324:90310:6> GE wide cab mechanism t1 In TRS19 and <kuid2:45324:90310:7> GE wide cab mechanism t1 in TRS22.

Today I have tried an experiment, I took the original TRS12 release of <kuid2:45324:90310:2> GE wide cab mechanism t1 in TANE and I changed it to <kuid2:45324:90310:8> GE wide cab mechanism t1
I then made a cdp and copied it to TRS19 and TRS22 so it would obsolete the built in and faulty versions.

Now all the locos work perfectly, I have previously raised a ticket for this and again today raised a bug report because I cannot see any reason for the kuid updates that break what is a working asset in at least 4 successive versions of the Trainz franchise.

I wonder if anyone from N3V can explain this for me and I wonder if they can fix the problem for all those users who cannot make the changes for their own use?
Hello, Can you explain a little about what the problem is? I don't seem to show any faults in the built-in items.

I do have an update to apply to them, but it is to fix a minor display problem not a game breaking fault.
Hello Justin,

I have previously submitted photos with a ticket to N3V and I also reported the issue to the JR web support. the issue has changed between the fault that has been present in TRS19 and that which can be seen in TRS22.

In both versions the green dots around the speedo flicker and disappear for long periods of time, in TRS19 the target speed in the centre of the speedo flickers and parts of the digits do not display, in TRS22 the target speed is permanently stuck on 76. The yellow speed indication dots in TRS19 are flickering on and off constantly and in TRS22 they do not appear at all at any speed. The length counter is not operational in TRS19 and in TRS22 it is fixed at 5400 feet approximately.

I cannot remember if I included the images when I reported this to the JR site but you were quoted as saying you thought the layers in the speedo were not correct but that there were no plans to fix it at that time. It is clear to me that no fix was necessary all that was needed was to reissue the TRS12 version :2 already available on the JR wab site but the :6 and :7 being built in make it difficult to change that. I strongly suggest you check out the :2 in both TRS19 and 22 because I cannot fault the operation and the graphics after my edit.

I am happy to email you the edited version of the file if you wish.
Yes that is the issue I am aware of with the dots. something about the new materials they are trying to use on the modified versions in 19-22.
The other issue is the computer where the length counter information is shared and the panel where it is set stopped and reset. there was one Beta of TRS22 that made it work but thereafter it stopped working again! That also works correctly with my edited :2 version of the file.
<kuid2:45324:90310:7> GE wide cab mechanism t1 doesn't show as faulty in my Trainz Plus latest build. By faulty, do you mean it doesn't work correctly in game?

Just to add, I tried the two locos I have that used this cab and got pretty much the same behavior as described. One worked slightly better than the other by showing the speed dots correctly but the other speed indicator was pretty much as described. Odd that the same cab behaves it different ways in different locos.
Last edited:
In TRs19 all builds it displays with faults and the length counter does not work in game, that is <kuid2:45324:90310:6>.
It TRS22 all Retail release Betas it displays with faults and in all except one Beta the length counter only displays a fixed length, that is

There is no error showing in CM both the built in assets show they are good.

I can confirm I have three separate installs of TRS19 on two PCs and a laptop. On one PC it is SP4 and on the other it is SP5 plus hot fix. I have two installs of TRS22 one on each PC and they have been regularly updated to the latest Retail Beta.

On every install the errors as explained are present and the same so I can say that the issues are 100% repeatable. My regular test for this issue has been the JR SP locomotive but I also have a test session in each install in KS County with all the affected locos including the Payware CN loco and they all display the errors. I made the
<kuid2:45324:90310:2> into <kuid2:45324:90310:8> so it would make the built in version obsolete and cab mech worked and displayed correctly in game in both TRS19 and 22.

I spent a couple hours looking over the built-in cab mech and the CN CW40-8 asset. The cab performs without issues. Yes the minor green indicators on the speedometer are flickering at times as discussed above and this is a known problem, but the other problems you described were not present. the Length counter, accelerometer and number displays were all readable and displaying the correct information. <kuid2:45324:90310:7> in 117092

here are some images



As I indicated before, There may be a fix for those indicator LEDs at some point but there doesn't appear to be anything else to really fix. All seems to be usable and in working condition.
I have deleted my edited cab mech in both TRS19 and 22 and allowed the built in version to restore. The error is back in both versions of Trainz, unfortunately my account has stopped letting me post images from my drop box here but be assured the error is back with the length indicator locked at 5400 feet approximately and the accelerometer locked at 76. This is now the same for both TRS19 and TRS22. When I restore the version downloaded from the JR website and edit the kuid to make it obsolete the built in versions the cab works exactly as it should and displays correctly.

This would be an easy fix if N3V had not made the dependency a built in asset and because it is used on both Built in locomotives as well as locomotives bought from JR site it breaks all the locomotives to some degree and as the buyers surely we should be able to select the dependencies for assets that are NOT built in!
wreeder Odd that the same cab behaves it different ways in different locos.[/QUOTE said:
Not really the built in CN loco is different from those sold by JR directly and it's behaviour has always presented slightly differently to the others but for me always faulty to some degree however by reverting to the cab mech on the JR site the problem is fixed even in the CN locomotive. I am astounded that the Author is not able to get the same faults as me unless there are significant differences in the Plus Beta releases. I have seen this in all versions of TRS19 and also since the early release of TRS22 but as a retail customer my updates do lag slightly behind the Subscription users.

I have sent JR an email with the images of the fault I see and the fix I achieved.
Why continue to use the confusing word "faulty" when you know this is a commonly known state in CM? The items are not faulty in CM. This can be confusing to others. :hehe:

Let's clear up some things for anyone reading.
wreeder's video link shows the cab operating as it should with the small visual glitch that some indicator LEDs flicker. The flickering LED is known. This is not likely to get any kind of rush fix, probably a DLS update. It does not break functionality or effect gameplay.

The difference in the cab mech on the JR site and the one built-in is that the built-ins to 19-22 are updated with pbr textures (to little end really imo) and therefore upversioned. I do not remember doing this myself but then again that would have been in 2018, so I may not even have the source to change the distance of the LEDs. But what is perhaps most important is that this is NOT the issue DennR describes in this thread.

@DennR I am not surprised that using the old version and changing it to obsolete the new one works fine, but this does not help identify a problem. It may be a good fix for what you see, but I don't think it should be something everyone does or tries to do. After looking at your email what I see is that the textures are not being swapped on the digits, that's why the numbers are 54321. That is just how the objects are designed and what they look like without the script running. The speedometer texture as well - "76 54321" - you are just seeing the digit slots with no data in them.

Why this happens I could only guess - script/trainz build compatibility mode? that may cause what you see.
Last edited:
Thank for all you time and effort, I am unable to help with identifying the problem. I did check the scripts used and they are the same version for all updates of the cab mech so if indeed it is the script not running then it must be in the built in updates where it is failing to start. My limited skill sets mean that I am at the limit of what has happened but at least I can use a fully working version in all the JR locomotives I have written sessions around. Thanks again and here is hoping that the fix come eventually.