Driver Setup rule ignored when Driver launched


Well-known member
TRS22 PE, Build 123801

In Surveyor mode, I enter a schedule in the Driver Setup rule for a train on a large route. Interlocking Towers are used to establish clear paths for trains. For testing, there is the only one train in the session under AI control. Here is the Driver Setup editor showing the train schedule:

Note that I have unchecked the 2 options 1) Remove all existing Drivers first and 2) Generate new Drivers for empty trains.

Having saved the session edits, I launch Driver mode. Driver opens in Pause despite my having unchecked the Pause option in the Tools Menu. The train set up in Surveyor with a schedule for AI Driver 'Alberto' is without a schedule in Driver and Alberto has been replaced by 'Scott'.


Does anyone know why the Driver Setup configuration is being ignored?
Does anyone know why the Driver Setup configuration is being ignored?
Yes, the driver has blonde hair!

All female drivers in trainz, especially AI are too dumb to even move. That's why I prefer to use JR Ryan, Charlie and other male drivers 'they just get the job done' ;)
Have you tried an exit from the game after your save? Exit and relaunch the route and session then try driver mode. I have found some things do not register straight away when going from surveyor to driver.
stagecoach, yes I've tried launching the session directly to Driver mode from the TRS22 Launcher. There is no difference to the problem: the Driver Setup rule is ignored.

big_b, I take your comment as a humorous one. If otherwise, could you elaborate?
I know this does not fix the problem, but...
I create sessions, and this rule has become very unstable. Driver names are changed and others come and go. The behavior transcends logic for me. Try deleting the rule. Then, with the new one, remove all drivers, uncheck all boxes, and save. Open again and start over. The box options do not necessarily process in the order on the screen.
I've had exactly the same problem - driver setup (including command library) not working, appointed drivers not appearing - but in plain TRS22. My procedure always worked fine in previous versions of Trainz so it must be a fault associated with TRS22. I just assumed it was the most likely cause - that of losing my marbles.
Thank you, pitkin, for your suggestion. I deleted and re-instated the Driver Setup rule and this cleared my problem : the AI driver and his schedule stipulated in the Driver Setup rule is allocated to the target train in Driver mode. Curiously the driver icon in Driver mode does not match the icon in Driver Setup. As you say, the rule is unstable, and so the problem is likely to re-appear when I have 10 or more AI schedules entered into Driver Setup. Deleting and re-instating Driver Setup will then be a very time-consuming and "marbles-losing" exercise.

Is there an alternative to the Driver Setup rule that performs with more stability?
Driver icon not matching the name is fixable, sort of. Use 2d images instead of the monstrous and weird 3d drivers. The images of Alberto and some of the others are correct. Adair and Alberto are no longer blonde gals at least the last time I looked!