Delete Missing Assets


Active member
I have created a little nightmare for myself.
I came across a small route of Garsdale which I wished to add to the end of my work in progress route, it merged ok.
I prepared the Garsdale route before merging by changing track to match the one on my route, also removed a mass of scenery such as vegetation building etc.,
I do create cdp's of the route and session that I am working on at the end of every day.
In my wisdom I also set out to reduce the number of boards/ground tiles with the aim of reducing the file size.
All sweet!
Then for the route and session I ran commands "Delete missing assets" and "Compact route"
The route was ok however the Session was now missing or had displaced rolling stock but all drivers and commands remained.
Those drivers emanating from portals were intact, only those drivers associated with consists placed in the route were missing/relocated
Not a major issue as I have a physical record in a spread sheet of the composition of the consists both in the portals and on the route.
Lots of work to carry out to recover however not insurmountable.
Proceeded to add some mineral (coal) consists, three of them on the track.
The Driver commands were there however of course the command "couple to" needed to be adjusted to reflect the new added rolling stock, not an issue however time consuming.
The first scheduled driver arrived at its destination and this is what I observed, see image below,

- As observed in Session edit


- as observed is Drive session, please ignore the wagons as they are meant to be there.
What I have not tried yet is deleting the Coal Staithes hence the track, will do this as a last resort


- as observed is drive session
There were lots of other remnant rolling stock items to observe however these were able to be deleted in Edit Session, this was the exception.
Are there any suggestion regarding how to delete.


So the actions not to undergo "Delete missing assets" when in Edit session.
I ran commands "Delete missing assets" and "Compact route"

I suspect that the "Compact Route" is the cause of your problem. I have never used it because of an old warning from N3V (or was it Auran back when it first appeared?) that this function is only to be used for extreme situations and then could have unpredictable results. I have made several large merges over the years and have never felt the need to use it. Your experience may be a case study in reasons not to.

My advice is to go back to your pre-merge backups and repeat your procedure except for the "Compact Route".
Unfortunately I neglected to change the name before backing up so it was overwritten that evening.
I will be able to reconstruct the missing session rolling stock but my issue is how to delete the remnants as illustrated.
I deleted the asset where the items were attached and they disappeared.
Just a lengthy process to restore some schedules now.