.
Results 1 to 4 of 4

Thread: Problems in saving and resuming session / route - save failure

  1. #1
    Join Date
    May 2011
    Location
    Wisbech, Cambridgeshire, United Kingdom
    Posts
    275
    Blog Entries
    3
     

    Default Problems in saving and resuming session / route - save failure

    Hello all. I'm having problems with my Trainz 2009 when trying to save a created session / route. As far as the save function on the game is, this works as expected. but when I exit off the game and then restart it a while later, my created session and route has disappeared altogether from the routes list, I'm suspecting that the game itself is deleting the saved route file when the game is resumed. All other aspects of the game are running 100% on my new computer - Windows 7 Home Premium edition on a 'Zoostorm PC'. The PC more than exceeds all game specifications on my TRS2009, as when the game was first installed all the games specs passed with everyone coming up as green ticks - no errors, no warnings come up.

    Any suggestions as to why my game is unable to save new user routes? No issues with the game running, or any issues with my pc as it exceeds game specs. I'm stumped as to why my game is failing to save a session and resume it. Many thanks if anyone can come up with a workable solution.

    I never had any save failure issues with my old Windows XP computer from this game, yet I do seem to have save fail/unknown deletion on my new Windows 7.

  2. #2
    Join Date
    Nov 2006
    Location
    Leyland, lancs
    Posts
    6,549
     

    Default

    Are you running as administrator?
    Have a look at this link.

    http://forums.auran.com/trainz/entry...nning-as-admin
    Last edited by fran1; June 25th, 2012 at 04:11 PM.

  3. #3
    Join Date
    May 2011
    Location
    Wisbech, Cambridgeshire, United Kingdom
    Posts
    275
    Blog Entries
    3
     

    Default

    Many thanks for the solution. Fingers crossed this solution will fix my save fail problem

    With any luck my game won't now keep being silly with me and deleting any routes i shall save for future train crashes. lol. Never gave much thought until yesterday as whether my new zoostorm PC would even run this game as it says XP / Vista on the game box. From now on I'll have to remember to right-click the mouse on the trainz icon and run the game through the administrator option that appears, and not run the game via the usual way.
    Last edited by fen_tiger; June 25th, 2012 at 04:38 PM.

  4. #4
    Join Date
    Oct 2010
    Location
    United Kingdom, West Yorks, Leeds
    Posts
    501
     

    Default

    No need to do that every time - R-click on your desktop icon, click "Properties", Compatability tab and tick the check box at the bottom "Run as Administrator". This is a permanent fix.

    Some recommend going into your Trainz folder in Windows Explorer and doing the above to every .exe im the main and bin folders, especially the CMP (Content Manager ones). I have done this myself, and it certainly doesn't do any harm.

    And once it's done, it's done.

    Ken

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •