.
Results 1 to 15 of 15

Thread: TRS2006:Can you reposition camera using Map View?

  1. #1
    Join Date
    Nov 2006
    Location
    United States of America, Tennessee, Cookeville
    Posts
    3,348
     

    Default TRS2006...any version...

    I'm using '06 build 3092.

    The mini-map, is only used in Surveyor Mode. In Driver Mode, it's called Map View...a full page map.

    Until recently, I was able to "land" anywhere on the route from Map View.

    Now, the view snaps-back to the train I was on...unless I snap-to another train.

    I have noticed several changes in the last three months.

    Content Manager Plus no longer shows the "Type" filter even though the tab still is there...

    I suppose things can be changed when the game logs into home whilst running...I'm ok with that...it's better than a service pack...
    Allen/Backyard's Download Station Content

  2. #2

    Default 2006: Map View camera "snap-back" problem.

    In TRS2006 drivers mode, can I move the center circle around in mini-map view, and have the camera repositioned to that location when I exit the mini-map? This works in the TRS2006 Hawes Junction Demo, but it doesn't work with my full version of TRS2006. In my full version TRS2006, the camera will always focus back on the train when I exit the mini-map. Even if I move the map view around with RMB or the arrow keys, the camera will always be looking at the train when I exit the mini-map. This makes certain operations a pain, such as if I'm driving the train but I want to check out some other part of the scenery, I would always have to "fly" there using the free camera rather than being able to use the mini-map to relocate the camera.

    I noticed that in addition to the 2006 demo, this features also works with TRS2004, but for some reason it doesn't work with my TRS2006. Is this by design or is there a bug here? My version of TRS2006 is from Trainz:The Complete Collection from Amazon.com, and on the main menu screen it says version 2.6 build 3335. I would really appreciate any help.

    EDIT 08/11/27: Changed title of thread again to better describe issue.
    Last edited by lbn204; November 27th, 2008 at 04:32 AM.

  3. #3
    Join Date
    Dec 2006
    Location
    Australia, NSW, URUNGA
    Posts
    634
     

    Default

    Try using the"["and"]" keys to turn the view forward after entering cab mode
    "1".
    There is a better view mode available for cab mode which requires a alteration to your trainzoption file. I think it<s showcab or something. I,ll look when I finish looking at some new D/ls I just did.
    baz66

  4. #4

    Default

    I wasn't referring to the cab view. I was talking about the ability to move the camera view to another place in the world, far away from the train you are driving without having to fly there using the Free Camera. In both TRS2006 demos, you can go to the 2D Map View in Drivers mode, scroll around in the map so that the map is centered somewhere away from the train you are driving, and when you exit the map the camera would be looking at that location in the world. However, in my full version of TRS2006, when I exit the 2D Map, the camera is always pointed at my train, even if I scrolled to another location on the Map. I'm just wondering if there's anyway to change this behavior so that it works like the way it did in the demos.

  5. #5
    Join Date
    Nov 2006
    Location
    United Kingdom
    Posts
    2,746
     

    Default

    I haven't got access to Trainz at the moment so I can't check, but try it in various camera modes. I suspect it might only work in modes 3 or 4.

    John

  6. #6
    Join Date
    Nov 2006
    Location
    United Kingdom
    Posts
    426
     

    Default

    In 04 you have to be in freecam view before you can move around with the map otherwise you snap back to the loco.

    cheers
    Roy

    I used to be confused, now I just don't know.

  7. #7

    Default

    In my TRS2006, the camera snaps back to the train after exiting the Map no matter which view (1-4) I'm in before I enter the map. My 2006 version is 2.6 build 3335.

    In my TRS2004, the camera does NOT snap back to the train in Driver mode, no matter which view I'm in before entering the map. But in 2004 Scenario mode, the camera always snaps back to the train regardless of the initial view. My version is 2.4, build 2370.

    In both 2006 demos, the camera does NOT snap back no matter which view you begin with.

    If any of you guys have different behavior than mine, can you tell me what version of the software you have? And is there a modification available somewhere that will allow me to make the camera not snap back to the train?

  8. #8

    Default

    So, if it's true that only newer versions have this behavior, is there any way to go back to an older version?

    (BTW, I changed the title of the thread from "mini-map" to "Map View" after the comment made by Backyard.)

  9. #9

    Default

    I decided to try some brute force methods to alter this Map snap-back behavior. I know that the trs2006 demos don't have this issue, so I copied the Trainz.exe file in the \Bin directory from the demo version to the \Bin dir in the full version (after backing up my original file). When I load the full version up now, it says TRS2006-demo, ver 2.5 build 2802. Surveyor mode no longer shows up in the main menu, but all the built-in routes and sessions in Driver mode show up.

    Guess what, the camera no longer snaps back to the train after exiting Map View. So, for example, now if I want to study some junctions far away from the train, I can just scroll there on the Map, and the camera will jump to that location after exiting the map. And I can then go back and forth between the Map and the camera, and the camera will stay at the new location. This makes studying other locations so much easier. If I want to return to the train at anytime, clicking either views 1,2, or 3 will jump me back there.

    I just did very brief testing so far, so I don't know if this will cause any other problems, and I haven't tried any downloadable content either. Plus, like I said, it will disable the Surveyor. But to me it's interesting how this does seem to change the Map View behavior. It would be nice if there's a way to do this without messing up Surveyor??

  10. #10
    Join Date
    Nov 2006
    Location
    United States of America, Tennessee, Cookeville
    Posts
    3,348
     

    Default Map View...not Cab View...freecam...or Mini-map....

    Thanks lbn204,

    I was beginning to think no one payed attention to my post!

    I have archived my truly beloved TRS2004 for '06 & look forward to TS2009.

    However I remember this feature in '04. Whilst in Map View, you were attached to the train or could attach by clicking on the train. Depending on where you clicked you returned to that particular train-car.

    But if you left that train, wherever the center of the map was, that's where you entered the route.

    That was standard operating procedure in TRS2006, however I cannot do that as of recently.

    You can, I'll add, zoom in whilst in Map View & pick a train using the taskbar(or the particular Driver you wish by button on a RailDriver) & the map will zoom in on the chosen train. I don't know if this has always been that way, but I like it.

    I substituted the Find Object feature in Driver Mode to go to another location. You just have to know the route well enough to enter your choice of location using the keyboard.

    Or..."fly the Jet!"
    Allen/Backyard's Download Station Content

  11. #11
    Join Date
    Nov 2006
    Location
    United States of America, Pennsylvania, McKeesport
    Posts
    4
     

    Default Camera snap-back

    The camera snap-back problem does not occur if SP 1 is not installed. I added some things to my work in progress route after installing SP 1 and saved over my previous saves in CMP. I then uninstalled 2006 and reinstalled without SP 1. My routes will not load. It tells me there is no map for it. The snap-back problem is resolved though. After reinstalling SP 1 my routes work fine, but there is still the camera snap-back problem. I hope Auran plans on fixing this. Thanx for listenn'

  12. #12
    Join Date
    Nov 2006
    Location
    United States of America, Alabama, Wetumpka
    Posts
    606
     

    Default

    Quote Originally Posted by SwitchmanEddie View Post
    The camera snap-back problem does not occur if SP 1 is not installed. I added some things to my work in progress route after installing SP 1 and saved over my previous saves in CMP. I then uninstalled 2006 and reinstalled without SP 1. My routes will not load. It tells me there is no map for it. The snap-back problem is resolved though. After reinstalling SP 1 my routes work fine, but there is still the camera snap-back problem. I hope Auran plans on fixing this. Thanx for listenn'
    The original 2006 was fine in this regard, and all one had to do to get back to cab view in any case was press 1. This was ruined (my word for it) in SP1 as SwitchmanEddie confirms above. To me this was the one major backward step in SP1 as the other changes were either improvements or at least didn't break anything.

    By the way, can any of the 2009 beta testers tell us if this infuriating "feature" remains unchanged?

    --Lamont

  13. #13
    Join Date
    Nov 2006
    Location
    Moss Vale Australia
    Posts
    261
     

    Default

    I have used
    hold right mouse then 'm'
    release 'm' then release right mouse.
    Works for me in 2006

    Forgot to mention - it isn't my idea but I can't remember who to give the credit to.
    Last edited by nahgallaco; November 23rd, 2008 at 06:20 PM.

  14. #14

    Default

    I just tried the method mentioned by nahgallaco, and it works! I hold the right mouse button while pressing "m" to exit the map. Initially, the view is focused on the train, but when I release the mouse button, it will jump to the last location pointed to on the map.

    What a great find! Thanks!

  15. #15

    Default Still a problem

    I've been using the "trick" described earlier to get around the camera snap-back problem. It works to a degree, but unfortunately it doesn't solve all the problems. Some glaring issues remain:

    1.) Once the above "trick" is applied to make the camera lose focus from the train, further use of the Map will still snap the camera back to the train, unless the trick is used again. Plus, when using the trick, the camera always comes back facing WEST, no matter what the initial orientation. So, if I'm out looking at something using the freecam, and I enter the Map and exit (using the trick), the camera will almost never be looking at the same direction.

    2.) The camera always returns from the Map View in EXTERNAL train cam if the "trick" is not used. It doesn't matter what view you start with or if you switch the view while looking at the Map, it will always come back in EXTERNAL view. So for example, if you are in Cab view, and you take a look at the map, it will come back in External view. Also, if you have some neat camera position set up using freecam, any use of the Map will snap the camera back the External train view (unless the above trick is used, but then the camera will still point at a different direction). This just cannot be right.

    It appears that older pre-SP1 versions of 2006 do not have any of these camera snap-back problems, based on my testing and other comments in this thread.

    So, I sincerely hope the developers can fix the annoying bugs which are mentioned in this thread; bugs which are apparently introduced in SP1. Thanks.
    Last edited by lbn204; November 27th, 2008 at 05:01 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •