.
Results 1 to 13 of 13

Thread: Noisy/speckled shadows in cab

  1. #1
    Join Date
    Mar 2011
    Location
    United States of America
    Posts
    43
     

    Default Noisy/speckled shadows in cab

    I'm having an issue with noisy/speckled shadows when I'm in cab view. I'm pretty sure it's the shadows because I don't see this when I'm in a tunnel, nor do I see it when shadows are turned off. I'll attach a sample image.

    Is this a known issue?

    Matt


    Core i5-10400 6-Core CPU, 32GB RAM, nVidia GTX 1660S 6GB GDDR6

  2. #2
    Join Date
    Apr 2015
    Location
    United States of America, Beaver Pennsylvania
    Posts
    844
     

    Default

    I get it all the time. Very annoying.
    TRS22+ 119122
    i7 6700K @ 4.0 ghrtz, nVidia 970
    I don't have a PhD, I have a DD214 - Freedom carries sacrifice

  3. #3
    Join Date
    Jan 2019
    Location
    United States of America
    Posts
    385
     

    Default

    I have it, too. And while some adjustments will reduce it slightly, nothing eliminates it that I have found.

  4. #4
    Join Date
    Nov 2006
    Location
    United States of America, Massachusetts, Haverhill
    Posts
    32,181
     

    Default

    It's the artefacts caused by the meshes and how the shadows are applied to the models. I pointed this out during the earliest testing in TANE and was told it is what it is and in so many words to live with it. Thus, we have buzzy shadows that look like swarms of gnats that go along with the jellyfish guts with the PBR textures.
    John
    Trainz User Since: 12-2003
    Trainz User ID: 124863
    Trainz-PLUS: 117669

  5. #5
    Join Date
    Nov 2006
    Location
    Newcastle NSW Australia
    Posts
    7,389
     

    Default

    I have read that these and other artefacts are common in all sims that use PBR textures, but Trainz is the only game I’ve seen them in. So I’m inclined to think PBR in Trainz is not implemented as well as it should be.
    T:ANE SP4, TRS19 SP5
    Max 2012, PhotoShop 3
    RTX 3090ti 24 GB, Ryzen 9 5950X 3.4 GHz
    32 GB ram, 2 TB SSD’s, Win 11

  6. #6
    Join Date
    Nov 2006
    Location
    United States of America, Arkansas, Jonesboro
    Posts
    7,513
     

    Default

    I've never seen that, but I do see telephone lines that look like dashed lines that offset and aren't quite connected.



  7. #7
    Join Date
    Feb 2012
    Location
    United States of America, TX, Houston
    Posts
    1,178
     

    Default

    Quote Originally Posted by Dinorius_Redundicus View Post
    I have read that these and other artefacts are common in all sims that use PBR textures, but Trainz is the only game I’ve seen them in. So I’m inclined to think PBR in Trainz is not implemented as well as it should be.
    I agree. Most of the games I play have PBR, and there are no such artifacts on any of the games (except trainz). Even some of those PBR ground texture artifacts ("jellyfish guts") that were supposedly a PBR problem I have not seen on any other game but Trainz. I suspect this is a problem with the trainz E2 engine rather then with PBR. Hopefully when ray tracing comes, which I assume will completely overhaul the current lighting system, these problems will be resolved.
    Last edited by dundun92; August 12th, 2022 at 01:33 PM.

  8. #8
    Join Date
    Mar 2011
    Location
    United States of America
    Posts
    43
     

    Default

    Do the Shadow quality or Main shadow resolution settings have any effect on it? I am current on Medium quality at 2048 for the resolution.
    Core i5-10400 6-Core CPU, 32GB RAM, nVidia GTX 1660S 6GB GDDR6

  9. #9
    Join Date
    Feb 2012
    Location
    United States of America, TX, Houston
    Posts
    1,178
     

    Default

    Quote Originally Posted by wedgef5 View Post
    Do the Shadow quality or Main shadow resolution settings have any effect on it? I am current on Medium quality at 2048 for the resolution.
    With shadows on ultra, the artifacts are much less, but ultra is way to high a setting for a 1660 and will run at basically slide-show speeds.
    Last edited by dundun92; August 17th, 2022 at 11:49 AM.

  10. #10
    Join Date
    Nov 2006
    Location
    New Zealand
    Posts
    3,503
     

    Default

    Typically, these artifacts disappear completely whenever you use Main shadow resolution set to 4096 and have Shadow Quality set to 'Ultra'.

  11. #11
    Join Date
    Nov 2006
    Location
    Johnston, Pembrokeshire, S.W. WALES
    Posts
    2,955
     

    Default

    Ultra settings or disable shadows, is the only way to get around it.
    YMA O HYD

  12. #12
    Join Date
    Aug 2022
    Location
    United Kingdom
    Posts
    1
     

    Default

    I had this problem with dotty shadows in cab. I tried every setting and nothing changed. But I will say since I turned on resizable bar in my PC bios for the Nvidia card it has sorted out my issue and it only happens in cab right up at the roof in the corners and I don't pan my camera up that high so I can live with it for now.

  13. #13
    Join Date
    Mar 2011
    Location
    United States of America
    Posts
    43
     

    Default

    Just to tie a ribbon on this topic...it was noted that setting shadows to Ultra/4096 significantly helps the issue, but my GTX 1660 can't handle Ultra shadows. I can confirm this. Performance even starts to degrade with shadows on High. I think I am just going to turn shadows off. Between the speckles in cab, and the very unrealistic shadows at times (e.g., sharp, clear shadows when it's cloudy and raining), it just isn't worth it at this point.

    Thank you everyone for the helpful input!

    Matt
    Core i5-10400 6-Core CPU, 32GB RAM, nVidia GTX 1660S 6GB GDDR6

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •