.
Results 1 to 4 of 4

Thread: Obsolete Assets show in Surveyor 2.0

  1. #1
    Join Date
    Nov 2006
    Location
    United States of America, California
    Posts
    3,573
     

    Default Obsolete Assets show in Surveyor 2.0

    I dont know if this is a bug or intended but your able to select and place obsolete assets in the new surveyor. I noticed this when using the ATLS slave and controller. There obsoleted assets are packaged payware so you cant delete them. Your able to place both assets when using the new surveyor.

  2. #2
    Join Date
    Nov 2006
    Location
    Australia, NSW, Sydney
    Posts
    9,047
    Blog Entries
    3
     

    Default

    Check the actual KUIDs of those assets but more info is needed. Exactly what are the assets involved?

    I just tried it with an asset that I have that matches your description of "Packaged, Obsolete, Payware" and could not replicate your problem in Surveyor 2.0 or Surveyor Classic. In both UIs only the most recent version, "Installed from DLS", could be selected.
    Development: Trainz Plus - b117699, Win 10, 16GB, RTX 3060Ti
    Testing: Trainz Plus beta - b117669, Win 11, 16GB, RTX 3050Ti

  3. #3
    Join Date
    Nov 2006
    Location
    United States of America, California
    Posts
    3,573
     

    Default

    If you select as the filter "installed" and then type in ATLS Slave for example both slave versions show up in the asset list.

  4. #4
    Join Date
    Nov 2006
    Location
    Australia, NSW, Sydney
    Posts
    9,047
    Blog Entries
    3
     

    Default

    OK, that gives me more info. I have very few ATLS assets on my system, and none as payware, but using the example in my post above, a payware rolling stock wagon, both assets do appear in the Installed filter list in S20 and both can be selected and added to a layout but the obsolete version has its name greyed out.

    I suspect that this is deliberate as the obsolete asset certainly is "installed" (as requested by the filter) and this gives you the option to select it instead of the later current version, if you so desire. Holding the mouse pointer on the asset name in the filtered list for a few seconds will reveal its details (kuid, description, author) which will further inform you as to which version is the current one or which one you want to use.

    My theories anyway.
    Development: Trainz Plus - b117699, Win 10, 16GB, RTX 3060Ti
    Testing: Trainz Plus beta - b117669, Win 11, 16GB, RTX 3050Ti

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •