.
Page 1 of 6 123 ... LastLast
Results 1 to 15 of 85

Thread: Final Beta Test 114205 (PC) and 114207 (Mac)

  1. #1
    Join Date
    Nov 2006
    Location
    Australia, Qld
    Posts
    6,681
     

    Default Final Beta Test 114205 (PC) and 114207 (Mac)

    Update: We've released a new update for PC to 114281 to fix the copy/paste issue below.

    We expect this build to be the final beta test update. The plan is then to release one more "Release Candidate" with Assertions and "legacy script errors" turned off before this update will go live.

    Mac: There is a patch from 111956 to 114207 now available on your Beta patch stream.

    Windows: There is a patch from 111956 to 114177 then a 2nd patch to 114207 now available on your Beta patch stream.

    For those already on 114022, there's a new update available, but this time due to an issue with the patch installer, there's an extra step to update.[/COLOR]

    Steps to update from 114022:

    1. Download the Manual Patcher from this link
    2. Unzip the file (the location doesn't matter, just as long as you know where you unzipped it to)
    3. Run the "TRS19 Beta Patch Installer.exe
    4. The "target" required is the path to your TRS19.exe file in your beta install folder. So find that location then continue with the next step.
    5. Click Change Targets > Browse to your beta install folder > select TRS19.exe > Click Open
    6. Click Next then Apply Patch

    This will update your build to 114205.

    Changelist:

    • Fix various crashes in Loop Line (DLC route in beta testing)
    • Fix for running numbers showing a white box (legacy material ordering issue)
    • Fix for LT R Stock DM" problems (assorted material ordering issues)c
    • Fix assertions and hang on loading KSC2 session (Mac)
    • Fixes to Cutscene mode
    • Fix for assertion - DriverScript::LocationMapObject> changing locations
    • Updates to texel factor error logs
    • Ongoing work with texel issues (appears to be exporter related)
    • Patcher fixes
    • Manual patcher fixes


    Known Issues:


    • This build has "Show Legacy script errors" enabled. This means that legacy scripts that do not utilise asynchronous streaming will not operate correctly (and you'll see a script error). This is done so that we can identify which scripts have errors and identify what needs to be done to resolve them. This mode will be turned off for release version (and switched back to the max compatibility setting)
    • Copy/paste function + Undo (or exiting the Tool tab) will clear the paste buffer.
    Last edited by Tony_Hilliam; September 7th, 2021 at 10:02 PM.
    Tony Hilliam

    Got questions about TRS19? Click here for TRS19 FAQs

    Looking for answers to in-game functionality? Click here for help

  2. #2
    Join Date
    Nov 2006
    Location
    Australia, Qld
    Posts
    6,681
     

    Default

    PLEASE NOTE: There are new instructions to patch from 114022 in the post above. I've made this post so that if you read this before reading the post above, go back and read it.
    Tony Hilliam

    Got questions about TRS19? Click here for TRS19 FAQs

    Looking for answers to in-game functionality? Click here for help

  3. #3
    Join Date
    Nov 2006
    Location
    Canberra, ACT. Australia
    Posts
    9,025
    Blog Entries
    30
     

    Default

    Update from 114022 114205 went smoothly.

    The comments about the Show Legacy script errors have me wondering if they should reported by us or does N3V already have a testing regime, at least for built-ins.

    I got one of these messages for the main menu for the method World.GetVehicleList(). I already knew that method was legacy because I've seen it often for repairs I do for the CRG. Maybe you could let us know if we should try and fix/replace that method in repaired assets. The emphasis is on "try" since at present I have no idea how difficult that might be although I have used asynchronous methods before.

    Paul


  4. #4
    Join Date
    Nov 2006
    Location
    Australia, Qld
    Posts
    6,681
     

    Default

    CRG are welcome to fix anything they can. Here are some links that may help.

    https://online.ts2009.com/mediaWiki/index.php/Scripting
    https://online.ts2009.com/mediaWiki/...oute_Streaming
    https://online.ts2009.com/mediaWiki/...s_in_the_world

    We're working through built-in and DLC content but anything on the DLS is fair game.
    Tony Hilliam

    Got questions about TRS19? Click here for TRS19 FAQs

    Looking for answers to in-game functionality? Click here for help

  5. #5
    Join Date
    Nov 2006
    Location
    Canberra, ACT. Australia
    Posts
    9,025
    Blog Entries
    30
     

    Default

    OK, thanks.

    Paul


  6. #6
    Join Date
    Oct 2018
    Location
    USA - North Carolina
    Posts
    2,063
     

    Default

    Concerning previous patches I posted about trains not emitting on session start from Portal using CPC on Port Zyd sessions. (But did work OK starting with Edit Session and then Drive.) Bug Report had been submitted weeks and weeks ago no no reply.

    I don't see anything about on change list, but I'm happy to report that this patch fixes that issue. CPC/Portal now functions as configured on a session start.
    19 Plus-SP4; Plus-beta 114800; 19-Std SP3; Tane SP4
    Win10, GTX1060-6, SSDs: 1TB(C), 2TB(D)

  7. #7
    Join Date
    Nov 2006
    Location
    Australia, Qld
    Posts
    6,681
     

    Default

    Yes, that was a content update fix, so not in the Changelist. But glad it’s confirmed working
    Tony Hilliam

    Got questions about TRS19? Click here for TRS19 FAQs

    Looking for answers to in-game functionality? Click here for help

  8. #8
    Join Date
    Jul 2007
    Location
    United Kingdom
    Posts
    195
     

    Default

    Patch to Build 114205 was quick and successful. Preliminary running of sessions on the GCR V15 route show no obvious operating difficulties. There are some legacy script reports, for example, with the BR Standard Van, kuid2:86627:2034:44, Script Class "Hybar", and the usual problems with JK script and superscript libraries, although these do not appear to affect the session operations. Further tests are in progress.

    Regards,

    Peter

  9. #9
    Join Date
    Nov 2006
    Location
    was in the Netherlands
    Posts
    5,441
    Blog Entries
    1
     

    Default

    The manual patch ran without any issue.
    Opened an existing test route, a few tracks, and switches. got
    TRS19 Trainz Debug Helper CXFiber:Update
    TRS19 Trainz Debug Helper CXFiber.Update.JPG
    When I clicked on Continue, the same popup appeared about 125 times. When it eventually ended, the route opened but was frozen. None of the controls worked, could just move the window around the screen. Nothing untoward showed in task manager nor in Resource monitor, TRSS19 was still running. Tried to close the Trainz Window but it would not close. The Trainz Launcher could be closed. Then the Trainz window finally closed.
    Reopened the route and this time there was no issue, no popup.
    Testing continues


    70337:
    TRS19 Platinum, build 110491 SP2, Win10 Pro 64 bit, i7-7700 3.6GHz 16 GB, GTX 1070 Ti

  10. #10
    Join Date
    Nov 2006
    Location
    United States of America, TN, Memphis
    Posts
    1,791
     

    Default

    For me this build has gone from bad to just awful. I had finally gotten all my stuff to work in build 114022. Now in build 114205 when I try to run a session all my trains just sit there with messages like "driver is stuck and awaiting new instructions" or no message at all and just sitting there.

    Even Kickstarter Country 2 no longer works. All the assets are there, just cannot get the trains to run.

    There are no errors showing in CRM and the DBR does not fix the issues. Multiple installs have the same issue. Out of solutions or things to try at this end.

    Trainz is no longer fun for me. I'll just stick with build 111951 which was very stable for the most part
    Last edited by Paul_Bert; September 7th, 2021 at 11:47 AM.

  11. #11
    Join Date
    Nov 2006
    Location
    France
    Posts
    2,484
     

    Default

    CP Rail SD40-2 5865-5879 Multimark is still bugged.

  12. #12
    Join Date
    Jul 2011
    Location
    Netherlands
    Posts
    261
     

    Default

    Mac 111956 -> 114207 went OK, but then the (E)DBR fails about 1/4 into "scanning for modified asset files".
    I've checked the drive in Disk Utility, appears to be OK, but still the (E)DBR fails at the same place. By "fail" I mean the programme crashes.

  13. #13
    Join Date
    Nov 2006
    Location
    Australia, Qld
    Posts
    6,681
     

    Default

    1.
    the same popup appeared about 125 times.
    >>
    If you get the same assertion a few times, it is best to hit Ignore and Continue.

    2.
    Mac 111956 -> 114207 went OK, but then the (E)DBR fails about 1/4 into "scanning for modified asset files".
    >>
    Please create a new local data folder to test the build is working.
    For the old folder,
    (i) create a backup copy
    (ii) delete the assets.tdx file and /cache folder then retry

    3.
    CP Rail SD40-2 5865-5879 Multimark is still bugged.
    >>
    I assume you mean the green textures you reported earlier? This is fixed here.
    Looking at
    <kuid2:338228:100501:2> CP Rail SD40-2 5865-5879 Multimark from sc548
    Please provide the KUID and dependency KUID list

    3.
    "driver is stuck and awaiting new instructions"
    "Even Kickstarter Country 2 no longer works. All the assets are there, just cannot get the trains to run."
    "Trainz is no longer fun for me. I'll just stick with build 111951 which was very stable for the most part"
    >>
    The most likely explanation is that you have one or more assets installed that are either newer or older than in our testing. If you give up now, the problem won't be fixed.
    I suggest creating a new local data folder, which I'm sure will work fine, then comparing the list of KSC2 deps in one build versus the other.
    Any differences could lead us directly to the problem.


    We've also released the fix for the copy/paste issue (build 114281 for PC).


    Last edited by Tony_Hilliam; September 7th, 2021 at 07:34 PM.
    Tony Hilliam

    Got questions about TRS19? Click here for TRS19 FAQs

    Looking for answers to in-game functionality? Click here for help

  14. #14
    Join Date
    Nov 2006
    Location
    was in the Netherlands
    Posts
    5,441
    Blog Entries
    1
     

    Default

    Testing existing routes continues with both Kickstarter County 2 and Kauai 2008 from Tane loading and sessions running without any issues.

    Then I created a new route. Placed two Portals, basic 30501:22006:5 and basic short 96914:22000:2.
    Each was programmed to produce a consist and sent it to a third portal that would consume everything.

    I ran the session, waited and nothing happened. No consists were emitted. Saved, reopened and still nothing happened. Did I forget how to use a portal? Did I miss a memo?


    70337:
    TRS19 Platinum, build 110491 SP2, Win10 Pro 64 bit, i7-7700 3.6GHz 16 GB, GTX 1070 Ti

  15. #15
    Join Date
    Nov 2008
    Location
    Crewe, Cheshire, UK
    Posts
    17,179
     

    Default

    Just had another update to 114281 haven't had time to look at 114205 yet.
    Malc


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •