.
Results 1 to 4 of 4

Thread: Help With AI Train

  1. #1
    Join Date
    Nov 2014
    Location
    United States of America, Fla., Spring Hill
    Posts
    869
     

    Question Help With AI Train

    Ok I have a AI train leaving one portal and sent to another, so in between it comes to a switch and the light is green and the next light is green also, but the train slows down and rolls through the green light when the light turns red the train stops and it says its waiting for access to the track past that switch. I've tried several thangs with no avail. Thanks for any help.

  2. #2
    Join Date
    Nov 2006
    Location
    United States of America, Massachusetts, Haverhill
    Posts
    31,489
     

    Default

    Did you try a track mark after the switch?

    AI driver sees the signal and switch, comes to the switch and then loses sight of the path to the portal. Have the driver set its sights on the track mark after the switch then have the AI driver continue on. If you have other switches, have track marks after those.

    It doesn't have to be track marks if you have passenger stations, for example, or some industry the AI has to drive to, but in essence they are one in the same in this case.
    John
    Trainz User Since: 12-2003
    Trainz User ID: 124863
    TRS2019/Trainz-PLUS: 114800
    TRS22 Beta tester

  3. #3

    Default I am having issues with my AI trains

    I recently upgraded to the Platinum Edition but have now noticed that I am having difficulty getting my AI Trains to remember their instructions. Basically, they just sit there. I am new to the game and so I admit its probably something I am doing wrong, but I had them working before the upgrade so I'm wondering if its related?



    Philip

  4. #4
    Join Date
    Nov 2006
    Location
    United States of America, Massachusetts, Haverhill
    Posts
    31,489
     

    Default

    Quote Originally Posted by HappyDad242 View Post
    I recently upgraded to the Platinum Edition but have now noticed that I am having difficulty getting my AI Trains to remember their instructions. Basically, they just sit there. I am new to the game and so I admit its probably something I am doing wrong, but I had them working before the upgrade so I'm wondering if its related?



    Philip
    Welcome to the forums, Phillip.

    It could be related, but it could be other things.

    Open up the driver message history on the left by expanding the message queue. It's a small arrow just above the driver's image.

    With that open, manually issue a driver command such as a drive to (some destination) located down the track apiece.

    If there's an error, such as track missing lever, or path not found, you need to drive the track yourself in that direction very slowly and search, or better yet, add some in between track marks and have the AI driver drive to one of those. If that works, repeat the process for another command until you find the problem.

    With that said, you'll eventually stumble on the problem, usually via a derailment!

    There are, however, some issues with the AI being stupid. You can try setting junctions ahead of the drivers and ensuring the signals are green for the driver. Once set, CTRL-right-click on the consist and choose continue schedule - you may have to issue stop first, wait a minute, then continue-schedule.

    Keep in mind too that Platinum has the pause enabled when jumping from Surveyor to Driver. This means that nothing will move until everything is unpaused.

    Hope this helps.
    John
    Trainz User Since: 12-2003
    Trainz User ID: 124863
    TRS2019/Trainz-PLUS: 114800
    TRS22 Beta tester

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •