.
Results 1 to 8 of 8

Thread: DLS having a weird fit

  1. #1
    Join Date
    Sep 2015
    Location
    Australia, Victoria, Churchill
    Posts
    2,452
     

    Default DLS having a weird fit

    On a clean fresh install of TRS19, I installed my route for testing and needed to download some missing deps. I downloaded the missing dependencies for Elstokos PBR protrack and found that most were faulty and marked third party. After a think, I deleted all of the Elstoko protrack and downloaded the lot in one hit, no more faulties. I noticed 2 were still missing, so checked the white pages DLS and both were there but showing as unknown in CM. After copying them across from another install, all was good.
    Why are assets installed from the DLS showing as third party after 2 years?
    Why are assets shown on the white pages DLS not available on CM even though they were uploaded 2 years ago and were previously available?
    My head is well and truly done in.

    Graeme

  2. #2
    Join Date
    May 2018
    Location
    Australia, NSW
    Posts
    1,989
     

    Default

    Seems to be a frequent problem, and I sympathise with your head. Try not to think about it too much but maybe list the kuids of false third party items so Zec can sort it out?
    Working on Trainz.

  3. #3
    Join Date
    Mar 2009
    Location
    Australia
    Posts
    3,757
    Blog Entries
    1
     

    Default

    Hi All
    Assets that have been detected as faulty in the DLS cleanup system will be marked as 'third party' in Content Manager until they are fixed (either by the content repair group, or by the creator). This will not prevent CM from downloading them as dependencies (if you have exact asset IDs that are failing to download as dependencies, and their dependents, then please let us know so that we can it), however it will avoid them showing up in the 'download station' list whilst they are faulty.

    This has been done due to the large numbers of complaints about faulty assets on the DLS. Until they are fixed, they are hidden from the Content Manager list, but will still download as dependencies if needed.

    It should be noted that in some cases errors may only show in specific situations, such as if an older version of a mesh-library is installed. As an example:

    A track asset specifies the mesh 'track.trainzmesh' in the mesh-library <kuid:12345:9876>.\

    However, this mesh was added in the mesh-library update <kuid2:12345:9876:1>.

    If you then have both versions of the mesh-library installed, the track will be faulty as the specified version of the mesh-library is missing the mesh.

    If you only have the :1 version, or newer, of the mesh-library installed then there will be no error. This is because Trainz cannot currently check the earlier versions of the mesh-library.

    This is done to ensure that the correct version of the mesh-library is being specified when calling the mesh. This is a relatively recent change (I think within the last 2-3 years), but is done to avoid users installing content and having no missing dependencies, but having missing mesh errors. For older content this can still occur, but on newer content the simple solution is to specify the required revision of the mesh-library.

    This was an issue that was seen with my own mesh-libraries for couplers, brake hoses, lamps etc. Personally, I now make a note in the description of what each revision was for so as to help creators specify the relevant version of the mesh-library (although best practice is to simply specify the latest one you have installed ).

    Regards
    Zec Murphy

    Customer Support Rep
    N3V Games (Auran)

    *Please do not use Private Messages for support. Support can only be provided via the helpdesk, or via the forums.

  4. #4
    Join Date
    Nov 2006
    Location
    United States of America, Massachusetts, Haverhill
    Posts
    30,145
     

    Default

    This is done to ensure that the correct version of the mesh-library is being specified when calling the mesh. This is a relatively recent change (I think within the last 2-3 years), but is done to avoid users installing content and having no missing dependencies, but having missing mesh errors. For older content this can still occur, but on newer content the simple solution is to specify the required revision of the mesh-library.

    This was an issue that was seen with my own mesh-libraries for couplers, brake hoses, lamps etc. Personally, I now make a note in the description of what each revision was for so as to help creators specify the relevant version of the mesh-library (although best practice is to simply specify the latest one you have installed ).
    mgalling people have this issue along with the helicopters that rely on the people assets.

    <kuid:101046:106193> Borossa Helicopter Cotton County Tours
    <kuid2:70791:35807:1> Male 07 sitting
    <kuid:101046:106191> Borossa Helicopter Cotton County Sheriff
    <kuid2:70791:35803:1> Male 03 sitting
    <kuid2:70791:35804:1> Male 04 sitting
    <kuid2:70791:35638:1> Female 38 sitting
    <kuid2:70791:35806:1> Male 06 sitting
    <kuid2:70791:35720:1> Male 20 standing

    There are other people assets by mgalling that also have this problem. I deleted the others because they're unused, but these are dependencies and can't be deleted.

    The mesh

    <kuid:-25:1354> Prod Passengers 2020

    Does not contain the components needed for these people among others that are found in the older mesh this asset replaced.

    Content Manager shows no missing assets, yet these people-assets show as faulty because of the mesh.

    The issue occurs in both Build 111951 and Build 113642. I initially thought it was beta-related, but it is not. The issue reared its ugly head after running an EDBR due to importing my database from Build 111951. When I ran an EDBR on Build 111951, the same error occurred there as well.
    John
    Trainz User Since: 12-2003
    Trainz User ID: 124863
    T:ANE Build: 94829
    TRS2019/Trainz-PLUS: 109641

  5. #5
    Join Date
    Nov 2006
    Location
    Canberra, ACT. Australia
    Posts
    9,032
    Blog Entries
    30
     

    Default

    Quote Originally Posted by grazlash View Post
    ...
    Why are assets installed from the DLS showing as third party after 2 years?
    Why are assets shown on the white pages DLS not available on CM even though they were uploaded 2 years ago and were previously available?
    My head is well and truly done in.

    Graeme
    Mostly because the CRG hasn't gotten around to fixing them. We are a very small team and enthusiasm for repair varies.

    The CRG has fixed 1,000s of assets since it was formed but there are still some 7000 on the list. Quite a few of them are error free but were uploaded with a TB less than 3.5. That automatically gets them added to the list although you can still download them as Zec described.

    Paul


  6. #6
    Join Date
    Mar 2009
    Location
    Australia
    Posts
    3,757
    Blog Entries
    1
     

    Default

    Quote Originally Posted by JCitron View Post
    mgalling people have this issue along with the helicopters that rely on the people assets.

    <kuid:101046:106193> Borossa Helicopter Cotton County Tours
    <kuid2:70791:35807:1> Male 07 sitting
    <kuid:101046:106191> Borossa Helicopter Cotton County Sheriff
    <kuid2:70791:35803:1> Male 03 sitting
    <kuid2:70791:35804:1> Male 04 sitting
    <kuid2:70791:35638:1> Female 38 sitting
    <kuid2:70791:35806:1> Male 06 sitting
    <kuid2:70791:35720:1> Male 20 standing

    There are other people assets by mgalling that also have this problem. I deleted the others because they're unused, but these are dependencies and can't be deleted.

    The mesh

    <kuid:-25:1354> Prod Passengers 2020

    Does not contain the components needed for these people among others that are found in the older mesh this asset replaced.

    Content Manager shows no missing assets, yet these people-assets show as faulty because of the mesh.

    The issue occurs in both Build 111951 and Build 113642. I initially thought it was beta-related, but it is not. The issue reared its ugly head after running an EDBR due to importing my database from Build 111951. When I ran an EDBR on Build 111951, the same error occurred there as well.
    Hi John, thank you for alerting us to this.

    In this case the 'Prod Passenger 2020' commodity is an update for the passenger set, to use newer much higher resolution people models. However as they are new PBR meshes, and are a different passenger set, the meshes are different names (and likely wouldn't work as 1to1 replacements in specific mesh-asset reference situations, as compared to regular passenger attachments where the positioning is a lot less specific).

    I've sent a request to the team to see if we can add the old meshes back in, however I can't say when any specific updates may be released for this. The passengers are currently included in only the Beloreck South Ural Mountains route (IIRC they aren't in the Liskaerd to Looe route), so removing this route should resolve this for the time being as well.

    I'm also seeing if we can release the old 'UK 50s' styled passenger set as a separate commodity, so that people making earlier period content can still use these if they wish to.

    Regards
    Zec Murphy

    Customer Support Rep
    N3V Games (Auran)

    *Please do not use Private Messages for support. Support can only be provided via the helpdesk, or via the forums.

  7. #7
    Join Date
    Nov 2006
    Location
    United States of America, Massachusetts, Haverhill
    Posts
    30,145
     

    Default

    Hi Zec,

    Thank you for the assistance with this.

    That makes a lot more sense now as to what's occurring.
    Last edited by JCitron; August 10th, 2021 at 09:17 AM.
    John
    Trainz User Since: 12-2003
    Trainz User ID: 124863
    T:ANE Build: 94829
    TRS2019/Trainz-PLUS: 109641

  8. #8
    Join Date
    Nov 2006
    Location
    United States of America, Massachusetts, Haverhill
    Posts
    30,145
     

    Default

    I came across another mesh issue after an update. This one too occurred at the same time as the people-problem, and exhibits the same symptoms.

    <kuid2:338228:300076:2> GE 7FDL-16 Prime Mover Mesh TS19 has broken some consists I created as well as created a faulty dependency on a route I had installed.

    The previous version, <kuid2:338228:300076:1>, worked fine.
    John
    Trainz User Since: 12-2003
    Trainz User ID: 124863
    T:ANE Build: 94829
    TRS2019/Trainz-PLUS: 109641

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •