.
Page 1 of 6 123 ... LastLast
Results 1 to 15 of 77

Thread: Trainz Plus Beta - 112778 (PC)

  1. #1
    Join Date
    Nov 2006
    Location
    Australia, Qld
    Posts
    6,561
     

    Default Trainz Plus Beta - 112778 (PC)

    Build 111951 to 112778 is now available on the Trainz Plus Beta stream.

    Surveyor 2.0 (S20) is disabled in this release, but the underlying code is there. In theory, Class Surveyor should work exactly as it did before. Please report any regressions you find.

    NOTE: This build is build 4.9 and therefore routes created in this version cannot be run on older builds.

    Changelist:

    • Dynamic brakes are now working when travelling backward
    • Driver "under water" overlay no longer renders on top of the HUD
    • Wheelslip sound no longer playing on Steam locos under DCC control
    • Fix - Script regulator = GetEngineSetting("regulator"); returns 0
    • Fix - Steam locomotive controls 'reverse' when heading reversed
    • Fix - Portals - reversed locos cause coupler break
    • Fix for long loading time in MP
    • Fix the driver list allowing multiplayer clients to delete drivers (leading to sync errors)
    • Fix - MP - focus to player is greyed out
    • Fix - Multiplayer trains frequently drawn with incorrect orientation
    • Fix - Minimap consist names don't move with consist
    • Fix - Moving the camera along a consist using -/= gets "stuck".
    • Fixed Safety Valve sound
    • Fix - Object adjust height tool is jumpy/uncontrollable using ctrl or shift modifier keys
    • Fix - Newly added layers are not shown to user until the layer tab is reopened
    • Fix - Assertion when moving a trackside object from session to route layer.
    • Fix - Assertion placing traincars - ReplicationManager::CreateDynamicNodeFromNetwork
    • Fix - MPS "Find" not very robust wrt/ streaming
    • Fix - MPS route not saving client location
    • Fix sorting of multiplayer routes/sessions in the menu
    • Fix - MPS/Surveyor keyboard shortcuts not working at startup
    • Fix - Trainz calls Cabin.UserSetControl() for each button in the cab every frame
    • Fix - Loco reduces momentum instantly when decoupling while moving
    • Fix - Fix a bug in route merge which was wiping the status of session layers
    • Add extra status validity checking in the LayerTable to catch cases which might do this again in the future
    • Add code to force correct the validity status of layers on load
    • Fix a stack overflow with carz
    • Fix a crash during surveyor train editing
    • Fix - Industry loses commodities in save game
    • Fix - Assertion during Copy Paste where height is selected
    • MeshObject clutter crash fix, and assorted minor allocation optimisations
    • Optimsation - Zooming to minimap and back forces visual regeneration
    • Several DRM server updates
    • Turntables no longer leaving tracks aligned unexpectedly when using UDS
    • Fix to some track segments not rendering


    Known issues;

    • Water effects include two unsupported bindings the UI allows users to select & paint, to no effect.
    • One or more assets using pbrmetalmasked are not rendering
    • W.i.p., updates to in-cab controls (unsure of effects on various old cab control implementations)
    • A "ClientChunk" assertion message will appear on first load - you can ignore this.
    • Copy/Paste has broken (it was working last week - sorry about that)
    Last edited by Tony_Hilliam; June 6th, 2021 at 05:58 PM.
    Tony Hilliam

    Got questions about TRS19? Click here for TRS19 FAQs

    Looking for answers to in-game functionality? Click here for help

  2. #2
    Join Date
    Jun 2011
    Location
    United States of America, Illinois, Rockford
    Posts
    2,065
    Blog Entries
    2
     

    Default

    Got it installed and running a database update.

    Upon the database update, I had the the follow message popup


    Cheers

    NARM's site^

    My personal site: https://hiawathamr.weebly.com/​

  3. #3
    Join Date
    Nov 2004
    Location
    Thailand, Phu Pan Nat'l park proud neighbor
    Posts
    3,766
    Blog Entries
    1
     

    Default

    210603.2031.38 error.
    me too and on top when continue working like before this morning I installed the patch now copy past on my side seem not to work anymore. Copy looks doing something but when hit P (paste)than its end of the command and nothing to paste.
    The makers of the famous Canadian Rocky Mountains routes
    Master my all new TRS19 Canadian Rocky Mountains routes

  4. #4
    Join Date
    Nov 2006
    Location
    Australia, Qld
    Posts
    6,561
     

    Default

    Thanks for the heads up Roy - copy/paste was working last week. That's why we run beta tests. I suggest going back to 111951 for route building.
    Tony Hilliam

    Got questions about TRS19? Click here for TRS19 FAQs

    Looking for answers to in-game functionality? Click here for help

  5. #5
    Join Date
    Sep 2015
    Location
    Australia, Victoria, Churchill
    Posts
    2,275
     

    Default

    Not being offered a patch on launcher, ran Patch Installer exe and found 'no patch available for this product' - Gold 111951
    ** @Roy - Can you select paste button with the mouse and paste a copy to a baseboard?
    cheers
    Graeme
    Last edited by grazlash; June 3rd, 2021 at 11:51 PM.

  6. #6
    Join Date
    Nov 2004
    Location
    Thailand, Phu Pan Nat'l park proud neighbor
    Posts
    3,766
    Blog Entries
    1
     

    Default

    nope you can select copy, draw the rectangle like always than hit P or ctrl v and than nothing happens no rectangle for doing the paste.
    The makers of the famous Canadian Rocky Mountains routes
    Master my all new TRS19 Canadian Rocky Mountains routes

  7. #7
    Join Date
    Nov 2006
    Location
    Australia, Qld
    Posts
    6,561
     

    Default

    Grazlash - have you selected Trainz Plus Beta?
    (and we've confirmed copy paste is broken)
    Tony Hilliam

    Got questions about TRS19? Click here for TRS19 FAQs

    Looking for answers to in-game functionality? Click here for help

  8. #8
    Join Date
    Sep 2015
    Location
    Australia, Victoria, Churchill
    Posts
    2,275
     

    Default

    All good now, I had it set to TRS19 beta at first. Had to run it off the patch installer and once I changed to Plus beta it worked. Running DBR now.
    I also got the same assertion message - if it's expensive and never useful it sounds overpriced to me...
    cheers
    Graeme

  9. #9
    Join Date
    Nov 2004
    Location
    Thailand, Phu Pan Nat'l park proud neighbor
    Posts
    3,766
    Blog Entries
    1
     

    Default

    yees a remarkable meessage!
    I for now have to fight trainz ghosts as going back to a former veersion it seems i losee all my picklists.
    Anybody has a way to locate them and link them to the now curreent version for me?

    I bought this year a new logitec keyboard (expensive)but hoped it would ddeliver. G 913 fancy and for now since 2 weeks a total ddisaster keys start repeat some always the same like the e and d some others too.
    Am i the only one with this weird bug?
    I lookedd all over the place for solutions but no luck so far.
    The makers of the famous Canadian Rocky Mountains routes
    Master my all new TRS19 Canadian Rocky Mountains routes

  10. #10
    Join Date
    Aug 2009
    Location
    United States of America, CA
    Posts
    2,927
     

    Default

    Installed ok, did a 7.5 hr EDBR after install, d/l a Wyoming Coal from the DLS, immediate CDT twice. DBR after each CDT, Attempted to run an installed route same results. Toooooooooo tired to try again. I'll test again in the morning.

    John

  11. #11
    Join Date
    Sep 2015
    Location
    Australia, Victoria, Churchill
    Posts
    2,275
     

    Default

    Quote Originally Posted by RoysTrainz View Post
    yees a remarkable meessage!
    I for now have to fight trainz ghosts as going back to a former veersion it seems i losee all my picklists.
    Anybody has a way to locate them and link them to the now curreent version for me?

    I bought this year a new logitec keyboard (expensive)but hoped it would ddeliver. G 913 fancy and for now since 2 weeks a total ddisaster keys start repeat some always the same like the e and d some others too.
    Am i the only one with this weird bug?
    I lookedd all over the place for solutions but no luck so far.
    Roy, I googled Logitech G613 and G913 problem. There are quite a number of users on Reddit who have the same issue and it was solved on the G613 by changing the batteries, apparently it occurs when the voltage drops below 1.5v (new batteries are usually 1.65v) once the batteries were changed the problem disappeared. I hope this solution works for your G913 as well. I would recommend using lithium non-rechargable batteries as they hold their voltage until almost depleted.
    https://www.reddit.com/r/LogitechG/c...epeat_problem/
    cheers
    Graeme

  12. #12
    Join Date
    Sep 2015
    Location
    Australia, Victoria, Churchill
    Posts
    2,275
     

    Default

    Installed, DBR completed ok.
    First look at CM revealed a new "status" of Packaged. Ok, exactly what does Packaged mean in relation to other status, eg. Installed from DLS, Payware etc. Runs ok, more extensive testing tomorrow.
    cheers
    Graeme

  13. #13
    Join Date
    Mar 2008
    Location
    United States of America, NJ, Ocean City
    Posts
    1,944
     

    Default

    Update no problem and was fast. Now doing DBR which always take some time. I did get this not sure why.
    ; <NULL> : Scanning for added asset files
    - <NULL> : Failed to download precached data for package 'sc276' at version '12345' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc025s' at version '12345' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc025' at version '12345' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc236' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc236s' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc025f' at version '12345' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc236d_0' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc025d' at version '12345' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc236d_1' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc236f_0' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc236f_1' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc236f_2' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc276d_1' at version '12345' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc276s' at version '12345' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc276f_0' at version '12345' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc297' at version '97966' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc276d_0' at version '12345' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc276f_1' at version '12345' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc297f_1' at version '97966' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc313f' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc297f_0' at version '97966' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc297f_2' at version '97966' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc313p' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc297s' at version '97966' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc276f_2' at version '12345' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc297f_3' at version '97966' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc313s' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc297f_4' at version '97966' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc450' at version '12345' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc407' at version '20201208202526_743_1' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc450f_0' at version '12345' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc441' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc450d' at version '12345' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc297d' at version '97966' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc297f_5' at version '97966' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc450f_1' at version '12345' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc450f_2' at version '12345' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc297f_6' at version '97966' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc450s' at version '12345' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc489s' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc489f' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc489p' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc486' at version '20201208212933_749_1' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc491f_0' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc491s' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc495' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc491f_1' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc490' at version '20201215214211_750_1' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc495d' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc491f_2' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc491d' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc491f_3' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc495f_2' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc495f_1' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc484' at version '20210127165345_744_1' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc450f_3' at version '12345' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc495f_0' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc491f_4' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc498' at version '20201215143650_751_1' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc495s' at version '104441' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc495f_3' at version '104441' for platform 'standard-5'
    TS06, TS09, TS10, TS12, New Era SP4, TS19

  14. #14
    Join Date
    Mar 2009
    Location
    United States of America, VA, Richmond
    Posts
    3,050
     

    Default

    Quick and easy patch, installed and a long edbr, was too tired to do some testing, but as others have pointed out, the copy/paste is broken for me as well.
    Last edited by UP5521; June 4th, 2021 at 03:22 PM.

  15. #15
    Join Date
    Nov 2006
    Location
    United States of America, Massachusetts, Haverhill
    Posts
    29,749
     

    Default

    Quote Originally Posted by Lewiscc65 View Post
    Update no problem and was fast. Now doing DBR which always take some time. I did get this not sure why.
    ; <NULL> : Scanning for added asset files
    - <NULL> : Failed to download precached data for package 'sc276' at version '12345' for platform 'standard-5'
    - <NULL> : Failed to download precached data for package 'sc025s' at version '12345' for platform 'standard-5'
    -... etc. ...

    This is normal. The update is newer than the packages that are precached on the server. You can ignore these.
    John
    Trainz User Since: 12-2003
    Trainz User ID: 124863
    T:ANE Build: 94829
    TRS2019/Trainz-PLUS: 109641

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •