.
Results 1 to 3 of 3

Thread: Setting Train Reporting Number in Surveyor / Driver Command

  1. #1

    Question Setting Train Reporting Number in Surveyor / Driver Command

    Hello everyone!

    For days now, I've been trying to get certain locomotives to change their headcodes either in surveyor or with the 'Change Locomotive Reporting Number' driver command in T:ANE.

    Certain locomotives like the "BR Class 37 Green Centre Headcode Full Yellow <kuid2:44090:1070:41>" (by paulhobbs) function perfectly with the driver command, however others like the "BR Class 47 blue 1970s 1 <kuid:283805:47001>" (by tmz06003) do not work with the driver command and neither of these can be changed in surveyor, only in driver, which is hard for me to do for the type of route I'm making which heavily relies on AI.

    I've tried changing certain headcode textures for others that do work, however the scripts simply don't comply with the driver command.

    If anyone has any clues how I could work around this or have any suggestions for alternatives, please do let me know. I can also supply more information.

    Thanks a bunch!
    Kitto Katto Kotto - I didn't copy Kit Kats!

  2. #2
    Join Date
    Nov 2010
    Location
    United Kingdom
    Posts
    20
     

    Default

    It seems I am not the only person having this issue, which texture groups did you download to edit the config file?

    Also have you tried the supporting html links for the various reporting number models?

  3. #3
    Join Date
    Oct 2007
    Location
    United Kingdom
    Posts
    1,553
     

    Default

    I think the Set Train Reporting Number command only works with the diesels that came originally with the S&C Route - so that's the Class 24, certain Class 37s, Class 40, and Class 45.

    As you have found, other locos only allow the headcode to be set in Driver, this includes the 37s that don't derive from the S&C models. I'm not aware of any way to get round this, bar possibly modifying the loco scripts, which is not at all straightforward.

    I've not heard of a 'Change Locomotive Reporting Number' command - is this the correct name for the command you are using?
    Making slow progress on a number of prototypical UK routes


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •