.
Results 1 to 6 of 6

Thread: Boats Rail crossings

  1. #1
    Join Date
    Nov 2006
    Location
    United Kingdom, england, london
    Posts
    378
     

    Default Boats Rail crossings

    I am using Midshire Mainline in TANE and there are several rail level crossings with roads . In the route the crossings are from Boat , I have set the channel and have had crossing barriers work only when I set individual locos up in the drive menu to each loco. Also I notice that the crossings only work when you program that time and when you go back to that session at a latter time the crossing programming has gone.
    Does anyone can tell me how to get these crossings to work automatically when I return to that session. Cheers George

  2. #2

    Default

    All boats assets save the information to the session. If you want to save it to the route you need to name the asset with the blue code in the top left of the properties window. If two assets have the same name you will also have to in brackets add different letters for each asset. ATLS9[0,2,1](a) ATLS9[0,2,1](b)

  3. #3
    Join Date
    Nov 2006
    Location
    United Kingdom, england, london
    Posts
    378
     

    Default

    many thanks

  4. #4
    Join Date
    Dec 2011
    Location
    USA Florida and Illinois
    Posts
    952
    Blog Entries
    1
     

    Default

    Quote Originally Posted by stagecoach View Post
    All boats assets save the information to the session. If you want to save it to the route you need to name the asset with the blue code in the top left of the properties window. If two assets have the same name you will also have to in brackets add different letters for each asset. ATLS9[0,2,1](a) ATLS9[0,2,1](b)
    I save to the route, and then they work in all the sessions for that route. I have also found that if you assign a channel, then rename the asset as stagecoach describes, there is one more step. If you open the asset again it still shows the channel number, by clicking save, even with no changes, then open again, the channel number will show 'MAP', repeat a couple times if needed until its says MAP. If you can't get it to say MAP, then check that you typed in the blue text correctly. From what boat has said in different posts is that once it says MAP, it's 'baked' into the route.

    Make sure the Controller, Slave and Triggers are all done with the same channel number. I use big numbers and use the first 2 numbers as an index (route) and the next 3 numbers sequential for each different crossing. IE Route Something is assigned a prefix of 49, so the first crossing will all use channel number 49101, second crossing 49102, etc. I don't know when you merge routes what happens if two crossings are using the same channel number, but I've read it causes havoc, and don't want to have to mess with it down the road. Adding (A) to the end of the asset name is only needed for the Triggers as there are more than one of them typically. The first one will go in fine, the second one will complain an asset is already has that name, so add the (A) with no space to the end of the asset name. Then save, open, save, open and it should then show MAP as the channel.



    If it's not broke, don't fix it.


  5. #5

    Default

    Chris you are correct that a merge of the route will end up with duplicates. It's not too hard to sort them out. Just use find asset = ATLS** (* being the channel) and check the location if two numbers appear the same.

  6. #6
    Join Date
    Nov 2006
    Location
    United Kingdom
    Posts
    1,114
     

    Default

    Hi Christopher,

    When your asset says 'MAP' it means the coded blue numbers you have typed in are saved to the Session, (or Route) so you can no longer change the settings in the normal way. This may take a couple of openings and closings of the ? box to show in the asset.

    If you want to go back to editing in the usual way simply delete the 'Name' to blank and save. That will clear the blue number code so you can start anew. Again, it may take a couple of openings and closings of the ? box to clear.
    (Don't forget to 'Name' it something though. Don't leave it blank!)

    Boat

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •