.
Results 1 to 9 of 9

Thread: Coming To Gripes With TRS19

  1. #1
    Join Date
    May 2018
    Location
    Australia, NSW
    Posts
    1,083
     

    Question Coming To Gripes With TRS19

    I still rate this as inferior to T:ane from the creating/playablity aspect, but Iíll give it one more shot if I can get any useful answers
    and/or fixes to these problems with it.


    1) We know the scoring has been broken for more than a year, and although a few donít care Iíd argue most do. Why play a session a second
    or third time, except to try and do a better job of it. How do you measure that? With the scoring of-course. That aside,


    2) I was able to add scoring into the HUD Ė except - it is marked as incompatible being from Tane and TRS19 doesnít have itís own version.
    Thatís a total deal breaker for me from the point of view of creating sessions, for the obvious reason you canít do what you can in Tane.
    I.e. you need the hub to add information like the number of times caught speeding, or stations visited, or loads picked up or dropped off and
    pretty much anything else you can think of.


    3) In using the old hud for adding scoring, it caused it to show 2 of everything! When adding speeding, on the third occasion of speeding it
    deducts points even after you cease speeding until you have no points left. Clearly you canít use the hud, and therefore canít add anything
    you could in Tane.


    So my questions are these, is there an alternative way of displaying information as mentioned above? Are they going to fix these serious errors,
    and/or add a hud again?


    4) Trying to bite the bullet and bring my two routes into TRS19, I found a serious issue for the new Queensland route I started. The 3ft6in
    Protrack build 4.2 is faulty in TRS19. The ONLY alternative on the DLS is QR 3ft 6in Track 09 build 2.9!!
    Seriously that is just not acceptable,
    and looks so horrible and has no frogs or working points. If there is anything better, itís not on the DLS that I can see. If this is the case,
    then I will continue the route in Tane where there is much more useful items including the Union Jack. Yep, no Union Jack in TRS19 except one
    old cardboard cutout. No thanks.


    So, am I missing anything? Because if there is no way to display and add information like you can in Tane (stay with SP3), then I wonít be
    making sessions for TRS19, as you are so restricted in what you can do, there is no joy in it, period. However, if they do bring back the hud,
    Iíd happily give it a go, and they certainly should return it in the next version of the game. Itís like buying a modern car and finding they
    no-longer come with a radio. Is it essential, not really. But it is expected. Backwards steps are never desirable, or profitable.

  2. #2

    Default

    I have just downloaded the 3.6 protrack and it was not faulty in 109037. Did you download the Tane content and fixes from the content store?
    <kuid:524343:6287> Flag United Kingdom Anim built in

    https://forums.auran.com/trainz/show...hlight=scoring

  3. #3
    Join Date
    May 2018
    Location
    Australia, NSW
    Posts
    1,083
     

    Default

    I have build 105096 and I've tried several times to sort out the 3ft 6in protrack, and remains broken every time. Thanks for the flag, I missed that so that's one problem solved. Funny your link leads to me telling someone how to add scoring to a session! That works in Tane, not TRS19. It will add up when the session ends. But without a hud, you can not show it progressing, so you have no idea what it is until the session has ended.

  4. #4
    Join Date
    Nov 2006
    Location
    Australia, Qld
    Posts
    6,282
     

    Default

    Please update to the latest SP2 beta and confirm your issues are resolved.

    https://forums.auran.com/trainz/show...Beta-Available
    Tony Hilliam

    Got questions about TRS19? Click here for TRS19 FAQs

    Looking for answers to in-game functionality? Click here for help

  5. #5
    Join Date
    May 2018
    Location
    Australia, NSW
    Posts
    1,083
     

    Default

    Sadly that flag is useless and I recognised it immediately as one that was a problem in Tane. The base flaps around crazily. In an odd development, I have found transferring hundreds of assets from Tane come up faulty, but oddly if I delete them then re-download directly into TRS19 they work. They seem to loose texture files if transferred via CDP from Tane into TRS19. I now have several useful flags. However, this trick has not worked with the 3ft 6in Protrack sadly. I have a hundred plus items to redownload directly into TRS19. As for using a beta, um, I'll hold off on that awhile and see how others fair. I don't want to screw it up any more than it is, so I'll take a careful approach. I may try the 3ft 6in protrack a third time, given there is nothing else suitable. Perhaps a second EDBR is in order.

  6. #6
    Join Date
    Nov 2006
    Location
    United States of America, Massachusetts, Haverhill
    Posts
    28,237
     

    Default

    Quote Originally Posted by Alikiwi View Post
    Sadly that flag is useless and I recognised it immediately as one that was a problem in Tane. The base flaps around crazily. In an odd development, I have found transferring hundreds of assets from Tane come up faulty, but oddly if I delete them then re-download directly into TRS19 they work. They seem to loose texture files if transferred via CDP from Tane into TRS19. I now have several useful flags. However, this trick has not worked with the 3ft 6in Protrack sadly. I have a hundred plus items to redownload directly into TRS19. As for using a beta, um, I'll hold off on that awhile and see how others fair. I don't want to screw it up any more than it is, so I'll take a careful approach. I may try the 3ft 6in protrack a third time, given there is nothing else suitable. Perhaps a second EDBR is in order.
    The texture issue occurs most often with built-in assets and rarely with DLS content. Use PEV's Images2TGA to fix that.

    After running an DBR or EDBR after you've imported content, you may see errors. Don't panic! View errors and warnings, change to some other view such as Download Station then return back to the faulty assets. This will refresh the content and most if not all the errors will disappear once the content has been validated again.

    There's also a bunch of T:ANE content updated for TRS2019 available for download. I recommend installing that if you haven't already. That may fix a lot of the content you have problems with.

    One of the things I recommend doing is creating two simple filters instead of seeing all faulty assets which includes missing dependencies. I have a filter for Faulty-only and one for Missing dependencies only. Simple because it separates the views and I can find out which is which. In many cases, running just the faulty filter shows none, but the missing dependencies filter will show I have a dozen or so after upgrading. Downloading content usually fixes that, and if not I then check for updated DLC.

    With that said, at the present time after importing all my content from T:ANE and previous versions, I have no faulty content listed in any version of TRS2019 including the latest beta build. I do have two missing dependencies and these are known and belong to Dan's Timber Ridge route. The assets are unknown because they are no longer available anywhere on the web or DLS.
    John
    Trainz User Since: 12-2003
    Trainz User ID: 124863
    T:ANE Build: 94829
    TRS2019/Trainz-PLUS: 106618

  7. #7
    Join Date
    May 2013
    Location
    United States of America, Pennsylvania
    Posts
    315
     

    Default

    The thing is, i am so used to Tane, and i like making content for people that dont have 19, so i stick with TANE. I have heard lots of bad, and some good about the new games, but that happens every time it seems, i think everyone loves/hates tane so much because it was the newest game for a lot longer than any other gap

  8. #8
    Join Date
    Nov 2006
    Location
    United States of America, Massachusetts, Haverhill
    Posts
    28,237
     

    Default

    Quote Originally Posted by kcwright_rm View Post
    The thing is, i am so used to Tane, and i like making content for people that dont have 19, so i stick with TANE. I have heard lots of bad, and some good about the new games, but that happens every time it seems, i think everyone loves/hates tane so much because it was the newest game for a lot longer than any other gap
    You'll see a lot of this here. People always look at the previous version with the rosiest glasses they can find, but while that version was the latest and greatest they dissed it and hated it. This has been the way here since the earliest I remember which is back in December 2003 when I joined the Trainz route, no pun intended.

    I have nothing against T:ANE, but I lived through its worst teething and growing pains, and I'm not saying this with those rosy glasses on. As an early supporter I saw numerous CTDs even with SP1 and SP2. At one point, backing up the assets.tdx and relations outside of the Trainz data folders was a common procedure because an inevitable CTD would occur if you moved the mouse the wrong way. It was this and other annoyances such as the fiasco with the signaling and driver system which wasn't resolved until a hotfix after SP3 came out, and that hotfix was to rollback what was changed. This is the technical stuff. There were a lot of managerial issues that this product brought out, and what we have today is the result of those changes for the good.

    With that said, things are different and for the good I think. TRS2019 is what T:ANE was promised to be. Outside of the interface and the typical Trainz anomalies with the new version, it's still the same program under the hood except for some new interface changes on the menus. Sure there are some scripting issues, but that's the name of the game with any updated software. This is true of anything that's complex. Take a look at Oracles R13 database, Microsoft Windows 10, or even Adobes latest and greatest. There are a lot of things that don't quite work or smell right when used.

    If you're happy with T:ANE, by all means stay with it. If your content is in good shape, meaning updated and repaired, there's no reason not to try TRS2019 and import what you've got. There's no reason why this and other versions can't coexist on your system anyway. It's not as though your hard disk will blow up or something because you have both versions or older versions installed.
    John
    Trainz User Since: 12-2003
    Trainz User ID: 124863
    T:ANE Build: 94829
    TRS2019/Trainz-PLUS: 106618

  9. #9
    Join Date
    May 2018
    Location
    Australia, NSW
    Posts
    1,083
     

    Default

    Well, short version, I've run out of data a couple of times in the last 6 weeks! Main reason, re-downloading hundreds of assets that showed as faulty importing from Tane, but which eventually I found weren't really faulty. Talking of which, I'm horrified in SP2 (beta) they have chosen to revert to the old system of importing assets by having to log onto a website, instead on from within the games content manager. More data, more cost although probably only slightly?

    I certainly get that each new version gets its lovers and haters, new version late next year = repeat? If only they had the functionality of Tane (ie timer, score, hud,) and the graphics of TRS19 you'd have a game of great quality and usefulness. Anyway, it is what it is. Poking around in TRS19 Kickstarter to have a break from route building, I see the Local Freight session is broken! Er, seriously? Anyone notice the flat wagons are not programmed to pick up steel coils, so you can never complete it.

    Another query, I was told you had to indent "fade" in a session to get it to work. I see others have tried that and like me found it doesn't work. Anyone ever get fading to work?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •