.
Page 1 of 2 12 LastLast
Results 1 to 15 of 19

Thread: The DLS refuses to update my content. Will not pass unless it is just duplicated.

  1. #1
    Join Date
    Nov 2006
    Location
    United States of America, Colorado, Westminster
    Posts
    383
     

    Exclamation The DLS refuses to update my content. Will not pass unless it is just duplicated.

    The DLS refuses to update my content.
    I had errors with one way roads and they successfully uploaded to the DLS, but they had errors that I missed and I corrected them with a obsolete number and the DLS keeps rejecting my repaired ones.

    If I do not obsolete the old ones then they are approved, but that causes major confusion and duplicates do to the DLS will not allow a obsolete to work.

  2. #2
    Join Date
    Nov 2006
    Location
    Australia, NSW, Sydney
    Posts
    7,665
    Blog Entries
    3
     

    Default

    It would help clarify your problem if you stated
    1. the kuid of an original (but faulty) asset you uploaded
    2. the (obsolete) kuid that you attempted to replace it with.
    TRS19 Platinum Edition build 111951

  3. #3
    Join Date
    Nov 2006
    Location
    United States of America, Colorado, Westminster
    Posts
    383
     

    Default

    Thank for the reply.
    This just started happening. It is just a simple Asset repair and then cloned and inverted the old Config error kuid and upload it again and it always rejects the new repaired Clone.
    Worked last month without issue but recently the DLS is no accepting a repaid and obsolete the old ones.

    Now my assets are faulty on the DLS and i can not obsolete them.

  4. #4
    Join Date
    May 2018
    Location
    Australia, NSW
    Posts
    1,709
     

    Default

    It might help if you actually answer pware's question. It would give him an actual idea of what the items are which could affect how it behaves in regards to obsoleting.

  5. #5
    Join Date
    Nov 2008
    Location
    Crewe, Cheshire, UK
    Posts
    16,943
     

    Default

    Highlight the faulty asset, click content on the top menu, create new version which creates a kuid2 version which will obsolete the original, edit the new version which will be in Open for Edit to correct whatever was wrong, submit and upload to the DLS.
    Malc


  6. #6
    Join Date
    Nov 2006
    Location
    United States of America, Colorado, Westminster
    Posts
    383
     

    Default

    Thank You clam1952 that should work perfectly, I never thought of that.
    That is why i Respect all of you Trainzers so much you always have helpful answers.
    Much appreciated.
    Cheers.

  7. #7
    Join Date
    Nov 2006
    Location
    United States of America, Colorado, Westminster
    Posts
    383
     

    Default

    Quote Originally Posted by Alikiwi View Post
    It might help if you actually answer pware's question. It would give him an actual idea of what the items are which could affect how it behaves in regards to obsoleting.
    Sorry

    Alikiw



    I was doing that last night giving him an answer and all of a sudden I deleted my reply by accident and just gave up an went to bed for the evening.
    I am testing now to see if the DLS will accept a create New asset obsoleting the older one;

    What had happened is that I spent a whole Day making the Custom Invisible Road kit for the community. I should have tested all functions for uploading to the DLS,
    come to find out a defect in the Config file container a line entry of
    invisible 1
    had caused the Traffic not to show up in Driver, only surveyor was working
    .
    Last edited by jjeff1955; June 7th, 2020 at 08:19 AM.

  8. #8
    Join Date
    Nov 2006
    Location
    United States of America, Colorado, Westminster
    Posts
    383
     

    Default

    Still getting rejected. I had created a new asset and obsoleted the one on the DLS. The Older one will not obsolete as the DLS is nor allowing it.
    Here is the error that I get. I am trying to obsolete <kuid:95230:111433> with the <kuid:95230:111750>
    If I can not get the old ones obsoleted then I will have to upload <kuid:95230:111750> as new and it will be accepted, and then there will be duplicates with the<kuid:95230:111433> having errors so to confuse everyone. I do not want to make it difficult for the community to use my Custom assets.

    Dear jjeff1955,
    The addition of your content file Jons_Oneway_Invisible_2L_Pass_Road15mph.cdp has failed due to the following reason:
    An Error Occured with <kuid:95230:111750> Jons Oneway Invisible 2L Pass Road,15mph
    <kuid:95230:111750> : Asset <kuid:95230:111750> uses an obsolete trainz-build number. Trainz-build numbers below 3.5 are no longer supported.

    If you require further assistance please contact our helpdesk (http://www.auran.com/helpdesk)

    Regards,
    The Trainz Team

    I already have sent this to the helpdesk waiting for a response.
    Cheers.
    Last edited by jjeff1955; June 7th, 2020 at 09:19 AM.

  9. #9
    Join Date
    Nov 2008
    Location
    Crewe, Cheshire, UK
    Posts
    16,943
     

    Default

    Doing it wrong, as I said

    Highlight <kuid:95230:111433>

    Click Content on top menu

    Click Create New Version, this will create a new copy in the Open for edit folder <kuid2:95230:111433:1> this is how you obsolete, you do not use the obsolete table which is a hangover from prehistoric versions of Trainz.
    Edit the asset to correct the error and change the build to 3.5. you can no longer upload assets lower than 3.5 as they are not supported.

    Just as a matter of interest <kuid:95230:111433> is not on the DLS anyway unless it hasn't been listed yet, so not sure why you need to obsolete anything, just make sure your replacement is Trainz Version 3.5 or higher.
    Malc


  10. #10
    Join Date
    Nov 2006
    Location
    United States of America, Colorado, Westminster
    Posts
    383
     

    Default

    Yea I am so Stupid at times, lol.
    I just now understood what you had told me to do, I found the Create new versions, I did not know that I had that option.
    Like I said before you People are awesome for having Patience with me as My Stupidity overwhelms me when I am very Tired from working so long on my Projects.
    Thank You so very much to all that has supported me.
    Cheers.

  11. #11
    Join Date
    Nov 2006
    Location
    United States of America, Colorado, Westminster
    Posts
    383
     

    Default

    Did not work, failed again.

    Dear jjeff1955,
    The addition of your content file Jons_Oneway_Invisible_2L_Pass_RoadNo_Traffic.cdp has failed due to the following reason:
    An Error Occured with <kuid2:95230:111738:1> Jons Oneway Invisible 2L Pass Road,No Traffic
    <kuid2:95230:111738:1> : Asset <kuid2:95230:111738:1> uses an obsolete trainz-build number. Trainz-build numbers below 3.5 are no longer supported.

    If you require further assistance please contact our helpdesk (http://www.auran.com/helpdesk)

    Regards,
    The Trainz Team


  12. #12

    Default

    In your "config.txt" you have a line:
    trainz-build x.x

    The x.x need to be 3.5 or higher
    Trainz user since May 2003
    * Intel i7-6700K 4GHz * Nvidia GTX 980Ti * 32GB Ram * Samsung SSD *

  13. #13
    Join Date
    Jun 2013
    Location
    United States of America
    Posts
    30
     

    Default DLS Help

    Sorry I posted in wrong Place
    Last edited by jeffy88; June 7th, 2020 at 01:31 PM.

  14. #14
    Join Date
    Nov 2006
    Location
    United States of America, Colorado, Westminster
    Posts
    383
     

    Default

    Quote Originally Posted by JanRasmussen View Post
    In your "config.txt" you have a line:
    trainz-build x.x

    The x.x need to be 3.5 or higher
    Seems not so, as i have all of the other ones at 2.4 and many others that were approved for the 2.4 Versions.
    I think that the DLS has a Bug that needs to be looked at.
    The issue was that the DLS no longer accepts this statement in the config file.

    obsolete-table
    {
    0 <kuid:xxxxx:xxxxx>
    }

    Thank Jan for the trying to help.
    Last edited by jjeff1955; June 7th, 2020 at 01:30 PM.

  15. #15
    Join Date
    Nov 2008
    Location
    Crewe, Cheshire, UK
    Posts
    16,943
     

    Default

    You can no longer use builds lower than 3.5 its not a bug, its a long overdue restriction, as lower than 3.5 used to get shoved onto the repair list and will not be visible on the DLS.

    Trainz versions below TS12 which is 3.5 to 3.7 are not supported, TS12 was supposed to have ended support in September 2018 and is living on borrowed time.
    Malc


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •