.
Results 1 to 7 of 7

Thread: Explaination Please

  1. #1
    Join Date
    Nov 2006
    Location
    United States of America, Calif., Greenville
    Posts
    686
    Blog Entries
    1
     

    Default Explaination Please

    Can someone explain to me why My AI loco responded to the "runaround" command 2 days ago and now starts to respond but, stops to wait
    for a junction to change and after the junction changes, refuses to move. Just sit there and idles.

    Dave

    TRS19 PLUS
    105100
    This is NOT a Test, I hope!

  2. #2
    Join Date
    Nov 2006
    Location
    United States of America, Colorado, Colorado Springs
    Posts
    665
     

    Default

    Have you checked the message overlay?
    I7-8700K
    1070Ti
    PCIe SSD operation (program and build)

  3. #3
    Join Date
    Nov 2006
    Location
    United States of America, Calif., Greenville
    Posts
    686
    Blog Entries
    1
     

    Default

    No need to, now, I just ran it again and it worked as it should.
    I just LOVE not knowing what is going to work and what is not going to work!!!

    Dave
    This is NOT a Test, I hope!

  4. #4
    Join Date
    Nov 2006
    Location
    United States of America, Colorado, Colorado Springs
    Posts
    665
     

    Default

    Quote Originally Posted by DaveL View Post
    No need to, now, I just ran it again and it worked as it should.
    I just LOVE not knowing what is going to work and what is not going to work!!!

    Dave
    The crew was probably staring into their smartphones.
    I7-8700K
    1070Ti
    PCIe SSD operation (program and build)

  5. #5
    Join Date
    Nov 2006
    Location
    United States of America, Calif., Greenville
    Posts
    686
    Blog Entries
    1
     

    Default

    Well, all I have to say is that there is far too much wrong with even 105100 when it comes to the AI operations!!
    Different place in same session, same problem, should be moving, but will not.
    Oh, and no driver messages either.

    Dave
    This is NOT a Test, I hope!

  6. #6
    Join Date
    Nov 2006
    Location
    Australia, Qld
    Posts
    6,060
     

    Default

    There have been no changes to AI for 105100, so any difference in behaviour is to do with track and signals.

    Given that it changed on your same build, then clearly something changed on the route. Perhaps additional track was laid, signal changes, content updates (which could mean new scripts).

    Something else to check is whether you're starting the "original" session with session rules not run/completed, or running a saved session where some of the rules have already been run. See http://game.ts2009.com/mediaWiki/ind...river_Surveyor

    Given the nature of code, the AI does exactly the same every time in the same circumstances. That doesn't mean 100 tests will have identical results as "timing" could play a factor due to your PC running faster or slower (e.g. more/less background apps running) triggering a script a split second before or after the previous run. (That's a layman explanation for one possible difference, not saying it is the only variable).

    Fwiw, usually when a loco gets "stuck" you can try Stop Schedule > Continue Schedule and that will often clear things. Another option is to Stop, manually intervene then Continue.

    And one last thing - yes, we do need to improve the AI in cases such as when you describe, and to provide more feedback as to why it is doing what it is doing (which may appear to be "nothing" but is in fact "something").

    Hope that helps.
    Last edited by Tony_Hilliam; February 6th, 2020 at 06:38 PM.
    Tony Hilliam

    Got questions about TRS19? Click here for TRS19 FAQs

    Looking for answers to in-game functionality? Click here for help

  7. #7
    Join Date
    Nov 2006
    Location
    United States of America, Calif., Greenville
    Posts
    686
    Blog Entries
    1
     

    Default

    Tony,

    Thanks a lot for your answer. It gives me a lot to "chew" on. Some I have an answer for, some I don't.
    I will write up a lot more later today or tomorrow morning (PST).

    Dave
    This is NOT a Test, I hope!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •