.
Page 1 of 3 123 LastLast
Results 1 to 15 of 45

Thread: Trainz Plus Beta Update 105624 available

  1. #1
    Join Date
    Nov 2006
    Location
    Australia, Qld
    Posts
    6,124
     

    Default Trainz Plus Beta Update 105624 available

    There's an update from 105458 to 105624 available on the Trainz Plus Beta stream.

    Changelist:
    • Delete missing assets now better handles deleting of "unknown" assets
    • Faulty asset validation now pays attention to dependants of any asset version, not just the modified asset version.
    • Turffx no longer disappears near the camera
    • Turffx no longer disappears and rebuilds (stalling) regularly when driving
    • Improvements to Turffx redraw process (much faster to build grid)
    • Crash fix when exiting session with CFD locotracteur loco
    • Region assets no longer show errors
    • Player can now regain train control when loading a save game
    • Advanced options window no longer opens when using the Preset arrow buttons
    • Update the effect layers dialog to not automatically apply binding changes when switching to a preset
    • More Turffx improvements
    • Fix for randomly disappearing track


    Known Issues:
    • Certain sessions load with derailed consists or consists at 0.0
    • No horizontal scrolling on the content list
    • Commodity shows 458m queue size
    Last edited by Tony_Hilliam; January 30th, 2020 at 10:43 PM.
    Tony Hilliam

    Got questions about TRS19? Click here for TRS19 FAQs

    Looking for answers to in-game functionality? Click here for help

  2. #2
    Join Date
    Nov 2006
    Location
    United States of America, Massachusetts, Haverhill
    Posts
    27,207
     

    Default

    Thank you, Tony.

    The updates installed quickly and now running the database repair. I'll be busy testing tomorrow.
    John
    Trainz User Since: 12-2003
    Trainz User ID: 124863
    T:ANE Build: 94829
    TRS2019/Trainz-PLUS: 106618

  3. #3
    Join Date
    Dec 2008
    Location
    New Zealand
    Posts
    340
     

    Default

    Looking very good so far

  4. #4
    Join Date
    Oct 2007
    Location
    Australia, Queensland, CLINTON (QLD)
    Posts
    724
     

    Red face

    Hi Tony
    DL okay
    Install and DB repair okay
    Still have 40 faulty region files - seems that this build is picky about out-dated issues one examples below:

    ! <kuid2:348638:100002:1> VE179: The kuid '<kuid2:67261:29302:2>' specified in 'car0' is not of the correct type.

    ! <kuid2:283523:60004:1> VE179: The kuid '<kuid:-25:485>' specified in 'defaultjunction' is not of the correct type.

    FIXED - did a few open & close edits and view faults - I suppose TRS19 was working in the background as well and all appears sorted - weird??????


    Have a lot of these others say faulty but when checking for the fault box reads 0 faults
    Last edited by butler57; January 31st, 2020 at 01:39 AM. Reason: additional info
    butler57

  5. #5
    Join Date
    Nov 2006
    Location
    Australia, Qld
    Posts
    6,124
     

    Default

    Still have 40 faulty region files
    >>
    What does it show as errors when you click View Errors and warnings?
    Does saving one as a .cdp adjust the status?
    (There's an open task about incorrect faulty status)

    Tony Hilliam

    Got questions about TRS19? Click here for TRS19 FAQs

    Looking for answers to in-game functionality? Click here for help

  6. #6
    Join Date
    Oct 2007
    Location
    Australia, Queensland, CLINTON (QLD)
    Posts
    724
     

    Default

    Hi Tony,

    Re-read my Post #4
    additional info added and issues appear resolved.
    butler57

  7. #7
    Join Date
    Oct 2007
    Location
    Australia, Queensland, CLINTON (QLD)
    Posts
    724
     

    Default

    Hi N3V,

    the following asset is faulty:

    N&W Y6B Tender - downloadable from DLS, is faulty because dependency:

    <kuid2:523:19723189:2> N&W Y6B TenderTruck 02 is installed, Payware not active
    How can that be?
    butler57

  8. #8
    Join Date
    Nov 2006
    Location
    Switzerland
    Posts
    1,015
     

    Default

    Strange, the TenderTruck 02, <kuid2:523:19723189:2>, is ok with me, but I have still some other Payware-not-active assets, I don't know why.

    Regards
    Swordfish

  9. #9
    Join Date
    Apr 2015
    Location
    United States of America, Pennsylvania, Beaver
    Posts
    578
     

    Default

    Quote Originally Posted by butler57 View Post
    Hi N3V,

    the following asset is faulty:

    N&W Y6B Tender - downloadable from DLS, is faulty because dependency:



    <kuid2:523:19723189:2> N&W Y6B TenderTruck 02 is installed, Payware not active
    How can that be?

    I have had this error for the last 2 updates. Just waiting for it to clear up.
    TRS19 106618 - T:ANE 105957
    i7 6700K @ 4.0 ghrtz, nVidia 970
    I don't have a PhD, I have a DD214 - Freedom carries sacrifice

  10. #10
    Join Date
    Apr 2015
    Location
    United States of America, Pennsylvania, Beaver
    Posts
    578
     

    Default Regions

    All the regions were still faulty last night. So I tried the open to edit and resubmit. After resubmit still faulty, then I just double clicked the region in Cm and it was good after that. Strange but worked. View errors showed no errors. Today after work I will check out the routes with TurfFX to see how that works now. Had to go to sleep last night.
    TRS19 106618 - T:ANE 105957
    i7 6700K @ 4.0 ghrtz, nVidia 970
    I don't have a PhD, I have a DD214 - Freedom carries sacrifice

  11. #11
    Join Date
    Nov 2006
    Location
    France
    Posts
    1,955
     

    Default

    105100 to 105458 to 105624: for the first time in History, nothing faulty and/or missing!

  12. #12
    Join Date
    Nov 2008
    Location
    Crewe, Cheshire, UK
    Posts
    16,026
     

    Default

    Regions, non builtin ones, all faulty even after full DBR. Open for edit and submit fixed them.
    Malc


  13. #13
    Join Date
    Nov 2006
    Location
    France
    Posts
    1,955
     

    Default

    ALL savegames now unusable: ALL start with derailed trains! Can't even start some existing sessions!

  14. #14
    Join Date
    Nov 2006
    Location
    United States of America, Massachusetts, Haverhill
    Posts
    27,207
     

    Default

    Quote Originally Posted by HPL View Post
    ALL savegames now unusable: ALL start with derailed trains! Can't even start some existing sessions!
    Known Issue:

    • Certain sessions load with derailed consists or consists at 0.



    From the top-post.
    John
    Trainz User Since: 12-2003
    Trainz User ID: 124863
    T:ANE Build: 94829
    TRS2019/Trainz-PLUS: 106618

  15. #15
    Join Date
    Nov 2008
    Location
    Crewe, Cheshire, UK
    Posts
    16,026
     

    Default

    My own sessions appear to be OK as is saving and restarting them, ATLS broken again on My FR route, had to again rename the controllers, which fixed it. May just be my imagination but the lighting looks to be better?
    Malc


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •