.
Page 2 of 2 FirstFirst 12
Results 16 to 22 of 22

Thread: TurfX problem

  1. #16
    Join Date
    Nov 2006
    Location
    Australia, Qld
    Posts
    6,060
     

    Default

    Thanks for the extra information - excellent repro.

    Task added: "Adding a new effect layer wipes existing turffx layers from large routes that have lots of turffx already"
    Last edited by Tony_Hilliam; February 5th, 2020 at 12:54 AM.
    Tony Hilliam

    Got questions about TRS19? Click here for TRS19 FAQs

    Looking for answers to in-game functionality? Click here for help

  2. #17
    Join Date
    Nov 2006
    Location
    Australia, Qld
    Posts
    6,060
     

    Default

    Also I've moved this post from Footplatephil here as it is a more appropriate place to respond:

    1. Areas of TurfFX applied (and visible) in Surveyor do not always display in Driver. The areas that have TurfFX displayed in Driver depends on the direction of travel, and the density of application.
    >>
    We're not seeing anything unexpected here. Camera angle and zoom range will definitely make things look different, but that doesn't sound like what you are describing. Screenshots and more details may help.

    2. TurfFX defined after application of the initially defined set of TurfFX can only be applied to 'untreated' based boards. If you try to apply them to areas with existing TurfFX the existing TurfFX in that area are wiped out. I have seen a couple of threads on this one.
    >>
    This sounds very like the same issue in #3 (so covered in the same bug report). Please recheck when we release the update.

    3. Possibly an extension of 2. Once a large area of TurfFX has been applied (hundreds of base boards ?), any new definition wipes out existing TurfFX across the entire route in a seemingly random manor. This one I reported to the Helpdesk, and it was acknowledged as a problem.
    >>
    As above

    4. When merging routes only the TurfFX in the base route survive the merge.
    >>
    Merging Turffx layers are not currently supported in Route Merge. (It was news to me too). There is a significant amount of work to add support, and it is on our to do list.

    Fwiw, the new bulk add tools (currently in beta testing with Trainz Plus members) do make a big difference to the ease of adding effect layers (e.g. by bulk-adding an effect layer to a specific texture).
    Tony Hilliam

    Got questions about TRS19? Click here for TRS19 FAQs

    Looking for answers to in-game functionality? Click here for help

  3. #18
    Join Date
    Nov 2006
    Location
    Australia, NSW, Katoomba
    Posts
    943
     

    Default

    Hi Tony,

    With regards Issue 1: I believe it may have something to do with the amount of TurfFX recently displayed. Hence the direction of travel can affect the outcome. As a work-around when building my Weddin V4 route I 'ploughed in' a number of crops in some areas to reduce the overall TurfFX in that area. However I have managed to find one area I missed in the WeddinV4 route currently on the DLS. I will attempt to explain the steps I have taken in producing the below sample images....

    1. I set up a test session, and placed a test consist (the Fairmont trike) just north of the road crossing at Bendick Murrell. (Bookmark 3 will take you to Bendick Murrell). I instructed Harry to Navigate to @South Staging, and set the camera mode to the lineside view. 3 minutes or so into the session a bald patch is visible in the TurfFX wheat crop, as follows...

    Lineside Camera




    Roaming Camera



    2. I saved the session at that point, and exited.

    3. I selected 'Drive Session' to restart the saved session, and hit 'P' to pause as soon as the session started.

    4. From the same location as used for the previous images I captured the following. Note that the TurfFX now appear as they should. This is how also how they appear when you load the route into Surveyor.

    Lineside camera



    Roaming camera




    5. In order to more precisely identify the location of my test images I also 'snipped' an image of the Map View at that point (for some reason the inbuilt image capture tool does not capture the map view). Harry is driving the trike.





    I hope this info helps your team identify and resolve the issue. As I said, there is a work around... just don't use too much TurfFX in any given area. However this is a bit limiting.
    Last edited by FootplatePhil; February 5th, 2020 at 08:09 PM.
    Phil
    'WeddinNSW V4.1' for TRS2019 SP1 coming soon to the DLS.

  4. #19
    Join Date
    Nov 2006
    Location
    Australia, Qld
    Posts
    6,060
     

    Default

    Ok - sounds like a similar situation to another test case we had with near camera turf not showing at various times (in driver or surveyor). This has been fixed in the latest Trainz Plus beta (105674). That beta is nearing release with very few outstanding issues remaining, so I would suggest you patch using the Trainz Plus Beta stream to check out that it is resolved.

    If you're already on that version, please let us know. (Note that "[COLOR=rgba(0, 0, 0, 0.9)]Turffx is completely wiped when creating a new clutter layer " is not fixed yet).[/COLOR]
    Tony Hilliam

    Got questions about TRS19? Click here for TRS19 FAQs

    Looking for answers to in-game functionality? Click here for help

  5. #20
    Join Date
    Nov 2006
    Location
    Australia, NSW, Katoomba
    Posts
    943
     

    Default

    Quote Originally Posted by Tony_Hilliam View Post
    Ok - sounds like a similar situation to another test case we had with near camera turf not showing at various times (in driver or surveyor). This has been fixed in the latest Trainz Plus beta (105674). That beta is nearing release with very few outstanding issues remaining, so I would suggest you patch using the Trainz Plus Beta stream to check out that it is resolved.

    If you're already on that version, please let us know. (Note that "[COLOR=rgba(0, 0, 0, 0.9)]Turffx is completely wiped when creating a new clutter layer " is not fixed yet).[/COLOR]
    OK, thanks Tony. I don't have Trainz Plus, I have TRS2019 Platinum. So I guess I will have to wait for Titanium.
    Phil
    'WeddinNSW V4.1' for TRS2019 SP1 coming soon to the DLS.

  6. #21
    Join Date
    Nov 2006
    Location
    Australia, Qld
    Posts
    6,060
     

    Default

    The bug fixes will make it back into other releases, so you shouldn't have to wait too long.
    Tony Hilliam

    Got questions about TRS19? Click here for TRS19 FAQs

    Looking for answers to in-game functionality? Click here for help

  7. #22
    Join Date
    Nov 2006
    Location
    Brixton, London, England
    Posts
    2,916
     

    Default

    Quote Originally Posted by FootplatePhil View Post
    So I guess I will have to wait for Titanium.
    I like that concept! Can't wait for Trainz Titanium.....

    Paul

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •