.
Results 1 to 5 of 5

Thread: Updated Steam TRS 2019 NA Regional Version and Faulty Assets (EMD GP40-2 Cab)

  1. #1
    Join Date
    Nov 2006
    Location
    K-W, Canada
    Posts
    3,060
     

    Default Updated Steam TRS 2019 NA Regional Version and Faulty Assets (EMD GP40-2 Cab)

    Hi Everyone,


    So I started up my steam version of TRS 2019 NA version just now...updated software and checked my assets to see I've got close to 230 faulty assets. Many are from Auran/N3V themselves and I can live with that but I noticed another issue that's leaving me scratching my head. Can someone help me figure out how to fix this? Let me explain.

    A lot of my locomotives are showing up as faulty (missing dependencies). I look at the dependencies and find out that the EMD Hood Unit Interior dependency is missing the EMD GP40-2 cab dependency. Apparently, this is installed Payware (not active). Can someone explain to me what happened, where, by updating trainz, this dependency overwrote what was functioning, made this a necessity, and now seems like something that I need to now pay for to make things work?

    Even stranger: I have a built in version of the same thing (EMD GP40-2 Cab) but with a different KUID (276266:100460:14) which is now obsolete.

    N3V...seriously, wth did you do? Seriously...

    Can someone help me figure out the easiest way to fix this mess? It'd be much appreciated!


    Gisa
    "Build it and they will come..."

  2. #2
    Join Date
    Jun 2016
    Location
    New Zealand
    Posts
    2,533
     

    Default

    The easiest way is to take to take obsolete version open it in explorer and copy the folder to your desktop. Once there open the folder and the the config file in notepad and change the version number at the end of the KUID number to being one higher than that of the payware version. Use 'import folder' in CM to load in your edited folder.
    After doing that everything should be fine.
    Narcolepsy is not napping.



  3. #3
    Join Date
    Nov 2006
    Location
    United States of America, Alabama, Birmingham
    Posts
    3,019
     

    Default

    Or delete the newer one. I've had to do this several times. The issue is that N3V requires all DLC to include all assets that the DLC uses. This includes builtin content too. So sometimes a DLC product will obsolete an older working version with a faulty one.
    William

  4. #4
    Join Date
    Nov 2008
    Location
    Crewe, Cheshire, UK
    Posts
    15,806
     

    Default

    Before doing anything try a database repair, often sorts out things like this.
    Malc


  5. #5
    Join Date
    Nov 2006
    Location
    K-W, Canada
    Posts
    3,060
     

    Default

    Thank you all for your replies and advice. Sorry mine is a bit late (I was playing with my real trains today ).

    Wouldn't you know, I start up trainz again, ran a database repair and it looks much better (14 assets). Kotangagirl, thank you for the advice. I recalled vaguely how to make the new missing asset obsolete but now I (and others) know how to do so if this situation comes up again. Seems fine for now. :/ Maybe someone in N3V saw this and fixed it? Wish I knew what happened. :/

    Thing was, I ran 2 Database Repairs last night and still had the same issue. Maybe I had to shutdown and reboot for the fixes to take effect?

    Now, if N3V would only make available payware scenery assets included in the full version so the regional users like me could have them in routes, it'd be normal again. Somehow, I doubt this will happen though...

    Thanks again everyone. Have a great day/night!


    Gisa
    "Build it and they will come..."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •