.
Results 1 to 3 of 3

Thread: A Basemapz quirk?

  1. #1
    Join Date
    Nov 2006
    Location
    United States of America, Ohio
    Posts
    4,014
     

    Default A Basemapz quirk?

    Having fun importing some route JPGs into TMR2017 using Basemapz. There is one thing that is consistent throughout my creations and that is: Every basemap comes out turned 90 degrees from the baseboard(s) created. I had one route that required a 2x6 baseboards. The Basemap stuck out the side of the top 2, with the other 4 hovering over nothing while the four other baseboards below the two top ones were bare. I had to unlock the layer, rotate ALL baseboards by 90 degrees, then piece them together in the right spot on the 2x6 baseboard.

    The KUID for the World Origin created by Basemapz is wrong and generated a "missing content" error. If I "delete missing content" before initial save, then it goes away.

    Is this normal, or bugs, or what? I'm using the latest version off the website.

    Bill
    Name: Bill (CTR1, USN, Retired 1961--1980)
    User ID: 202442
    Trainzer since: 2003
    Currently using: T:ANE (build 94808)

  2. #2
    Join Date
    Nov 2006
    Location
    United States of America, South Jersey
    Posts
    1,804
    Blog Entries
    1
     

    Default

    Bill, if I read you post correctly both problems are known problems. The 1st with the baseboards rotated 90 deg I picked up when I 1st tested it - unfortunately that was just after it was released. There is an update to the program on MJmodelers site that fixes it.

    Check out this thread in the forums here or you can go directly to his site here and dl the latest copy of the program.

    The world origin error is a kuid typo in the config.txt for the route that is generated by the program. IIRC there is an extra 0 in the item number. You can just edit the config's kuid-table in CM. Find and change <kuid:44179:600014> to <kuid:44179:60014>.

    Does Surveyor add the "correct" world origin asset back in if you use delete all missing assets approach?

    Bob Pearson
    Last edited by RPearson; December 13th, 2019 at 07:23 PM.
    TRAINZ-UTC-TRS04-TRS06-TC1&2-TC3-TS09-TS10-TS12-TANE(TEG)-TMR17-TS19
    Member since 6-14-2002

  3. #3
    Join Date
    Nov 2006
    Location
    United States of America, Ohio
    Posts
    4,014
     

    Default

    Quote Originally Posted by RPearson View Post
    Bill, if I read you post correctly both problems are known problems. The 1st with the baseboards rotated 90 deg I picked up when I 1st tested it - unfortunately that was just after it was released. There is an update to the program on MJmodelers site that fixes it.

    Check out this thread in the forums here or you can go directly to his site here and dl the latest copy of the program.

    The world origin error is a kuid typo in the config.txt for the route that is generated by the program. IIRC there is an extra 0 in the item number. You can just edit the config's kuid-table in CM. Find and change <kuid:44179:600014> to <kuid:44179:60014>.

    Does Surveyor add the "correct" world origin asset back in if you use delete all missing assets approach?

    Bob Pearson
    Thanks, Bob. Yes, I downloaded the latest, but for some unknown reason it didn't replace version 0.9.2 when I tried to overwrite it. So I uninstalled it, then reinstalled the latest. Haven't tried it yet as it is dinnertime.

    As far as I can see, deleting missing assets works okay. I haven't noticed any glitches other than the forementioned.

    Bill
    Name: Bill (CTR1, USN, Retired 1961--1980)
    User ID: 202442
    Trainzer since: 2003
    Currently using: T:ANE (build 94808)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •