.
Results 1 to 3 of 3

Thread: EIT Tower with TCBs Shows too many TCB detectors

  1. #1
    Join Date
    Nov 2011
    Location
    United States of America, Tampa, FL
    Posts
    1,155
     

    Question EIT Tower with TCBs Shows too many TCB detectors

    BUILD 100240.

    I have an EIT Tower "Enhanced TRC3 invisible Interlocking Tower (SP2 and later)" <KUID2:61392:8101:52>
    I have 2 rails running past a single rail station. (one rail is station, the other is a bypass). There are double slips off to each side of the station for crossover needs.

    https://www.trainzportal.com/mytrain...post_id=140686 <--Pic of slips with paths in yellow. East and west slips are exactly the same and configured the same.

    -----------<S-/-\-S>---TI----------Bypass--TCD-------------TI------<S-/-\-S>----------
    -----------<S/---\S>---TI----------Station--TCD-------------TI------<S/---\S>----------

    This is shown with North up.

    KEY:
    S = Signal
    <or> = Signal Direction
    TI = Track insulator
    TCD = Track Circuit Detector
    /or\ = Slipover
    --- = Track line

    I have 8 paths on one tower.
    West crossover has "EB STN INBOUND" "EB BYPASS INBOUND" "WB STN OUTBOUND" "WB BYPASS OUTBOUND"
    East crossover has "EB STN OUTBOUND" "EB BYPASS OUTBOUND" "WWB STN INBOUND" ""WB BYPASS INBOUND"
    No paths are set along the middle section, I have only the TCB setup there.

    I'd give a screenshot of the exact problem, But the menu is not in the snapshots I tried to get.

    I have one TCD named "Bypass", The other is named "Station". When ran in driver, I get a hold up where a train does not activate certain paths because the RM data says a path TCB is occupied. Going back to surveyer, the affected paths are somehow identifying either both TCDs for a path, or the same TCD twice. I have even gone as far as deleting the TCDs, checking to see that it clears from the tower, then reinstall the TCDs with slightly modified names to be sure, Problem is persistant and I cannot figure out why Some paths are seeing the same TCD twice or both TCDs at once.
    "Cave Johnson. We're done here."

  2. #2

    Default

    Hi Maruffijd.

    Just try to insert a track spline point between the track insulator and the nearby signal on the station track and the bypass track ( 4 tracks spline points to insert ).

    -----------<S-/-\-S>--TSP--TI----------Bypass--TCD-------------TI--TSP----<S-/-\-S>----------
    -----------<S/---\S>--TSP--TI----------Station--TCD-------------TI--TSP----<S/---\S>----------

    TSP = Track spline point to insert

    I have seen in the past some situations where the track circuit block did not exactly end at the track insulator itself but at the next track spline point encountered … And if the next track spline point is a junction point, the junction is considered as embedded in the track circuit block. By inserting some track spline point you should be able to limit the track circuit block exactly to the location you want to have.

    By the way, when you will have fix the previous problem, I don't understand why in your configuration you use these track circuit blocks. Each track circuit block do not embed any signal or junction, and so should not be part of any of the paths you defined. So the paths should activate either with the TCB being occupied or not. So why do you add these TCBs that seems for me as they are currently defined useless … If you want to add a track circuit block to a path, you need that the path exit signal is embedded in the track circuit block.

    Regards.
    Pierre.
    Last edited by pguy; December 10th, 2019 at 11:00 PM.

  3. #3
    Join Date
    Nov 2011
    Location
    United States of America, Tampa, FL
    Posts
    1,155
     

    Default

    Quote Originally Posted by pguy View Post
    Hi Maruffijd.

    Just try to insert a track spline point between the track insulator and the nearby signal on the station track and the bypass track ( 4 tracks spline points to insert ).

    -----------<S-/-\-S>--TSP--TI----------Bypass--TCD-------------TI--TSP----<S-/-\-S>----------
    -----------<S/---\S>--TSP--TI----------Station--TCD-------------TI--TSP----<S/---\S>----------

    TSP = Track spline point to insert

    I have seen in the past some situations where the track circuit block did not exactly end at the track insulator itself but at the next track spline point encountered … And if the next track spline point is a junction point, the junction is considered as embedded in the track circuit block. By inserting some track spline point you should be able to limit the track circuit block exactly to the location you want to have.
    I will try the added spline points tomorrow. Time for these tired bones to sleep for work. I have found that the trains got stuck because I missed an Auto drive command causing a train to prematurely try to take a path miles ahead of the entry signal. This caused the trains ahead of it to have to wait for permission that never came. Adding the missing command put the errant train on schedule and allows my trainz to request paths in proper order.

    Quote Originally Posted by pguy View Post
    By the way, when you will have fix the previous problem, I don't understand why in your configuration you use these track circuit blocks. Each track circuit block do not embed any signal or junction, and so should not be part of any of the paths you defined. So the paths should activate either with the TCB being occupied or not. So why do you add these TCBs that seems for me as they are currently defined useless … If you want to add a track circuit block to a path, you need that the path exit signal is embedded in the track circuit block.

    Regards.
    Pierre.
    This one does operate as you say. With the TCB isolated outside the paths, it does indeed do nothing to help. I found this while fidgeting with the route. I have moved the insulators to include the inner Signals and got the desired results. Even the "meets" are under control now.

    Thank you for the advice and assistance.
    Last edited by maruffijd; December 11th, 2019 at 01:58 AM. Reason: Typos ERRR!!
    "Cave Johnson. We're done here."

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •