.
Results 1 to 8 of 8

Thread: TRS2019 - Loco Smoke Offset

  1. #1
    Join Date
    Nov 2006
    Location
    United Kingdom
    Posts
    1,142
     

    Default TRS2019 - Loco Smoke Offset

    When running a steam locomotive session across the Forth Rail bridge in Edinburgh & Dundee I noticed that locomotive smoke appears to be significantly offset to one side.
    I have seen this effect in T:ANE where it was about a couple of metres (6 feet approx), but this looks more like ten metres (30 feet approx).
    Several content creators locos exhibit it so it is possibly not something they are at fault for?



    Anyone else experiencing this?

  2. #2
    Join Date
    Jun 2008
    Location
    Great Britain
    Posts
    2,611
     

    Default

    Try turning off PhysX in the settings. This is supposed to enable to the particle collision effects but often this doesn't work properly and results in the effect you have seen.


  3. #3
    Join Date
    Nov 2006
    Location
    United Kingdom
    Posts
    1,142
     

    Default

    Thanks ed, I will try that. I checked back through the screenshots I took and the chimney smoke appears ok away from the Forth Rail Bridge but goes awry anywhere on the bridge.

  4. #4
    Join Date
    Nov 2006
    Location
    United Kingdom
    Posts
    1,142
     

    Default

    Hello ed

    Spot on. PhysX disabled and the smoke offset disappeared.
    Here's the Drummond D 0-6-0 on the bridge heading south.


  5. #5

    Default

    You didn’t turn off PhysX in the settings, you turned off the simulation of PhysX. This doesn’t work properly, you want the real thing.

    Paul

  6. #6
    Join Date
    Mar 2009
    Location
    Australia
    Posts
    3,327
    Blog Entries
    1
     

    Default

    Quote Originally Posted by paulhobbs View Post
    You didn’t turn off PhysX in the settings, you turned off the simulation of PhysX. This doesn’t work properly, you want the real thing.

    Paul
    Just a correction, this does disable a number of the PhysX functions. In particular, it disables particle effect collisions on everything except the terrain. This is why the smoke doesn't become offset, because the smoke (particle effect) won't 'collide' with anything. If you drive through the terrain, you should see the particle effects become offset.

    The smoke becoming offset is itself due to one or more objects near/around the train using the default collision mesh/box. By default, the collision box effectively 'shrink wraps' over the top of the object (think a bit like draping a sheet over it); anything inside that will offset it's smoke effect.

    Creators can specify custom collision meshes for their content. In particular this would be needed for any object the train can legitimately pass through (ie the bridge pictured in this thread, which the train passes through in places, or tunnels, or bridges over the track), to make a 'hole' through the collision mesh for the train to go through.

    Regards
    Zec Murphy

    Customer Support Rep
    N3V Games (Auran)

    *Please do not use Private Messages for support. Support can only be provided via the helpdesk, or via the forums.

  7. #7
    Join Date
    Dec 2007
    Location
    United Kingdom
    Posts
    217
     

    Default

    Quote Originally Posted by paulhobbs View Post
    You didn’t turn off PhysX in the settings, you turned off the simulation of PhysX. This doesn’t work properly, you want the real thing.

    Paul
    What is 'the real thing' and how does one get it please?

    Ingha

  8. #8
    Join Date
    Sep 2015
    Location
    Australia, Victoria, Churchill
    Posts
    1,516
     

    Default

    The 'real thing' is already on your graphics card and is usually turned on by default. If nVidia, open the nVidia Control Panel by right clicking on the desktop, to check its status. AMD ???
    cheers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •