.
Results 1 to 7 of 7

Thread: TRC Crossings stopped working on a route I'm editing.

  1. #1
    Join Date
    Jul 2013
    Location
    United States of America
    Posts
    208
     

    Default TRC Crossings stopped working on a route I'm editing.

    I am editing a route from TS12 for TRS2019 and suddenly the TRC crossings I've placed stopped working even and it is only happening on this one route, all the TRC Crossings on other routes still work as they should.

    I am also getting these errors when editing the route in Surveyor:
    - <kuid2:458053:100686:14>
    File trc_close.gs, Line 115, ER_ThreadError; <kuid2:458053:100686:14> Script class: TRCscript
    ; <kuid2:458053:100686:14> MeshObject: <kuid2:458053:100686:14> "TRC 3 Trigger for closure of rail crossing"
    ; <kuid2:458053:100686:14> Script callstack
    ; <kuid2:458053:100686:14> function $void@TRCscript::RefreshNOL(), line 88
    I have tried rebuilding one of the TRC crossings and it still didn't work, any suggestions?

    I am using Trainz Plus.
    Last edited by BBarnes005; May 16th, 2019 at 10:42 AM.

  2. #2
    Join Date
    Nov 2006
    Location
    United States of America, Massachusetts, Haverhill
    Posts
    24,954
     

    Default

    This was an issue in TRS19 its self as well. The creator needs to update his assets to work with the new way that the scripts are managed. Mike (Boat) has already done this with his ATLS crossing assets and they work fine.
    John
    Trainz User Since: 12-2003
    Trainz User ID: 124863
    T:ANE Build: 94829
    TRS2019: 98592

  3. #3
    Join Date
    Jul 2013
    Location
    United States of America
    Posts
    208
     

    Default

    If that's the case, then why are the TRC crossings on other routes still working fine? It's just one route where they've suddenly stopped working.

  4. #4
    Join Date
    Nov 2006
    Location
    United States of America, Massachusetts, Haverhill
    Posts
    24,954
     

    Default

    Did you touch the other routes, meaning save or update them?
    John
    Trainz User Since: 12-2003
    Trainz User ID: 124863
    T:ANE Build: 94829
    TRS2019: 98592

  5. #5
    Join Date
    Jul 2013
    Location
    United States of America
    Posts
    208
     

    Default

    I haven’t.

  6. #6
    Join Date
    Nov 2006
    Location
    United States of America, Massachusetts, Haverhill
    Posts
    24,954
     

    Default

    I ask because I too have had trouble with them as well and so have others. As I said there has been some code updates to the underlying game engine that can cause assets such as the TRC crossings to stop working. Vincent needs to look at them and hopefully update the code just as Mike did with the ATLS crossing data.
    John
    Trainz User Since: 12-2003
    Trainz User ID: 124863
    T:ANE Build: 94829
    TRS2019: 98592

  7. #7

    Default

    Or N3V need to stop changing the code and breaking things that are established and worked perfectly alright - then blaming the asset creator.
    Digging away in MSTS & TANE...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •