.
Results 1 to 7 of 7

Thread: Missing the built-in Passengers <kuid:-3:10060> asset.

  1. #1
    Join Date
    Feb 2016
    Location
    Moose Rump, Canada
    Posts
    86
     

    Exclamation Missing the built-in Passengers <kuid:-3:10060> asset.

    Hello! I am using Build 98569 of TRS2019. The other day, I tried opening a couple of the built-in multiplayer sessions to see how they worked. I got the following error messages:



    Upon further inspection, I discovered that this asset is the built-in Passengers asset from TS12/Mac 2. Not having these assets means that none of the Built-In Multiplayer sessions or small CNR stations function properly. This is especially painful since these are both things that I use for my m120 youtube series on the regular. If there isn't some fix to this missing asset issue, multiplayer will not function correctly.

    Thank you for your time,
    -TrainmasterGT

  2. #2
    Join Date
    Sep 2015
    Location
    Australia, Victoria, Churchill
    Posts
    1,751
     

    Default

    The way I read that message, is that those assets are on your system and are preventing multiplayer from running. If they are, delete or disable them, run a quick DBR and try again.
    cheers
    Graeme

  3. #3
    Join Date
    Nov 2006
    Location
    Germany
    Posts
    2,192
     

    Default

    The latest version of the passengers is <kuid:-25:1235> Prod Passengers 2012, which is builtin in TRS19 and available at the DLS. This version obsoletes both versions (-3:10060 and -3:11060).

    Peter

  4. #4
    Join Date
    Feb 2016
    Location
    Moose Rump, Canada
    Posts
    86
     

    Default

    Quote Originally Posted by p-dehnert View Post
    The latest version of the passengers is <kuid:-25:1235> Prod Passengers 2012, which is builtin in TRS19 and available at the DLS. This version obsoletes both versions (-3:10060 and -3:11060).

    Peter
    Prod Passengers 2012 is built in, although it didn't obsolete the -3:10060 passengers asset, even after a database rebuild. Am I doing something wrong?

    Quote Originally Posted by grazlash View Post
    The way I read that message, is that those assets are on your system and are preventing multiplayer from running. If they are, delete or disable them, run a quick DBR and try again.
    cheers
    Graeme
    Those assets are not on my system, hence the thread. I did do a DBR but it didn't change anything.

  5. #5
    Join Date
    Oct 2011
    Location
    New Caledonia
    Posts
    3,306
     

    Default

    Quote Originally Posted by TrainmasterGT View Post
    Those assets are not on my system, hence the thread. I did do a DBR but it didn't change anything.
    Were they ever on your system? It appears that the system thinks that they are required. This will be because either the system still thinks they have obsoleted the correct versions (an extended DBR might fix that) or the sessions have been updated to refer to them (the sessions should be reverted to original).

  6. #6

    Default

    This is the latest update for the passenger product and replaces all those in the obsolete table.

    kuid <kuid:-25:1235>
    username "Prod Passengers 2012"
    kind "product"
    product-category <kuid:-3:10091>
    instance-type "instance"
    mass 65
    allows-mixing 1
    category-era "2000s;2010s"
    category-region "RU"
    category-class "IP"
    icon-texture "passengers.texture"
    trainz-build 3.5

    obsolete-table
    {
    0 <kuid:-3:10060>
    1 <kuid:-3:11060>
    2 <kuid:-3:11061>
    3 <kuid:-3:110060>
    4 <kuid:-3:12060>
    5 <kuid:-25:1188>
    }

    Are those multi player routes TRS19 or an earlier version of trainz where other players cant use the latest build?
    Last edited by stagecoach; January 9th, 2019 at 05:34 PM.

  7. #7
    Join Date
    Oct 2011
    Location
    New Caledonia
    Posts
    3,306
     

    Default

    Quote Originally Posted by stagecoach View Post
    ... and replaces all those in the obsolete table.
    But only if the internal obsolete table references are updated correctly. There is a lot of evidence that from TANE onwards obsoleting done in the obsolete-table (rather than through the version number) is not always effective. Perhaps rebuilding this table was removed from the quick DBR. I believe there is a way to force the internal table to be rebuilt by deleting something and rebuilding the database but I can't find the reference at the moment.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •