.
Results 1 to 14 of 14

Thread: Poor performance

  1. #1
    Join Date
    Nov 2006
    Location
    United States of America, New Jersey
    Posts
    9

    Unhappy Poor performance

    I downloaded Trainz Railroad Simulator 2019 yesterday and thus far I have been very disappointed in its performance. Nothing runs smoothly compared to Trainz: A New Era. I have tried numerous adjustments under Trainz Settings and see little difference. I surely hope I didn't throw $70.00 out the window. I started running a few of the tutorials and the performance is horrible. It shutters with every movement. My computer specs are:

    Asrock Z77 Extreme 4 motherboard
    Intel Core i7-2600K
    24GB DDR3
    GeForce GTX 1070Ti
    Asus G-Sync monitor 2560x1440
    SSD 480GB

    Any suggestions would be most appreciated. I am in desperate need of help.

  2. #2
    Join Date
    Nov 2006
    Location
    United States of America, Massachusetts, Haverhill
    Posts
    24,534

    Default

    Disable G-sync for starters. That is a known problem with the latest NVidia drivers and Windows 10 in general. There are many complaints about it in the NVidia support forum.

    Try these settings in TRS19 and see if they work for you. These are the settings I use:


    Shadow quality: High
    Main shadow resolution: 4096
    Shader quality: Standard
    Texture detail: Normal
    Post processing: High
    Detail scenery: Clutter + TurfFX
    Antialiasing: 4x

    Check boxes:
    Use multiple threads: Checked
    Process objects behind camera: Checked

    In game settings:

    Maximum Draw Distance: 8000 m
    Process Objects Behind Camera (checked)
    Scenery Detail: High
    Tree Detail: Normal
    Post Processing: High
    John
    Trainz User Since: 12-2003
    Trainz User ID: 124863
    T:ANE Build: 94829
    TRS2019: 98592

  3. #3
    Join Date
    Nov 2006
    Location
    United States of America, Colorado, Colorado Springs
    Posts
    330

    Default

    Use the task manager to make sure there is only one instance of TS19 running.
    Also see what else is running. Reboot Windows. It sounds to me like some other program(s) may be causing this.

  4. #4
    Join Date
    Nov 2006
    Location
    Spain, Barcelona
    Posts
    8

    Default

    Hi,

    Before doing anything, I advise you to read this thread.

    https://forums.auran.com/trainz/show...z-2019-Stutter

    You are not the only one who has performance problems in driver mode.

    Note: Try disabling HUD with the F5 key

    Greetings.
    Vicens
    User Since: 2002
    User ID: 53862

  5. #5
    Join Date
    Nov 2006
    Location
    Portugal, Setúbal, Pinhal Novo
    Posts
    37

    Default

    Hello.

    in my system, the ultra quality of shadows was lagging system to 10 fps...changed it to medium quality in launcher and get 30 fps now..

    read more here to help performance:
    http://www.trainzportal.com/blog/vie...e-requirements

  6. #6

    Default

    It's not really FPS the problem in fact but the constant stutters when the train is moving, HUD on or not (it's better without the HUD but does not resolve the issue).

  7. #7
    Join Date
    Nov 2008
    Location
    United Kingdom
    Posts
    14,325

    Default

    Something else to try, in the Nvidia Control Panel, find Vertical Sync and change it from Use the 3d application Setting to On.

    Apparently this is a known fix for in game stuttering in that it handles the frame rates in a different way to games, so it won't actually clamp them at say 60 FPS it apparently adapts to suit. Using that I'm getting between 50 and 75 FPS on a 60Hz monitor and no stutter.
    Malc


  8. #8
    Join Date
    Nov 2006
    Location
    United Kingdom
    Posts
    1,097

    Default

    I'm using an i5 4670K, with a GTX 770. With the tutorials I'm getting 30fps (upwards) and smooth display.

    You have added the TS19 program and data files locations to your virus checker's exclusion lists?
    You may need to check the "user" folder to see the location...

    Let us know how it goes,
    Colin

  9. #9

    Default

    Hi Dick --

    Your PC specifications are similar, if not marginally better, than mine.

    The settings I use are:
    _____

    Full Screen 1920 x 1080 : 60Hz
    Vertical Sync None
    _____


    Shadow High (Ultra tanks frame rates)
    Main Shadow 2048
    Shader Ultra (needs Ultra to show PBR textures)
    Texture High
    Post Low
    Water High
    Detail Clutter + TurfFx
    Anti 8x
    Detail Update High
    _____


    Max Draw 6000m
    Scenery Ultra
    Tree Ultra
    _____

    I generally get very good frame rates but that can be depend on the route. Some routes are frame rate killers. Can I suggest one (of mine) that is very frame rate friendly? Try this:

    https://forums.auran.com/trainz/show...illiput-Logger

    Also see some of my youtube videos. Search with "philskene". If you can't mach those frame rates then you do have some serious issues with your PC or the settings.

    Tell us how you go.

    Phil

  10. #10
    Join Date
    Nov 2006
    Location
    United States of America, Massachusetts, Haverhill
    Posts
    24,534

    Default

    Even my settings posted above work well on my Alienware 15 laptop with its now much older GTX980M, 32GB RAM, and i7 6700K.

    There's a lot more to performance than just the video card and processor. I have found some content-related performance issues which were solved by replacing the assets with better equivalents.

    On the system level, ensure that the antivirus software is not scanning the TRS19 executable and content folders. This constant scanning and checking of the individual files in the content folders can and will impact the performance horribly.
    John
    Trainz User Since: 12-2003
    Trainz User ID: 124863
    T:ANE Build: 94829
    TRS2019: 98592

  11. #11
    Join Date
    Mar 2016
    Location
    Australia, NSW, Gosford
    Posts
    368

    Default

    Fairly disappointed.
    After reading the thread decided to check my settings. When placing the 'shader quality to 'ultra', which is mentioned here as necessary to get the visual effect of PBR, then loading a recently uploaded route that took months to complete I notice that PBR and 'normal' [non PBR]texturing are incompatible. Also, for me, that ultra setting really slows everything down.

    Now I am wondering if the recently uploaded Southern Region - Brighton Line is looking lame! Seeing as it has both PBR and non PBR texturing. Do I have to make all textures PBR in order to eliminate what appears to be 'floating/shaded' textures, especially grass.

    Looks like I'll have to play around and see which settings suit best for my situation. Not everyone has super fast/powerful machines which seems N3V are requiring to run TRS19.

    Val.
    Where the hell is that fountain of youth

  12. #12

    Default

    Quote Originally Posted by clam1952 View Post
    Something else to try, in the Nvidia Control Panel, find Vertical Sync and change it from Use the 3d application Setting to On.

    Apparently this is a known fix for in game stuttering in that it handles the frame rates in a different way to games, so it won't actually clamp them at say 60 FPS it apparently adapts to suit. Using that I'm getting between 50 and 75 FPS on a 60Hz monitor and no stutter.
    Already tried that without success. The vsync setting on the graphic card doesn not give better performances than the one of the game unfortunetly in my case. I wonder how you can I have 75 FPS on a 60 Hz monitor with vsync "on" (on the graphic cards or in the game) because Vsync means that it tries to maintain the game with your refresh rate monitor in this case 60 so it should be 60 max and not 75 (witch means that the Vsync graphic card setting doesn't affect the game ?).

    However, I already have a pretty descent FPS (55-60), that's not really the pb for me (I say it again) but the constant stutters/jitters of the background object and models on road that are a game killer for me. But I could try again and I will to see if something has changed or not or if I missed something when I tested this setting, but I'm fed up spending my time to try to have something smooth when I can have it elsewhere.
    Last edited by CrystalNoir; January 12th, 2019 at 05:06 AM.

  13. #13
    Join Date
    Nov 2006
    Location
    Brighouse, West Yorkshire, United Kingdom
    Posts
    527

    Default

    Turn off 'use PhysX Simulation'

    I have very similar specs to you and when I was on the beta build it would not run with it turned on.

  14. #14
    Join Date
    Nov 2008
    Location
    United Kingdom
    Posts
    14,325

    Default

    Quote Originally Posted by CrystalNoir View Post
    Already tried that without success. The vsync setting on the graphic card doesn not give better performances than the one of the game unfortunetly in my case. I wonder how you can I have 75 FPS on a 60 Hz monitor with vsync "on" (on the graphic cards or in the game) because Vsync means that it tries to maintain the game with your refresh rate monitor in this case 60 so it should be 60 max and not 75 (witch means that the Vsync graphic card setting doesn't affect the game ?).

    However, I already have a pretty descent FPS (55-60), that's not really the pb for me (I say it again) but the constant stutters/jitters of the background object and models on road that are a game killer for me. But I could try again and I will to see if something has changed or not or if I missed something when I tested this setting, but I'm fed up spending my time to try to have something smooth when I can have it elsewhere.
    As I said apparently it handles vsync in a different way, whatever I don't normally need vsync anyway with a 1080TI, just tested it to see what if anything it did, Frame rates are way better with it off anyway, not that I'm obsessed with them.
    Malc


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •