.
Page 4 of 4 FirstFirst ... 234
Results 46 to 53 of 53

Thread: Trainz 2019 crashes when speed approaches 65 MPH.

  1. #46
    Join Date
    Nov 2006
    Location
    Australia, Qld
    Posts
    5,672
     

    Default

    It's actually fixed but missed the integration for SP1 by an hour or so. (i.e. it will be in the next update).
    Tony Hilliam

    Got questions about TRS19? Click here for TRS19 FAQs

    Looking for answers to in-game functionality? Click here for help

  2. #47
    Join Date
    Nov 2006
    Location
    United States of America, California, San Jose
    Posts
    5,108
    Blog Entries
    1
     

    Default

    And here I thought maybe he was speeding around curves without inclines too fast.

    Make train simulators great again #MTSGA obiter dictum

  3. #48

    Default

    The game program does not support 64MPH (103-104kph) variables

    103kph=64.0012245mph
    104kph=
    64.6225956mph

  4. #49
    Join Date
    Aug 2019
    Location
    United States of America, In Front Of My PC
    Posts
    232
     

    Default

    Does not happen when you drive slower.

    I drive at yard switching speeds of 1 mph - 5 mph, with a top mainline speed of 10 mph - 35 mph max.

    Your trains running at 104KPH (64MPH) will be an absolute blurrrrrr zooming by !

    Have fun, and learn to drive slower, or enjoy crash to desktop all the time.
    I want all my performance sliders set to "Full"

  5. #50
    Join Date
    Nov 2006
    Location
    Australia, Qld
    Posts
    5,672
     

    Default

    Interestingly the problem is/was totally related to OpenAL (https://en.wikipedia.org/wiki/OpenAL). Our code was correct as per the OpenAL documentation, but not as per the OpenAL headers. This suggests that the OpenAL implementation itself has a bug (i.e. doesn't match its own formal specification). Since we can't do anything about that, and since clamping to the range specified in the headers appears to resolve the issue, that's the fix we've implemented. (To be included in the next update).
    Tony Hilliam

    Got questions about TRS19? Click here for TRS19 FAQs

    Looking for answers to in-game functionality? Click here for help

  6. #51
    Join Date
    Aug 2009
    Location
    United States of America, CA
    Posts
    2,822
     

    Default

    Quote Originally Posted by Tony_Hilliam View Post
    Interestingly the problem is/was totally related to OpenAL (https://en.wikipedia.org/wiki/OpenAL). Our code was correct as per the OpenAL documentation, but not as per the OpenAL headers. This suggests that the OpenAL implementation itself has a bug (i.e. doesn't match its own formal specification). Since we can't do anything about that, and since clamping to the range specified in the headers appears to resolve the issue, that's the fix we've implemented. (To be included in the next update).
    Don't forget game "Pause" in surveyor fix, please.

    John

  7. #52
    Join Date
    Nov 2013
    Location
    United Kingdom
    Posts
    10
     

    Default

    Hey, just wondered, as the thread has gone a bit Q since the 10th, is there any further progress reports?

    cheers.

  8. #53
    Join Date
    Nov 2006
    Location
    United States of America, Massachusetts, Haverhill
    Posts
    25,721
     

    Default

    Quote Originally Posted by MetCam101 View Post
    Hey, just wondered, as the thread has gone a bit Q since the 10th, is there any further progress reports?

    cheers.
    It could be the devs are busy. It's been said here, by Tony Hilliam by the way, that when we don't hear from anyone in management it means they're busy. With the issue being related to the Open/AL, it could mean they need to find a workaround to get past the bug in the code that's not even their fault because they based the work on the specs given. Tony will update us at some point, I'm sure.
    John
    Trainz User Since: 12-2003
    Trainz User ID: 124863
    T:ANE Build: 94829
    TRS2019: 98592

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •