.
Results 1 to 3 of 3

Thread: Help... Missing bogey dependency (apparently!? Strange behaviour)

  1. #1
    Join Date
    Nov 2006
    Location
    United Kingdom, Essex, Colchester
    Posts
    1,510

    Default Help... Missing bogey dependency (apparently!? Strange behaviour)

    I'm stumped!!

    I have a SP 70ton hopper I was moving over to TANE. TANE complains it is missing <kuid:156765:1599>.

    Now back in TS12, this isn't even listed as a dependency when going to 'view dependencies' Yet is in the KUID table and the config file as the bogey.
    In game the hopper displays fine.. with bogies.

    If I search this kuid in TS12 Content manager it finds nothing. Yet it's the bogey in the config file and the bogey and hopper display in game.

    Someone please explain how this is possible!?
    (i also can't find this kuid anywhere online to test it and get it into TANE)

    Cheers

  2. #2

    Default

    It was in USLW's "Rolling stock dependencies.cdp", but those bogeys are remove from the site currently due to outdated and have normal map missing bug.
    https://web.archive.org/web/20120705...wnloads/files/

    EDIT: If you need to fix normal map problem in some bogey, you need this software to remove normal map reference in those bogey mesh file.
    https://forums.auran.com/trainz/show...36#post1624736
    But in my enviroment this software not work on my win10, but work on win7 via VM with text size set to 100% in windows setting.
    Last edited by TimLee_TW; May 22nd, 2018 at 09:13 PM.

  3. #3
    Join Date
    Nov 2006
    Location
    United States of America, Massachusetts, Haverhill
    Posts
    22,212

    Default

    Quote Originally Posted by Davie_UCF View Post
    I'm stumped!!

    I have a SP 70ton hopper I was moving over to TANE. TANE complains it is missing <kuid:156765:1599>.

    Now back in TS12, this isn't even listed as a dependency when going to 'view dependencies' Yet is in the KUID table and the config file as the bogey.
    In game the hopper displays fine.. with bogies.

    If I search this kuid in TS12 Content manager it finds nothing. Yet it's the bogey in the config file and the bogey and hopper display in game.

    Someone please explain how this is possible!?
    (i also can't find this kuid anywhere online to test it and get it into TANE)

    Cheers
    This is most likely a built-in asset which is referenced by the SP Hopper, and sometimes when gathering dependencies, these assets are not always found.

    I've had luck searching for the author then sorting on KUIDs in TS12 Content Manager.

    I use the #Author ID format like this: #156765 in the author search.

    When all of that author's assets list, I then sort by Kuid by clicking on the column. Ensure you display that column if you do not have it set like that already.

    With the KUIDs in numerical order, you should be able to find that asset.

    Now as an FYI, there's a chance you may not be able to export that asset anyway if it's a payware item and this is TS12 build 61388. At TS12 SP1 HF4, the built-in and DLC content was copy protected, which means it can't be exported, or if it is, it can't be repaired due to being compressed.
    John
    Trainz User Since: 12-2003
    Trainz User ID: 124863
    TS12 Build: 61388
    T:ANE Build: 90955

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •