.
Results 1 to 11 of 11

Thread: Legacy of BN V2 - Faulty Dependency

  1. #1
    Join Date
    Sep 2008
    Location
    United States of America, Wyoming, Evanston
    Posts
    202

    Default Legacy of BN V2 - Faulty Dependency

    While working on some sessions for the Legacy of the Burlington Northern V2, I've noticed the route has a faulty dependency. This might have come up before but if so I missed it.

    The asset is:

    <kuid:321936:101444> RR Crossing 12x20M ST

    The errors, etc. are:

    ! <kuid:321936:101444> VE48: This asset uses an obsolete trainz-build number. Trainz-build numbers below 3.5 are no longer supported.
    - <kuid:321936:101444> VE170: Failed to open compiled texture 'gate_bump.texture' for 'arc:fld:$(local)/hash-2C||kuid 321936 102110.tzarc|'
    - <kuid:321936:101444> VE165: Texture 'gate_bump.texture' is missing or could not be loaded in mesh '1220.im', material 'gate.m.tbumptex'.
    ! <kuid:321936:101444> VE186: Material 'arc:fld:$(local)/hash-2C||kuid 321936 102110.tzarc|**gate.m.tbumptex' is shared between multiple chunks in this asset but the material parameters conflict.
    ! <kuid:321936:101444> VE144: Category code 'ZX - Paintshed template' is obsolete.
    ! <kuid:321936:101444> VE109: The low-detail meshes total more than 500 polygons. This may have a negative impact on performance: 0: 5188

    The asset dependencies are:

    <kuid2:122285:900:1> AJS American Crossing Code Library
    <kuid:321936:100929> E Bell RR Crossing
    <kuid:321936:101442> Safetran Hybird M Bell RR Crossing
    <kuid:321936:102110> Safetran RR Crossing Mesh Library
    <kuid:321936:102206> RR Crossing Track Plate Textures
    <kuid:321936:102207> RR Crossing Library Textures
    <kuid:321936:102212> RR Crossing Corona
    <kuid:-25:893> Track Invisible

    I think I've found at least one instance of the use of the asset about a mile west of Vernon on the mainline. There are two rather large orange wire cages at a road crossing (probably the crossing gates or such).

    Do I need to download an updated version of one of the above dependencies? If so are they on the Jointed Rail site?

    Anyway, a little help would be appreciated so I can clean up the route's asset.

    Thanks much and take care,
    Don Bennett Evanston, WY USA Windows 10 T:ANE Deluxe 94829 TS2019 96000

  2. #2
    Join Date
    Dec 2009
    Location
    PA and TN
    Posts
    1,804
    Blog Entries
    1

    Default

    That asset is in here:
    http://jointedrail.com/product/safetran-crossing-pack/

    Fairly sure the fixed copy of this should be in here, make sure to commit anything overwritten when you install this again.

  3. #3
    Join Date
    Sep 2008
    Location
    United States of America, Wyoming, Evanston
    Posts
    202

    Default

    Quote Originally Posted by jointedrail View Post
    That asset is in here:
    http://jointedrail.com/product/safetran-crossing-pack/

    Fairly sure the fixed copy of this should be in here, make sure to commit anything overwritten when you install this again.
    Ok, I downloaded the pack (twice) and installed it (twice) and committed all the "open for edit" assests (twice) but the crossing:

    <kuid:321936:101444> RR Crossing 12x20M ST

    still came up faulty. The errors and warnings, again, were:

    ! <kuid:321936:101444> VE48: This asset uses an obsolete trainz-build number. Trainz-build numbers below 3.5 are no longer supported.
    - <kuid:321936:101444> VE170: Failed to open compiled texture 'gate_bump.texture' for 'arc:fld:$(local)/hash-2C||kuid 321936 102110.tzarc|'
    - <kuid:321936:101444> VE165: Texture 'gate_bump.texture' is missing or could not be loaded in mesh '1220.im', material 'gate.m.tbumptex'.
    ! <kuid:321936:101444> VE186: Material 'arc:fld:$(local)/hash-2C||kuid 321936 102110.tzarc|**gate.m.tbumptex' is shared between multiple chunks in this asset but the material parameters conflict.
    ! <kuid:321936:101444> VE144: Category code 'ZX - Paintshed template' is obsolete.
    ! <kuid:321936:101444> VE109: The low-detail meshes total more than 500 polygons. This may have a negative impact on performance: 0: 5188

    Don't know what to tell you. I have nothing open for edit in the content manager so that's not the problem.

    Anyway, thanks in advance for any help,
    Don Bennett Evanston, WY USA Windows 10 T:ANE Deluxe 94829 TS2019 96000

  4. #4
    Join Date
    Nov 2006
    Location
    France
    Posts
    1,255

    Default

    Not faulty in T:ANE 88364 (got it with the route on JR's site).

  5. #5
    Join Date
    Nov 2006
    Location
    United States of America, Massachusetts, Haverhill
    Posts
    23,354

    Default

    Quote Originally Posted by jointedrail View Post
    That asset is in here:
    http://jointedrail.com/product/safetran-crossing-pack/

    Fairly sure the fixed copy of this should be in here, make sure to commit anything overwritten when you install this again.
    Thanks for the updated parts. The mesh dependency says fixed in the name. I fixed the texture issue ages ago, but I'll replace mine with the updated parts.
    John
    Trainz User Since: 12-2003
    Trainz User ID: 124863
    TS12 Build: 61388
    T:ANE Build: 90955

  6. #6
    Join Date
    Sep 2008
    Location
    United States of America, Wyoming, Evanston
    Posts
    202

    Default

    Ha! I had a thought that the asset might be in my TS12 content and, yes, it was! And it was apparently the "fixed" version. I made a .cdp file and imported into T:ANE and everything is just fine.

    I should have thought of this earlier.

    Thanks,
    Don Bennett Evanston, WY USA Windows 10 T:ANE Deluxe 94829 TS2019 96000

  7. #7
    Join Date
    Nov 2006
    Location
    New Jersey, Mine Hill
    Posts
    2,213
    Blog Entries
    1

    Default

    Sorry to bump this up but I'm having the same issue in Ver1 with 3 12x20 crossing gates. I put in a ticket at JR and Kevin has been trying to figure this out but nothing has worked so far. I've re downloaded the gate file, reinstalled the crossing pack mentioned above but nothing has worked. I want to get Ver2 of the route but I'm concerned that the issue will persist.. 99% of the world can install this with no problems, I seem to have fallen into the 1%...and not in a good way.
    Last edited by boc61; September 21st, 2018 at 10:24 AM.
    "My wife says that if I buy one more train, she is going to leave me. I'm going to miss her."

  8. #8
    Join Date
    Nov 2006
    Location
    New Jersey, Mine Hill
    Posts
    2,213
    Blog Entries
    1

    Default

    Call the ASPCA as I am about to beat the dead horse. I spent the entire weekend on this, it brought my OCD level to Defcon 1. I reinstalled the Safetran pack several times to no avail. I tried bringing the files from my TS 12 installation over, that failed as well. Then I reinstalled the Legacy dependencies pack and that fixed 2 of the 3 crossings but the 12 x 20ST LA just refuses to fix itself. *shakes fist I even went to church yesterday and asked the Blessed Mother if she could figure this out........

    I guess I'll have to substitute a different crossing for the faulty one unless some deep thinker has a stroke of inspiration.

    Quote Originally Posted by JCitron View Post
    Thanks for the updated parts. The mesh dependency says fixed in the name. I fixed the texture issue ages ago, but I'll replace mine with the updated parts.
    If this the 'gate_bump' texture issue, I'd be indebted to you for life if you said how you fixed it.
    Last edited by boc61; September 24th, 2018 at 01:18 PM.
    "My wife says that if I buy one more train, she is going to leave me. I'm going to miss her."

  9. #9
    Join Date
    Nov 2006
    Location
    United States of America, Massachusetts, Haverhill
    Posts
    23,354

    Default

    Quote Originally Posted by boc61 View Post
    Call the ASPCA as I am about to beat the dead horse. I spent the entire weekend on this, it brought my OCD level to Defcon 1. I reinstalled the Safetran pack several times to no avail. I tried bringing the files from my TS 12 installation over, that failed as well. Then I reinstalled the Legacy dependencies pack and that fixed 2 of the 3 crossings but the 12 x 20ST LA just refuses to fix itself. *shakes fist I even went to church yesterday and asked the Blessed Mother if she could figure this out........

    I guess I'll have to substitute a different crossing for the faulty one unless some deep thinker has a stroke of inspiration.



    If this the 'gate_bump' texture issue, I'd be indebted to you for life if you said how you fixed it.
    It is.

    I simply found another crossing with the same texture name in it.
    Copied the texture out and then pasted it into the broken one.
    Problem solved.

    Forever indebted. Go play the lotto and if you win, send a percentage to the ASPCA.
    John
    Trainz User Since: 12-2003
    Trainz User ID: 124863
    TS12 Build: 61388
    T:ANE Build: 90955

  10. #10
    Join Date
    Nov 2006
    Location
    New Jersey, Mine Hill
    Posts
    2,213
    Blog Entries
    1

    Default

    You know I actually thought of that. I opened on of the working crossings in the Safetran set, the compared it with the faulty one and there no difference. Nothing in the good one that isn't in the bad one:

    This is the faulty crossing




    This is a working one

    "My wife says that if I buy one more train, she is going to leave me. I'm going to miss her."

  11. #11
    Join Date
    Nov 2006
    Location
    United States of America, Massachusetts, Haverhill
    Posts
    23,354

    Default

    I'll PM you...
    John
    Trainz User Since: 12-2003
    Trainz User ID: 124863
    TS12 Build: 61388
    T:ANE Build: 90955

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •