.
Results 1 to 8 of 8

Thread: Need help to reinstall TS12 and T:ANE after Windows 10 crashed

  1. #1
    Join Date
    Nov 2006
    Location
    Canada, Quebec, Montreal
    Posts
    1,924
     

    Default Need help to reinstall TS12 and T:ANE after Windows 10 crashed

    Hi fellow trainzer, Last week I have upgraded from Win 7 to Win 10. Yesterday I had my first ever major crash since I got PCs (almost 20 years). No rescue disk. Fortunately T:ane and Ts 2012 are on disk B while the OS which I format is on ''C''. I reinstalled Win 7. Some missing dll make my, both trainz installation they do not want to start. Which way is the better to reinstall but whithout loosing my content, or which folder do I have to backup and reinstall ?

    Is there a way to avoid redownloading T:ane's 8 Gb patch and install only what is missing ? Same question for TS 2012.

    Thank you for your help !
    Rail4Pete

  2. #2

    Default

    You can buy Trainz 2012 and T:ANE digitally at their current respective builds. As for backing up content, it should be in the user data original folder. Not sure though.

  3. #3
    Join Date
    Nov 2006
    Location
    United Kingdom, Worcestershire
    Posts
    30,794
    Blog Entries
    22
     

    Default

    Can I ask which file it says is missing? The likely one is d3dx9_43.dll - if this is the case, reinstall DirectX 9.

    Shane
    Shane Turner
    Technical and DirectX Advisor - Not affiliated with N3V

    My Forum -- PevSoft Tools -- Tutorial List (inc DirectX) -- My Utilities --TrainzTutorials.com

  4. #4
    Join Date
    Nov 2006
    Location
    Canada, Quebec, Montreal
    Posts
    1,924
     

    Default

    Quote Originally Posted by shaneturner12 View Post
    Can I ask which file it says is missing? The likely one is d3dx9_43.dll - if this is the case, reinstall DirectX 9.

    Shane
    Hi Shane, T:ANE is missing ''MSVCR120.dll'' and TS2012 is missing ''d3dx9_43.dll'' ...so I will reinstall DirectX 9 and see if TS 2012 is starting up.
    Thanks !
    Pierre

  5. #5
    Join Date
    Nov 2006
    Location
    Canada, Quebec, Montreal
    Posts
    1,924
     

    Default

    Hi Shane, I did reinstall Direct X 9.0c but I still get the same message from TS12.
    Thanks!
    Pierre

  6. #6
    Join Date
    Nov 2006
    Location
    United States of America, Massachusetts, Haverhill
    Posts
    26,349
     

    Default

    Hi Pierre,

    Try running the program in Open/GL and see if that helps.
    John
    Trainz User Since: 12-2003
    Trainz User ID: 124863
    T:ANE Build: 94829
    TRS2019/Trainz-PLUS: 105100

  7. #7
    Join Date
    Nov 2006
    Location
    Canada, Quebec, Montreal
    Posts
    1,924
     

    Default

    TS2012 now works. I tried another link to reinstall Direct X and now that works.

    T:ANE: A search on Google brought me to reinstalled Visual C++ Redistributable Packages for Visual Studio 2013
    BUT I got to figure out why it is asking me to redownload the dependencies packages.....

    Pierre

  8. #8
    Join Date
    Nov 2006
    Location
    United States of America, Massachusetts, Haverhill
    Posts
    26,349
     

    Default

    Quote Originally Posted by Rail4Pete View Post
    TS2012 now works. I tried another link to reinstall Direct X and now that works.

    T:ANE: A search on Google brought me to reinstalled Visual C++ Redistributable Packages for Visual Studio 2013
    BUT I got to figure out why it is asking me to redownload the dependencies packages.....

    Pierre
    T:ANE asking? It will do that if you have the Deluxe version because the base program is the same for all versions. It's the payware routes and sessions that make the difference and because your database references were broken during the reinstall, you are going to have to re download these again. It's no big deal.

    Good news on the progress anyway. One thing at a time they say.

    John
    John
    Trainz User Since: 12-2003
    Trainz User ID: 124863
    T:ANE Build: 94829
    TRS2019/Trainz-PLUS: 105100

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •