.

Search:

Type: Posts; User: umanbooks

Search: Search took 0.01 seconds.

  1. Sticky: it's ok,i found one for TS2012,but can found...

    it's ok,i found one for TS2012,but can found patch to update v6.2c to an other version,but if some ne are have TS2012,this is the link of site:
    http://www.justtrains.net/railworks-compatibility
  2. Sticky: Many Thank's,ut i dont understand,i have train...

    Many Thank's,ut i dont understand,i have train simulator deluxe 2012 v6.2c,so how to update it?many many build numbers,and fix...........i'm not computer,i'm just a human.i type in google bar:train...
Results 1 to 2 of 2