PDA

View Full Version : TRS2004 TrainzObjects Issue



Col_Klink
January 25th, 2013, 12:49 PM
Greetings All (from a long time back.........)

Something strange has happened that has not happened before.
First of all, I rarely post anything here since TRS2006 was staged. But I do have an issue I cannot get out of.
I am running TRS'04 since 2005 and usually have no difficulties on a Windows XP O/S with an nVidia graphics 8800GT. Here's the issue - currently, one of the Euro assets caused a system termination and I had to reload many items to get it to run again. Once I had it going, just a little, I installed TrainzObjects (TAFWEB) and checked it and was okay. THEN I put in Object Explorer (Tolaris) and must have clicked on the wrong folder for the install.
Now, what happens is that once I have the TrainzObjects open to check a view of an object, the TOE opens up and not the Objects Explorer (Tolaris) I want. I have reinstalled the entire TRS'04 twice (2 Discs) and made sure it all was clean and carefully watched everything go smoothly.

I would love to know how to change the path so I can open the assets with Object Explorer Viewer (Tolaris) and not Terry Franks TrainzObjects editor. Any help would be huge as I am enjoying a lot of the Polish, German, Russian and Bulgarian assets while building a nice Euro route.
If this sounds a little 'muddy' to you, I'll try again to explain better on another post.

The Colonel :cool:

wreeder
January 26th, 2013, 06:38 AM
Hi Colonel,

I'm not sure I understand but click on the Menu button at the bottom right of the TrainzObjectz screen and look at the Program Location setting value. This should allow you to point the view object menu choice to the program you want.

William

Col_Klink
January 26th, 2013, 09:02 AM
Hi William
I tried your suggestion and it worked. I have only used the Menu button for a few things but not the
path to the Objects Explorer. Thankyou sooo much for the quick response and the working solution.

The Colonel

Dinorius_Redundicus
January 26th, 2013, 06:16 PM
Colonel Klink

Trainz Object Explorer was having trouble opening some types of mesh when I last used it (several years ago). If you find the same thing, try 'pointing' the Trainzobjectz menu to PEV Mesh Viewer, instead of at TOE. It should work more successfully and has the advantage that you can use it to create a 240x180 thumbnail if the asset doesn't already have one. It will be called $screenshot$.jpg by default, which is exactly the naming convention that Trainzobjectz expects.

[Additional comment: I just tried this and it does work. The only thing to be aware of is that when you right-click an asset and choose Edit/View - View in TOE, PEV Mesh Viewer always opens in minimized mode. Look for it on your taskbar and simply maximize it to see the selected asset.]