PDA

View Full Version : CMP download helper question



jjanmarine3
June 8th, 2012, 01:09 PM
Can you pse explain to me : When one dl an asset in CM+ and the window opens up it shows a DS , a tick, the name of the asset and the size.
What does it mean when one wants it to dl but a dash (-) appears in the last square and CM is idle.

shaneturner12
June 8th, 2012, 01:15 PM
Usually, a - or a N/A in the size column can mean one of three things:

1.The asset is already installed.
2.The asset is built-in.
3.The asset is not on the Download Station, or Content Manager cannot get the information required about the asset.

For earlier versions of Trainz, this can also mean that the trainz-build for that asset is higher than the version you are running.

Shane

jjanmarine3
June 8th, 2012, 01:26 PM
Thanks Shane .

May I ask another question relating to 'For earlier versions of Trainz, this can also mean that the trainz-build for that asset is higher than the version you are running.'

When I look in the config of assets, I see the build number ( I don't know of any other way to check yet ) Can we manipulate this build number to make things work and if so, plse tell me how.

Jan





Jan

shaneturner12
June 8th, 2012, 01:28 PM
It is possible by adjusting the trainz-build value. See http://online.ts2009.com/mediaWiki/index.php5/Trainz-build for the values.

Be aware that this can cause additional issues due to changes in later versions (for example, Trainz Classics used the default.im naming method, whereas older versions did not).

Shane

jjanmarine3
June 8th, 2012, 01:35 PM
Thanks for the help .
Looks like I am going to have to attend Trainz university to deal with all these issues :'(

shaneturner12
June 8th, 2012, 01:39 PM
It's mainly routes,sessions,locomotives,rolling stock, and rules/driver commands that you want to watch out for. Scenery and industry items can sometimes be a problem if they are scripted.

If you do come across an issue when backdating, just post the issue, and either me or someone else will be able to advise.

Shane

jjanmarine3
June 8th, 2012, 02:06 PM
I have a problem at the moment with a steam locomotive I exported from TS12 to TR2006 but it is not showing in railyard and there are numerous things for me to look at that don't make sense at the moment , but I want to try and sort it myself -
If I can't do it I will post the details thanks. Perhaps other guys can learn too.

shaneturner12
June 8th, 2012, 02:13 PM
That's the good thing if you do post the information, as others can make the same fixes.

Shane

jjanmarine3
June 8th, 2012, 02:38 PM
That's the good thing if you do post the information, as others can make the same fixes.

Shane

Ok. let me just get my bearings so I can post what I think ( no guarantees ) is the relevant info.

Jan

shaneturner12
June 8th, 2012, 02:45 PM
The main information required at this point in time is any errors that are reported in Content Manager.

Shane

jjanmarine3
June 8th, 2012, 03:50 PM
30NG Porter 0-4-0T Loco. Author Pencil42

Some history first because I used your tutorial and imported this loco from TS12, using the picklist, but I don't know if i did it correct. The loco works in T!@ and there are no errors there , just a warning about an obsolete build number below 2.7 that is no longer supported.
When I browse in CMP I see info with the author and two assets , one with the missing dependency icon but I can't seem to pick up which dependency is missing , all it tells me when viewing in main list is that there are 6 on DS.
Maybe I am browsing wrong ?

jjanmarine3
June 8th, 2012, 03:53 PM
Sorry 4got - < kuid2:124060:1008:3> .

shaneturner12
June 8th, 2012, 04:04 PM
If it's a missing dependency problem, right-click the asset and click View Dependencies, then post any KUIDS that are showing with a ?.

Shane

jjanmarine3
June 8th, 2012, 04:21 PM
There are no kuids marked with a ? This is what I see.

Download Station: 040enginespec
Not faulty: 30NG Porter 0-4-0T Interior
Not faulty: invisible_bogey
Download Station: JintyEngineSound
Download Station: NG30 Porter 040T invisible bogie
Download Station: NG30 Porter 040T steam bogie
Download Station: Union Pacific small whistle and bell
Not faulty: Water
Download Station: Wood Loco Fuel V2

clam1952
June 8th, 2012, 07:31 PM
Already got it in 2010 but just downloaded from the DLS, all intact with no errors or anything missing. Either drag the loco to the Download helper window and download which should get the rest of it.

jjanmarine3
June 9th, 2012, 12:14 AM
Thanks clam I am going to try that, just not sure how it will work out from TR12 to TS06 with the build numbers .
I saw in TS12 that there are warnings regarding obsolete stuff not being supported below 2.7 and this asset is 2.4 .
I also see I have stuff hanging around from build 1.3... I presume this happens when one dl's stuff and you don't really know what you are doing :confused: ?
I am not sure at all what is cooking with that issue .

jjanmarine3
June 9th, 2012, 02:24 AM
I also notice that this asset can be 'viewed in railyard ' when r-clicking on it - but when I do CMP shuts down and dissapears. Is this the effect of the missing dependancy ?

In the actual railyard, the spirit is there, but the body is still floating around somewhere.

shaneturner12
June 9th, 2012, 02:31 AM
The View in Railyard will open Trainz to show you the item. Once Trainz is closed, Content Manager will appear automatically.

A shortcut for installing missing dependencies that are on the download station is to right-click the asset and click Download.

Shane

jjanmarine3
June 9th, 2012, 03:03 AM
The View in Railyard will open Trainz to show you the item. Once Trainz is closed, Content Manager will appear automatically.

A shortcut for installing missing dependencies that are on the download station is to right-click the asset and click Download.

Shane

Hi Shane.

CMP dissappears completely and trainz does not open up altough the option to view in railyard is active.

I have to open CMP anew after this has happened and the asset will not dl at all - I had understood that it might be because of the reasons you mentioned earlier in the thread relating to the dash (-) in the dl helper window.

I have not changed anything regarding the build number or tried what clam has suggested yet becuase I am not sure what to do first.

Jan

jjanmarine3
June 9th, 2012, 05:19 PM
It is possible by adjusting the trainz-build value. See http://online.ts2009.com/mediaWiki/index.php5/Trainz-build for the values.

Be aware that this can cause additional issues due to changes in later versions (for example, Trainz Classics used the default.im naming method, whereas older versions did not).

Shane

Thank you I read above media and there is have to know stuff in there that all trainzers should know .

Once again I have a question - I do not pick up how to adjust trainz build values , possibly I missed it for there is much stuff to read.

I seem to read between the lines that one can not use some assets (however hard you try) because they will no longer be supported . Is this why I cannot install this TR12 asset into TS2006 or is the problem me that does not understand how to find amissing dependency.
Thanks for your patience whoever reads this thread and possibly gets frustrated.:wave:

Jan

clam1952
June 9th, 2012, 06:24 PM
Right click in content manager, open for edit in explorer, double click config text which opens in notepad, edit the line that says trainz-build to read 2.6 I think it is for 2006 save, close the explorer window and commit.

I think the problem you are having is just down to the build number which 2006 doesn't know what to do with. Never had 2006 so I'm just guessing from experience of backdating from TS12 to TC3. Newer versions of Trainz flag a build number higher than the version as an error, going by TC3 old versions don't flag it as an error it just doesn't work.

jjanmarine3
June 9th, 2012, 06:40 PM
Right click in content manager, open for edit in explorer, double click config text which opens in notepad, edit the line that says trainz-build to read 2.6 I think it is for 2006 save, close the explorer window and commit.

I think the problem you are having is just down to the build number which 2006 doesn't know what to do with. Never had 2006 so I'm just guessing from experience of backdating from TS12 to TC3. Newer versions of Trainz flag a build number higher than the version as an error, going by TC3 old versions don't flag it as an error it just doesn't work.

I need to just tell you from your previous answer in #16 that everything relating to this kuid that I tried to drag and drop anywhere ended up lying idle in the dl helper windows which makes me think you are correct about TR2006 not knowing what to do with it. I will try this fix tomorrow and let you know. Hope it works , I really like this loco and want it to work in 06. There are plenty other assets after this that will be cool in TR2006 . have to watch for Shanes warnings though....
and thanks to all so far :)

jjanmarine3
June 10th, 2012, 10:24 AM
I eventually got this loco to work in TR06.
I have been trying to dl the dependencies which it showed me I needed, which are on the DS, but every time I tried to dl it would lie idle in the dl helper.
Today I learnt by scratching here and ticking there that if stuff lies idle in the dl helper window for some reason and I untick the first tick, then the start button comes up and it either downloads or a cow starts mooing whlie red script says it can't find a URL. Lucky for me the cow was quiet this time .
The loco now appears in the railyard and works fine in the game, but the bogeys are still missing . I am working on that now .
Hope this makes sense and thanks for the help to all.

Jan

shaneturner12
June 10th, 2012, 10:29 AM
That's a good sign - if you do run into other issues, post them here.

Shane

jjanmarine3
June 10th, 2012, 10:47 AM
Will do.

Thanks Shane

Jan

jjanmarine3
June 10th, 2012, 11:38 AM
It seems I still have only one troublesome unknown dependency < Kuid 44700:55317> in the NG30's which is causing other dependant assets trouble , which is connected somehow to the NG24's - which still has much stuff not working in my CM. Most of the last mentioned also begin with 44700 :

I can't find this unknown dependency <Kuid 44700:55317> and it's dependant asset <kuid 44700:18205> on google and the closest I get is Sirgibbys. The dependant asset is <kuid 44700:18205>

If somebody can please help me further on my merry way by helping me to find them it will be great.

Jan