PDA

View Full Version : Attn N3V...What's happened to the TrainzDEV WIKI?



PEV
June 7th, 2012, 06:50 PM
I am trying to get into the TrainzDEV WIKI and I am getting the following errors.


Warning: Parameter 2 to Parser::parse() expected to be a reference, value given in /var/www/html/External/online/mediaWiki/includes/StubObject.php on line 58

Fatal error: Call to a member function getCacheTime() on a non-object in /var/www/html/External/online/mediaWiki/includes/Article.php on line 3387

N3V, please fix this as I need to change references to my Trainz Tools.

Thanks

ZecMurphy
June 7th, 2012, 07:44 PM
Hi Peter
We have tested this here (from a few different locations), and we are not seeing this issue.

Just to confirm, are you able to access the wiki here: http://online.ts2009.com/mediaWiki/index.php5/TrainzDev_Wiki

Regards
Zec

ZecMurphy
June 7th, 2012, 07:44 PM
Hi Peter
We have tested this here (from a few different locations), and we are not seeing this issue.

Just to confirm, are you able to access the wiki here: http://online.ts2009.com/mediaWiki/index.php5/TrainzDev_Wiki

Regards
Zec

Pencil42
June 7th, 2012, 07:46 PM
works from here, also

Dinorius_Redundicus
June 7th, 2012, 11:05 PM
OK from here in NSW as well. The link to the 'tools' page within the Wiki works too.

shaneturner12
June 8th, 2012, 03:13 AM
It may be connected to an issue I mentioned involving the TS2009 SP4 main menu screen.

http://forums.auran.com/trainz/showthread.php?89616-Oddity-on-main-Trainz-menu-(not-Launcher)-server-issue-maybe

Shane

EDIT: Checked my TS2009 SP4 this morning and the problem seems to have solved itself.

PEV
June 8th, 2012, 08:25 AM
Zec,

Thanks for your prompt reply on this.

The link you provided is the same as the one I always use. That page works for me but nothing much else does.

I have changed my password, tried it from different computers (apple and PC) in different locations, and I still can't get past the opening page of the TrainzDEV wiki, plus a few parallel pages. As soon I try to go further I get the error messages.. nothing else on the page.

Same error messages in all cases.

When I'm not logged in I can get to the pages but obviously can't do the edits that I want.

RPearson
June 8th, 2012, 04:10 PM
Peter I just got the same error message.

Jusy to clarify I can access the wiki but trying to view the discussions tab or anything that requires login permissions I get the error you quoted after I successfully logged in and tried to access them.

Bob Pearson

PerRock
June 8th, 2012, 05:43 PM
I'm getting the error as well. Logging in and viewing the. Main page works, but not much else. Tested on my Android phone using It's default browser.

Peter

PEV
June 8th, 2012, 06:40 PM
Bob and Peter,
Thanks for verifying the error. I was begining to think I was persona-non-grata..

shaneturner12
June 9th, 2012, 02:22 AM
I can also confirm a problem on the Wiki site.

Steps to reproduce:

1.Visit http://online.ts2009.com/mediaWiki
2.Click Login - this will redirect the page.
3.Enter your username and password
4.Click Wiki.
5.Click the Discussion tab at the top.

Shane

P.S. Just found another whilst visiting http://online.ts2009.com/mediaWiki/index.php5/%22Thumbnails%22_container whilst being logged in to the Wiki system.

mjolnir
June 9th, 2012, 09:36 PM
My attempt to access a different page,

http://online.ts2009.com/mediaWiki/index.php5/HowTo/Export_from_Blender

gives the identical error that Peter V obtained. I can get to the top level page cited in the link provided by Zec, but any attempt to get to a different page, whether by typing in the link in the URL bar, or by clicking on a link on the TrainzDEV main page, give the same error.

Is it out of order here, since TRS has migrated from the 2009 to the 2012 flavor. to suggest revisiting the overall layout of the WIKI pages? If asked, my suggestion would be to move the page to something more general, and use categories to differentiate pages which are particular to a specific Trainz version.

Later edit: As of about 16 hours later, I'm able to access any page.

ns

PEV
June 11th, 2012, 06:08 PM
Zec,
Just a reminder that you need to be logged in and attempting to navigate around the Wiki to raise the errors mentioned above.

The errorrs are still occurring..

Thanks again

PEV
June 13th, 2012, 06:40 PM
Bump... Hello N3V.. We need some help here. TrainzDEV Wiki is still not working when logged in.

PEV
June 18th, 2012, 11:51 PM
Bump AGAIN... Is there any body home at N3V?

Spiffy
June 24th, 2012, 10:04 PM
Hi we are working on trying to resolve this issue though it is a pretty complicated situation due to it tying into everything else.

PEV
June 24th, 2012, 10:21 PM
Thank you. I understand.. Hopefully not too complicated..

Spiffy
June 27th, 2012, 08:04 PM
We are making progress on this, editing and logins have been fixed however we are still working on a couple of small issues. Currently clicking login at the top of the wiki page does not redirect as it should to the trainz online main page.

Spiffy
June 27th, 2012, 08:22 PM
Login system has been fixed. If you find any issues with the wiki can you please post here so that we can look into it further.

PEV
June 27th, 2012, 09:33 PM
I've just done log-in, log-out, and a test edit of a page.. ALL WORKING... Thank you.