PDA

View Full Version : Issue with Trainz Multiplayer



TrainzFan95
April 4th, 2012, 09:46 PM
After a few months of playing Trainz Simulator 12, I've experienced a problem with the game's multiplayer feature. The Hungarian map (I can't pronounce the name right), is the ONLY map that is multiplayer-capable. All the other maps that came with my copy of TS12 cannot host multiplayer sessions. I dunno what to do...:(

Mouse84
April 4th, 2012, 10:16 PM
You need to find what maps that people are using and download and install them. If you don't have them installed, you won't see them. Montana Rail Link 1.5 is a good one, not too big and a lot to do. You can find it on the DLS.

TrainzFan95
April 5th, 2012, 12:26 AM
Well, thing is, when I tried to start a session on Mojave, an error message showed up saying "Error: System is in wrong state to start a multiplayer game."

Scottbe8
April 5th, 2012, 12:52 AM
When you launch Trainz, you have a Launcher window with "Start", "Content", etc. What is the number in the bottom-right of that window?

shaneturner12
April 5th, 2012, 02:41 AM
I see no-one else has noticed that the OP has not registered any version of Trainz.

This is required to access many Trainz features, including Multiplayer.

TrainzFan95, please register your serial number if you haven't already, as it will enable you to use all features of your version.

Shane

Mouse84
April 5th, 2012, 06:15 AM
OMG, I'm not sure if you've read the post in other parts of the forum about people's latest versions of Trainz not showing up next to their name. Relax Mr. Forum Policeman.

shaneturner12
April 5th, 2012, 06:24 AM
I'm aware of that, but it may or may not have a bearing on the issue.

The other possible issue is build version.

Shane

TrainzFan95
April 5th, 2012, 07:56 AM
Okay, so, I already registered my copy's serial number, but I dunno what that's supposed to do. Anyway, maybe if I reinstalled it...

peghorse
April 5th, 2012, 08:10 AM
Relax Mr. Forum Policeman.

No need to relax. One of the best things about TRS from its conception is the polite checking and reminders to people to register
their version of TRS. There may be known issues regarding registration nevertheless TRS users, members of the community and its
representatives will continue to offer these polite reminders whenever it is deemed necessary.
That is how it has always been.

Who am I? I am no-one. I'm just saying that's all. ;)

Trainzfan95 rest assured the community will assist you with this process.
You registered it via planet auran? Go to the forum homepage and follow the Planet Auran link in the top menu for starters if you haven't done so already.
CheerZ!

shaneturner12
April 5th, 2012, 08:34 AM
Okay, so, I already registered my copy's serial number, but I dunno what that's supposed to do. Anyway, maybe if I reinstalled it...

Before you look into reinstalling, what's the 5-digit code shown on the bottom right of your Launcher screen?

Shane

oknotsen
April 5th, 2012, 08:35 AM
Hi and welcome to Trainz.

All the other maps that came with my copy of TS12 cannot host multiplayer sessions. I dunno what to do...:(
Every route can have multiplayer sessions. By default, there is only 1 installed (the one on the Debrecen route). Every other session needs to be downloaded from the content site.

To be able to play MP, start with checking if you have registered your game to the account you are using. For us it currently does not show that you have TS12 registered to your trainzfan95 account, but that might be a bug.
Next step is to check if you have the latest build. Currently that is 49922. You will find this number in the bottom right corner of the start-up screen. If it aint the latest, you need to patch your game else you will NOT be able to play multiplayer. If you got your game via Steam, then you are screwed as you can not update to the latest build.

Check these things. If you have a specific question after that, please return with that specific question and be clear in what messages you got and version / build you have.

ct_krogen
April 5th, 2012, 09:45 AM
Okay, so, I already registered my copy's serial number, but I dunno what that's supposed to do. Anyway, maybe if I reinstalled it...


you have to registered it here on theweb site

TrainzFan95
April 5th, 2012, 11:04 AM
I bought my copy from the website, which was a digital download. I'll find a way...

shaneturner12
April 5th, 2012, 11:23 AM
OK - can I ask what build number it is? This will be shown at the bottom-right of the Launcher.

Shane

TrainzFan95
April 5th, 2012, 11:25 AM
It's Build 49922

shaneturner12
April 5th, 2012, 11:30 AM
OK - that's the latest build.

Some maps cannot support multiplayer sessions due to usage of assets that are not built-in or on the Download Station.

There are a few maps that are available on the Download Station for multiplayer use - the threads for these are in this forum.

Shane

007007
April 5th, 2012, 11:55 AM
You need to start the session out of the "Menu" and not right from Surveyor mode.

TrainzFan95
April 5th, 2012, 09:46 PM
And that'll work?

colourlight
April 6th, 2012, 02:32 AM
It appears to me the problem is that TS12 is not showing up on the "railway track" next to your name. First thing to do, if you havn,t already done so is to check your profile and see if it is actually registered and also the name is exactly the same as your copy. If that is ok, from the launchpad select "options" and go to the page with your username and password and check they are listed. Next, again from launch pad select "website" and at the top enter your username and password.

TrainzFan95
April 6th, 2012, 03:00 AM
I checked that, but I can't find it....

colourlight
April 6th, 2012, 04:03 AM
I,m at work so giving you a "walk through" is not an option and posting is a pain anyway. Later on when I,m at home I can do a much better post. As an afterthought, if you have Win7 or Vista, Are you starting TS 12 as "run as Administrator?

colourlight
April 6th, 2012, 09:31 AM
OK, I,m at home so I can walk you through the process. Right click on the Trainz Icon on desktop, select "Run as Admimistrator, Amswer question "yes". On the launchpad confirm that the build number is 49922, which you said it was. Now select "website" Enter your username and password at the top and click "login". Now click "home", "forum" "planet auran" Look at the T"rainz" options on the laft and select "serial number" Mine says Trainz Simuator 12 plus the Key Code. There are different versions of Trainz 12 so if you have installed a different version of TS12 at some point check the key code against the version you are using. You could do that in any case as a double check. Now back to the launchpad. Click "options" "planet auran" and check that your username and password are entered. Back to launchpad, select "content" "file", "settings", "internet and, yes you guessed it, username and password. Now back to launchpad once again and you can actually start the game, lol. select "routes" "the funny named hungarian one", "sessions" and select the multi player one. If you still get the same message as in your first post I would sayTrainz thinks you have an unregistered copy of TS12. You will then need to contact the help desk. Post here how you get on and that will confirm whether you have a registration problem one way or the other. Good luck! P.S. when you succeedI sugest you purchase a First Class Ticket, if you havn,t done so already and activated it in your profile. Then you could download UMR SUMMER TS12 MULTIPLAYER session which is popular and I would be happy to help you get settled in. It is a large map and takes quite a while to download and even longer to download the assets you need the first time you play it.