PDA

View Full Version : DLS hangs on certain assets



Gavan0c7
February 9th, 2012, 03:16 PM
Hi all,

new member of the groups and first time on Trainz. (TS12)

I keep having an issue where the download station hangs on particular assets.

Essentially it still indicates it is downloading but the download rate is 0.00 kbps. If I stop the download and start it again it still remains stuck. If I remove the asset from the list and start the download stream it starts downloading the next item.

This has happened three times. Each of the assets has been greater than 2MB and the freeze occurs after having downloaded 20-30MB.

Is this happening to anyone else?

Does anyone have an explanation?

Does anyone have a solution? I suspect these routes will not work properly with missing dependencies.

regards

Gavan

shaneturner12
February 9th, 2012, 03:23 PM
Can I ask at which point the hang happens? If it's at the end, there is a known issue that means that it is not installing certain files properly.

Shane

P.S. Welcome to the forums.

Gavan0c7
February 9th, 2012, 03:47 PM
Can I ask at which point the hang happens? If it's at the end, there is a known issue that means that it is not installing certain files properly.

Shane

P.S. Welcome to the forums.

Thanks Shane,

Twice at the end. Once in the middle.

shaneturner12
February 9th, 2012, 03:52 PM
The suggestion I can give regarding the problem assets is to download them manually. To do this, hold Ctrl on the keyboard and click DLS at the top. This will open it in a new tab.

Once it appears, use the search box to find the item name that has hung during downloading, then click Search.

Once the item appears, click Download Page next to it, then click Download (FTP). This will trigger a standard browser download process - save it to a folder you can remember.

Once done, open Content Manager then click File, followed by Import CDP. Use the box that appears to select the CDP file just downloaded, then click Open.

Shane

Gavan0c7
February 10th, 2012, 06:48 PM
Thanks for the advice Shane!

Tried it last night. The ftp download hung part way. The DLS also seemed to have ground to a halt as there wasn't anything I could do to get bandwidth. Gave it up as a dead loss and went to bed.

Tried again this morning and it seems to be working.

So as far as I can tell, the way to download anything is to:
1. Drag the item into the download list of content manger
2. Open up the dependencies list
3. For each item over 1000KB
i. view it in the main list
ii. note its kuid
iii. remove it from the download list
iv. download it using ftp
4. Download the balance of the item using content manager.

Or is there a more efficient way?

regards
Gavan

ventura
February 12th, 2012, 12:38 AM
Hi All,

Back after a long break and tried to download pgibbons recent "Wagga to Henty" ands "Kywong" routes and have the same problemas above. As these are the main asset I couldn't remove them from the associated list of assets as suggested above.

Is this download problem with large files (they were 7 and 10 Mb) a general problem? I last downloaded a large file (the Weddin route) about 18 months ago with no problem.

I have Trainz 2010 and have patched it up to the latest.

Slighty frustrated,

Ventura.

Gavan0c7
February 12th, 2012, 07:06 PM
Hi Ventura,

So far it seems to be more likely that a large file will do it, though I have been able to download large files through Content Manager in the mornings. Try the FTP method suggested by Shane. Any item will list its dependencies and while the process is manual, you can have two active sessions which kinda balances it out.

Gavan0c7
February 13th, 2012, 02:37 AM
Ventura,

Try this method.

Download the Wagga to Henty asset using FTP.
Once downloaded, install it using CM.
Go to Missing dependencies.
Right click on the Wagga to Henty asset and select 'View dependencies'.
Then click the 'View in main list' button.
Select all the items in the main window and drag them to the download helper window.
Once the download helper settles down (i.e there are no more question marks), sort by size, smallest to largest and click start.

You can either let it run until it hangs and download the rest using FTP or you can start at the bottom and download the largest files using FTP until you meet CM somewhere in the middle.

ventura
February 13th, 2012, 06:24 AM
Gavan0c7,

Thanks for that, it works. Took a bit of time to realize that the DLS was back through the Trainz web-site - it is years since I have downloaded through there! Followed your directions and downloaded the route via FTP and then got some of the assets through CMP but it started to hang at the 300kb files this evening. Will take a while to download the 60 odd dependencies!

Is this going to be an ongoing issue? Does using a first-class ticket solve this particular issue?

Ventura

shaneturner12
February 13th, 2012, 06:26 AM
It's a quite well-known issue. A First Class Ticket may help with it if it stalls halfway through, but it will not make any difference if it stalls at the end.

Shan