PDA

View Full Version : New Tutorial -Installing Content Updates using Content Manager (TS2009 or later)



shaneturner12
January 24th, 2012, 10:41 AM
Hi Trainzers,

I realise there are a few threads on this subject, but the ones I've seen so far are mainly text-based.

My new tutorial, on my tutorial website (which some of you will know has been recently reorganised) is a 7-step process (pictorial) of how to install updated content using Content Manager.

The pictures are quite large (due to the resolution of my system) but should be clear enough to see what's happening.

The direct link is http://shaneturner12.awardspace.co.uk/trainzdata/index.php?page=content-updating-in-ts2009-and-above or you can access it by clicking the link in my signature, then clicking Tutorials, then clicking Content Updating in TS2009 and above.

Comments etc on my latest tutorial are welcome.

Shane

Enkidoh
January 24th, 2012, 09:05 PM
Excellent tutorial Shane, it's taught me a few things about CMP that I didn't know about.

One thing about downloading updates that I've noticed which you didn't mention in the tutorial though - I've found that CMP (in 2010) will only download an update if the earlier version is showing up as faulty or giving warnings, it refuses to download if the earlier version has no problems.

Makes sense I guess, but then what's the point of making an updated version if it's not required? (I guess Trainz takes the idea of 'if it ain't broke don't fix it' seriously! :p)

Anyway, thanks again for the tutorial.

shaneturner12
January 25th, 2012, 03:46 AM
Thankyou for your comment.

I would have thought that the facility for updating content would update any piece of content with an update available, not just faulty content. (TS2009 SP4 does) I will add that to the tutorial.

Shane

llebrez
January 25th, 2012, 12:20 PM
So, all this brings a related subject. When we talk about TS2009, we should specify if it is SP3 or SP4. There is a difference. Having 2009 SP3, if I download all the updates, they may be made for SP4, and then most of them will not display or appear with the rainbow colors. You could say that if the check marks in the DLS are set for 09, then the assets to update will be for 09 only, but how does the system knows if they are for SP3 or SP4? As per right now, I am reluctant to download updates, just in case they mess my assets for the reasons above. Any explanations?

shaneturner12
January 25th, 2012, 12:23 PM
From memory, TS2009 SP3 content will either be 2.9/3.0/3.1/3.2, and TS2009 SP4 content is build 3.3.

Shane

Scottbe8
January 25th, 2012, 12:28 PM
In the filter for step 6, you can add the filter "Out of Date: False" to show only the most recent version of the asset.

If there's a problem with any download, you can get a CDP from the black pages (FTP).

shaneturner12
January 25th, 2012, 12:37 PM
I have amended the tutorial to include information on the additional filter opportunity.

Shane