View Full Version : Buggy Trainz-for-Mac

January 24th, 2012, 12:51 AM
I downloaded the Macintosh version from the App Store and I'm having a few issues with the program that I hope someone can help me with:

1) I got no serial number with my purchase and typing my Planet Auran username and password into the Settings prompt has yielded no results. Is there another way to register the program or do I need to send Apple a few disgruntled emails? EDIT: it says Trainz Mac next to my username, but I still can't do anything else inside Trainz itself.
2) I can't sign into my Planet Auran account through Trainz itself - clicking on the boxes for username and password doesn't do anything.
3) Trying to visit the Download Station within Trainz causes the whole program to crash, before the page can load anything.

I tried using third-party stuff to no avail, but that's not really a problem. I'd like to get this stuff sorted out first. I had the original Trainz for Windows XP back in the day and it worked without a single problem...

- Ryan

January 24th, 2012, 03:28 AM
Notice that there is a support forum for each version of Trainz. For Mac, thats here:
Notice that the registration / serial key subject alone is handled at least twice on the first page of topics alone.

Dig around that place, you might find the answers to the rest of your questions there also ;).

January 24th, 2012, 03:33 AM
Hi ryanmasecar,

Welcome to the forums.

The App Store version is automatically registered with N3V(according to Zec and WindWalkr, who are both N3V employees) when you enter your username and password in the Trainz Mac software.

I would advise that you access the Download Station using a web browser, as the in-game one is not designed for browsing the Download Station with, despite there being a link for it.

For any other problems, please see the Trainz Mac forum.


January 24th, 2012, 05:56 AM
as the in-game one is not designed for browsing the Download Station with, despite there being a link for it.I'm not sure that N3V would agree with this statement.

I'd suggest contacting the helpdesk (http://auran.com/helpdesk/default.php).

January 24th, 2012, 09:06 AM
N3V have stated previously that Content Manager is their prefence over the web-based Download Station. I do know that it's unlikely to work as well in-game due to the downloading requirement.


March 1st, 2013, 03:41 AM
Hey guys - I have a buggy version on my Mac.
I tried the Mac forum link above and it tells me I don't have privileges to view.

Basically It was all working great - then it crashed and when I restarted it rebuilt part of the database. Now items drop out of the scenes and it's very slow.

I tried deleting the app and re-installing - but when I re-install all my session data is still there. And it's still broken.

I want my train set back!



March 1st, 2013, 03:51 AM
Welcome to the forums.

The reason you cannot view the Mac forum is because you haven't registered your version. How to register it depends on where you bought it from.

Once this is sorted, it may sort out the remaining issues.


March 1st, 2013, 05:10 AM
Thanks for that.

App store download.

Am I correct that to register I have to provide my apple account ID and password?

March 1st, 2013, 05:21 AM
Hope this link helps:

I noticed Mac in the list of options, but it might also work different if you do not have a serial.

March 1st, 2013, 08:09 AM
Failing that, click Options on the Launcher, then Planet Auran, then enter your Planet Auran username and password before clicking OK.


March 2nd, 2013, 05:48 AM
Sorry to be a pain - but all that does is bring me back here still with no access to the mac help section.

March 2nd, 2013, 05:59 AM
As long as your game is not registered to your forum account, you will not get access to the specific sub sections. So if you have a serial key, follow the link I posted and fix your registration. If not, consider contacting the helpdesk and/or read instructions that came with the game.

March 2nd, 2013, 08:21 AM
Sorry to be a pain - but all that does is bring me back here still with no access to the mac help section. Hi BDA,

As far as I am aware, you should be automatically registered. Contact the Helpdesk using the link in the top navigation bar. Be warned it may take a few days to get a reply.

March 5th, 2013, 11:58 PM
Unfortunately there is no key in the mac App store version and there are very scant instructions.

I've already invested a fair bit of time to get this far.
The search for tech help for the Mac App store download leads in circles or to that dead end link above.

All I want to know is how to fully uninstall the mac store version.
I don't even care if I lose all data - I wanted to start again anyway.

To have to go through a process to obtain this information is very frustrating.

Cheers again for the help anyway.

March 6th, 2013, 12:37 AM
The Mac App Store version of Trainz does not require or provide a product key / serial number / CD KEY. It is registered to your specific Apple ID. You can link this to your Planet Auran profile by entering your Planet Auran details into the Trainz Settings screen available from the launcher.

kind regards,


March 6th, 2013, 05:16 PM
Thank you too Chris. It's a nice day in Brisbane so far huh.

I have done that - and still don't have access to the 'mystery' Mac help thread listed above.

March 6th, 2013, 05:34 PM
Have you entered your Planet Auran details in the Trainz Options box? If you have you will need to contact Helpdesk.


March 8th, 2013, 12:51 AM
Yes I have. Numerous times.

Thanks a final time for trying to help.

I'm over it. Too hard for a novelty.

March 8th, 2013, 11:05 PM
I was ready to skitz at mine and throw it out the window ... until ... I changed my password. Then it all seemed to sync up - I could *already* log in and get content from the DLS directly (before any of you say I stuffed up the password), but couldn't access the Mac forum (even though my correct serial was entered) or download content from within Trainz itself.

Changed the password, filled in the settings correctly when I launched Trainz, and am now consuming all my bandwidth downloading content... wheeee.