PDA

View Full Version : Attn: AURAN/ N3V:



overkill650
November 16th, 2011, 06:24 PM
I have a problem, that many other users have. Its the biggest problem with the game.

when i go into content mangler, it tells me that all the dependencies i need, are obsolete...what the hell is that?? I mean, why do you need to update assets, if the game isnt online enabled (i have no interest playing online).

i mean, really just sit back and think for a second. Why would a dependency go "out-of-date???" i would understand if there was something wrong with the dependency, but in that case you should have to re download the new version, not try to update to it.

is there a way to make my trainz so that i can use the "older dependency versions???"

i dont have a FCT. Nor do i feel i must buy one. I just read in another post that the money for the FCT pays for the free server...

wait...so you mean to tell me that paying for a FCT doesnt mean i get to download from a dedicated server???

im sorry to get mad, but i see you guys made TRS 2004. so that means youve had this problem for over 7 years!!! its amazing it has not been fixed.

please AURAN/ N3V, please please, please help, not just me, but the others too.

and please dont tell me to submit a ticket to the helpdesk. this is a community wide issue.

ZecMurphy
November 16th, 2011, 06:43 PM
Good Morning overkill650

An 'out of date' dependency means just that, it is out of date. Or, to put it another way, it has an update available for it.

This can be one of two things. First, the asset may have been faulty, and has been updated as part of the DLS Clean Up process. Second, the author of the asset may have made improvements, or changes, to the asset.

In either case, it's not necessary to download the update. However, it is recommended, so as to ensure you are running the latest version. Some assets may require the newer version to operate correctly. A good example are some of the 'mesh library' asset (e.g. the 'coupler' library that I've released under the username 'S301').

With that coupler library, I often add new or modified couplers to best fit specific vehicles. In this case, I have to update the library to include those new items. If you download an item that requires the updated asset, but don't download the update, then the item will not work correctly, or may not work at all.

Either way, it's the community/creators who update the assets, not us. If you don't wish to download updates for specific items, then this is your choice. However, when you download a new asset using content manager that uses that dependency/asset, then the update will be automatically downloaded. This ensure you are running the newest version, which is generally recommended (You really can't know what bugs/errors/issues may have been in the asset when you updated it).

As to the First Class Ticket, this gives you access to the First Class Server which provides a higher download speed, and removes the daily download limit. Except in exceptional circumstances, you will not encounter the server full message.

The First Class Ticket subscriptions also help to pay for the operation of the Free server. If we didn't have enough FCT subscriptions, we would have to reduce the free server access, since we would not be able to cover the costs of operating the free server.

RRSignal
November 16th, 2011, 06:46 PM
Dependencies go "out of date" because there was something wrong with them that was fixed in a subsequent version. Content developers do update our works. Also, a lot of content that doesn't work properly with newer versions of Trainz is in the process of being upgraded to newer, more-rigorous standards that DO work. Frankly, the content system would be a nightmare if there was no provision to update stuff.

Oh, and yes, getting an FCT DOES get you access to a dedicated, first-class server.

Retro00064
November 16th, 2011, 06:57 PM
You do not know what you are missing out on if you have never had an FCT. How does a download speed of roughly 50 to 100 times faster than the free download speed sound? Once you try one, you may be willing to renew it once it expires. ;)

overkill650
November 16th, 2011, 07:54 PM
ok guys, thanks for the quick response, especially zec. i understand now. and to go from here, im guessing my only option is to get a fct. ok i will, but i need to make some money first. ill let u guys know when i get a fct. sorry for the blow up