PDA

View Full Version : Game Freezing !



RonnyM
September 23rd, 2011, 06:40 AM
Hey to you all.
Has any of you this problem?
My TS2010 Freezes not just the game but the whole PC apr. every 5 minutes.
The more i build the worse it gets, sometimes it even crashes(Game).
PC Specs. 8gb. Ram/Q9400 Quad core/Nvidia GTX 550Ti:).
Any solutions
With this problem it can take a very long time to build a Route.

Is installed on a secondary HDD With 154gb free space.
Running Windovs 7-64bit, but has runned vista 32bit x86 with same problems
I will try keep an eye on task manager. regarding defrag I do it freqently.
the problem appears right after reinstall of both game and windovs
NB! 340gb free on C drive


RonnyM Denmark

Kessica
September 23rd, 2011, 06:52 AM
I have often found that when my PC freezes and nothing works for a while, but then recovers, it has been down to the system swapping stuff from memory to and from the virtual memory (on your drive). Defragging your drives can help, and also defragging your virtual memory. Might also be worth checking space on your C Drive. It can get quite cluttered without realizing.

Bring up Task Manager and view the performance and keep the window on top. Keep an eye on virtual memory usage. When it freezes you may be able to discover what process is running when it happens especially if you sort by CPU usage on the process tab. This may give you some pointers as to where the problem lays.

shaneturner12
September 23rd, 2011, 07:00 AM
RonnyM, firstly, I must ask you to remove your email address from your post, as this is a publicly visible part of the forum (which means that spammers can also view it without needing a login)

Secondly, it may be worth checking that your drivers are up to date, and providing information such as:

Operating system
Memory (size/capacity)
Hard drive (preferably the free space figure(s))
Processor

Shane

shaneturner12
September 23rd, 2011, 09:38 AM
OK - as you have stated that you have reinstalled Windows, there is a good chance you need to update both your graphics card and DirectX files.

See my tutorial thread in this forum on how to update DirectX, and see my tutorial website (http://shaneturner12.awardspace.co.uk/trainzdata/index.php?page=useful-link) for a link to update your Nvidia drivers.

Shane

pfx
September 23rd, 2011, 09:44 AM
Ronny, there is another possibility. From what you say, it sounds like you are in Surveyor mode when the freezing happens? If so, this may be related to autosave. Check the settings on this. Every time an auto save takes place, the system will come to a grinding halt. The bigger your route, the longer this will take.

Try setting the autosave to every 20 or 30 minutes and see if that helps. If it does, then you will know what the problem is.

sniper297
September 23rd, 2011, 01:50 PM
http://forums.auran.com/trainz/showthread.php?t=75302

When I got TS2010 I had a Maxtor 160 with an 8mb buffer, one of the slowest hard drives in existence. Recently replaced with a Western Digital 500 gig 16mb buffer that averages about twice the speed, I've found it doesn't cure the problem entirely but it does help a lot.

One thing I checked that hasn't been fixed yet;

http://forums.auran.com/trainz/showthread.php?t=59346

Since I swapped all the hardware except the hard disk while troubleshooting that, and now have a new hard disk, new RAM sticks, new video card, it's either some .NET Framework plugin or a problem with the motherboard or video card (only components that haven't changed in the last year). Doesn't affect other games or any other program, so it's something specific to TS2010 and TS12. And the autosave was the first thing I turned off.

So if it's the terrain paint causing your freezes, the only thing you can do is paint as many swatches as you can in five minutes onto a palette area, save and get out before it freezes. Reload and repeat until you have all the terrain paint textures you need. After that when you go to paint ground, open the paint tool, type "ZX" in so it blanks the selection window (available textures selection is what causes mine to freeze after 8 1/2 minutes), then use the pick tool to select textures from the palette on the ground.

If it's changing tabs, try going into content manager and disabling all the stuff you're not intending to use so there aren't so many in the list. Also decrease the draw distance in surveyor, one of the odd things about this game is surveyor actually hammers the video card GPU with a higher load than driver does.

And before anyone suggests it to me, disabling autosave was one of the first things I did, it's always off.

RonnyM
September 26th, 2011, 02:54 PM
RonnyM Denmark[/quote]Hey Guys! Thanks for the inputs!
So, are running DirectX 11 and have the latest Graph. drivers, allways install
the necessesary components so that shouldnt be the problem.
Regarding the Autosave its set to 15min. so i dont risk loosing work upon crash. But sounds like a possible solution, so will try that.

Will return with detailed info on your ideas effect!

clam1952
September 26th, 2011, 03:24 PM
A couple more suggestions to improve things.

Disable Windows search and indexing on the Trainz drive.
Exclude the Trainz folders from Antivirus and malware scans.

Both the above will slow down loading assets while in game and increase the time taken for any database repairs.

Check that you are actually using the full capabilty of your hard drives in that they are using the correct AHCI drivers from the manufacturer and not Windows IDE drivers, can tell from the IDE/ATAPI controllers entry in device manager should be something along the lines of name_of_chipset SATA controller. If all you see is Standard Dual PCE IDE controller then you are using Microsofts drivers. May need to change the drives from IDE to AHCI in the bios.

With Nvidia cards, make sure that the Nvidia contol panel setting for Trainz 2004 (yes it works on TS12) are set to performance, single display, and Use Applications settings where applicable.

If you are using Nvidia driver 280.26 be aware that it is buggy and causes problems for some (from Nvidia forum plus unusable here as well) with quite a lot of games and it's replacement is currently being tested, suggest using 275.33 for the moment or try the beta 285.27 which has quite a performance kick compared to previous drivers.

RonnyM
September 26th, 2011, 04:36 PM
A couple more suggestions to improve things.

Disable Windows search and indexing on the Trainz drive.
Exclude the Trainz folders from Antivirus and malware scans.

Both the above will slow down loading assets while in game and increase the time taken for any database repairs.

Check that you are actually using the full capabilty of your hard drives in that they are using the correct AHCI drivers from the manufacturer and not Windows IDE drivers, can tell from the IDE/ATAPI controllers entry in device manager should be something along the lines of name_of_chipset SATA controller. If all you see is Standard Dual PCE IDE controller then you are using Microsofts drivers. May need to change the drives from IDE to AHCI in the bios.

With Nvidia cards, make sure that the Nvidia contol panel setting for Trainz 2004 (yes it works on TS12) are set to performance, single display, and Use Applications settings where applicable.

If you are using Nvidia driver 280.26 be aware that it is buggy and causes problems for some (from Nvidia forum plus unusable here as well) with quite a lot of games and it's replacement is currently being tested, suggest using 275.33 for the moment or try the beta 285.27 which has quite a performance kick compared to previous drivers.
That was a mouthfull of info:) .Thanks Going to check the Nvidia driver version. It is 280 something.

RonnyM
September 26th, 2011, 04:42 PM
Ronny, there is another possibility. From what you say, it sounds like you are in Surveyor mode when the freezing happens? If so, this may be related to autosave. Check the settings on this. Every time an auto save takes place, the system will come to a grinding halt. The bigger your route, the longer this will take.

Try setting the autosave to every 20 or 30 minutes and see if that helps. If it does, then you will know what the problem is.

RonnyM: Thats it! Increased autosave interval to 30min.
1 hour with no Brrrrr Freezing. THANK YOU!!!!:D

RonnyM
September 26th, 2011, 04:50 PM
Problem seems to be solved by increase of the autosave interval.
Thanks everybody and thanks to "pfx" for hitting the right button.:D :D


RonnyM Denmark

RonnyM
September 26th, 2011, 04:53 PM
That was a mouthfull of info:) .Thanks Going to check the Nvidia driver version. It is 280 something.
Yep! 280.26 Finding another one just in case. Thanks.:)