PDA

View Full Version : Some items have gone white on me!



AnalogOldguy
June 27th, 2010, 12:39 PM
Hello everyone,

I'm having what "seems" to be a minor problem with a few items going white in color in my Trainz programs. (2004 SP4 and 2006 SP1). But I know this is not normal!

I'm sure that this started when I moved my Trainz 2004 and 2006 programs to a brand new hard drive. Along with my downloaded stuff.

The first occurrence of this was in Trainz 2004, in a route called Lot's Creek Branch. Exactly one tree had gone "white" on me (all over the route). I re-downloaded that one tree and all seemed fixed.

Now, months later in Trainz 2006, I was in the Regional Passenger Transit route when I noticed that a "prime mover truck" (I think it was number 9, a built-in) had gone white in color in the cab section.

I tried reverting it in the CMP, which did not fix it.

Then I noticed that all the built-in prime movers, and others I had downloaded, were white (in the cab section). I then downloaded "prime mover 8" which I did not have. And surprise, it also shows up as white in color. I then downloaded two of JKeenan's prime movers ConAgra and Exxon. These also come up with white cabs in surveyor.

The prime movers in my 2004 are all properly colored. I am thinking that this might be a problem with some sector or something on the hard drive. Does anyone have any thoughts about this?

Thanks. Bob P.

bendorsey
June 27th, 2010, 01:23 PM
I'd suggest you have a missing texture that didn't get transferred for some reason. That will make things turn white.

Ben

BobCass
June 27th, 2010, 01:33 PM
AnalogOldguy: The only thing I can suggest is a forced extended data base repair..I'm thinking like you that its something on the disk..I hope this works..

nfitzsimmons
June 27th, 2010, 01:40 PM
I've downloaded all of the prime mover assets recently. They're all missing the primary texture. I checked in editing mode; the texture just isn't there.

WillPac
June 27th, 2010, 03:05 PM
I too have all of those primer movers and all but one (I think it might be Prime Mover 1) are completely white, despite the fact that none of these show errors or missing deps.

AnalogOldguy
June 27th, 2010, 04:28 PM
Well folks,

I downloaded the "prime mover" 3, 4, and 6 into my TC 1&2 (which is on a different partition on my hard drive) and they show up as white.

TC 1&2 had no prime movers built-in, (I checked before I downloaded).

So, this makes me feel a little better about my hard drive being possibly at fault.

What makes me wonder is how the built-in ones in 2006 could be white and lacking a texture, They don't show as faulty or anything. A couple of the prime movers I dl'ed into 2006 produced the green triangles, meaning modified. I wonder if the built-ins "caught" this disease from ones that were modified?

Well, I'm not quite as worried since the TC 1&2 ones are white. :hehe: See you all later, and thanks!!

Krupa
June 28th, 2010, 02:13 AM
The above mentioned prime movers show the following .JPG and .texture files errors when installed in Trainz 2006 and above:-

Error: Filename '`dogbox.jpg' contains illegal characters
Error: Filename '`dogbox.texture.txt' contains illegal characters
Error: Filename '`hlites.jpg' contains illegal characters
Error: Filename '`hlites.texture.txt' contains illegal characters
Error: Filename '`mainsemi.jpg' contains illegal characters
Error: Filename '`mainsemi.texture.txt' contains illegal characters
Error: Filename '`orange.jpg' contains illegal characters
Error: Filename '`orange.texture.txt' contains illegal characters.

Trainz 2004 ignores the errors, thus they show up OK.

Les.

davesnow
June 28th, 2010, 09:54 AM
See this thread:

http://forums.auran.com/trainz/showthread.php?t=43513&highlight=white+locos

AnalogOldguy
June 28th, 2010, 02:19 PM
Davesnow, Very interesting thread (about the locos turning white)! I've never had anything like that happen! But it does show us that there is probably a connection between items which are using complex scripting and so on...

Krupa: All those errors you found! Too bad nobody has fixed them. I'm thinking that the "prime movers" are a strong part of the history of Trainz!

Bob P.

shaneturner12
June 28th, 2010, 02:22 PM
I have had some strange goings-on in that area as well.

Firstly, I have found it frequently happens in DirectX mode - if you are using DirectX mode, try running it in OpenGL mode and see if that fixes the problem.

Secondly, in relation to the illegal character errors mentioned, the ` character (the key that is usually to the left of the 1 key (and usually underneath the Esc key) appears to be the one at fault. You may have to update any files that point at the affected files to remove the ` character.

Shane

AnalogOldguy
June 29th, 2010, 08:10 PM
Just for the record, I tried OpenGL for the white prime movers. Did not help.

That character ` (under the esc key) I'll look for it some day! In fact I did look and couldn't find it! (in the config file any way). Could be that I looked in the wrong place, or that my eyeballs were very weary!:'(

Thanks for the info Shane.

shaneturner12
June 30th, 2010, 02:45 AM
According to the Content Manager errors, the problem is actually relating to the .texture.txt files (or maybe even the texture files themselves), not the config file.

Shane

Krupa
June 30th, 2010, 11:10 PM
Prime movers in TRS2006.
http://img20.imageshack.us/img20/8100/primemovers.jpg (http://img20.imageshack.us/i/primemovers.jpg/)
Uploaded with ImageShack.us (http://imageshack.us)

Les.