PDA

View Full Version : TRS2004 & Windows 7. CDP says "No Trainz products installed"



caseyjones101
February 13th, 2010, 01:37 PM
Guys, I'm at the end of my teather with Trainz and Windows 7. Help me before one is destroyed with force.

I have installed Trainz 2004 on my laptop on the path...

C:\Program Files (x86)\Auran\TRS2004

I try to install any CDP from any Trainz website and it reconises the file type. However at the extraction screen says in the Product box. "No Trainz products installed" when TRS2004 is blatently installed on the system.

It has been registered with Planet Auran and registered with my User ID. But it still will not allow me to install.

Help me before something sees my size 10 foot! :eek:

Adam.

martinvk
February 13th, 2010, 02:42 PM
TS2010 and all previous versions work just fine on my Win7 64bit
Did you install it as administrator? Are you running as it administrator? Not just TRS2004.exe but also Trainz.exe and ContentDispatcher.exe. Rights are something that have tripped up more than one user.

caseyjones101
February 13th, 2010, 02:48 PM
Yes, I've done all that. I don't get why it doesn't work.....:o

Adam.

caseyjones101
February 13th, 2010, 03:09 PM
Anyone else? Otherwise that's another trainsim that hates Windows 7 :'(

Adam.

martinvk
February 13th, 2010, 04:19 PM
Anyone else? Otherwise that's another trainsim that hates Windows 7 :'(

Adam.
That's not true. There is probably something in your setup which is blocking Trainz but TS2010 work very well, in fact, better than in Vista where I had it before upgrading.

raildriver1
February 13th, 2010, 04:42 PM
Hi Adam,

Go to the map: Program Files/Auran/trs2004.
Do you see there a file called content dispatcher ?
Ok start it and fill everything in there. There you can give the path to the location of trs2004.
Maybe this will help you ?

Greetings, raildriver1

Azol
February 13th, 2010, 05:11 PM
This is called UAC (User Access Control).
If you install anything into Program Files directory, it creates virtual directory visible only to the same user who installed this program.
Either disable UAC completely or re-install Trainz into some other directory outside of Program Files, like C:\Trainz2004

slugsmasher
February 13th, 2010, 11:09 PM
Disabling UAC is a good fix for several Win7 issues. Google "UAC disable" for the steps.

ALso you will have to enable XP compatibility mode if you have not done so already. Right click the content dispatcher file from the TRS2004 directory folder, select properties and then the compatibility tab. Select run in compatibility mode for "windows XP SP3" and select "run as administrator". It will work fine then.

caseyjones101
February 14th, 2010, 06:49 AM
Excellent, thanks guys.

I have since found out though that I had a download copy of TRS2009 which I can still download.:D

Sorted!

Adam.

bigingo
February 14th, 2010, 06:52 AM
-Can only agree with former replyer Caseyjones101 and the "end" sentense! -Trainz sim hate Win7...

-My versions of Trainz, both TRS2006 AND TS2009 won´t work with Win7 64bit.. -AND as a "Administrator" -AND XP SP3, -AND disable UAC, -AND installing with disable antivirus.. -AND have all drivers up to date... have tested all things now... -It crashes all the time.. (TS2009)
-The TSR2006 won´t even start from launcher.. -Total error right after!!!!

-Therefore I havn´t brought TS2010 yet!!!

-AND just for the record.. -Have a hot game PC here!!


cheers bigingo

caseyjones101
February 14th, 2010, 07:03 AM
-Can only agree with former replyer and "end" sentense! -My versions of Trainz, both TRS2006 AND TS2009 won´t work with Win7.. AND as a "Administrator" and XP PS3 have tested all things ..and have all drivers up to date... It crashes all the time.. and you´re right trainz sim hate Win7...

cheers bigingo

Well, mine runs fine. But just won't let me download any new items.:confused:

Adam.

bigingo
February 14th, 2010, 07:50 AM
-Ok!! -Sorry Caseyjones101... Have missunderstand you then.. hope that you can solve the problems about the DL..

Greeetings from Sweden
bigingo
;)

caseyjones101
February 15th, 2010, 08:23 AM
Well chaps, Tried all that with TRS2004 with no luck at all.

Tried TRS2009, but that just made all my downloads see-through. :eek:

I'm giving TRS2004 one last shot, if it fails. Then that's it! I give up! :'(

Adam.

Stationbeem
February 15th, 2010, 11:45 AM
Are you up to service pack 4 . Mine is running with only one problem ( I have to download routes via FTP). Apart from that I have no other problems.

caseyjones101
February 15th, 2010, 12:42 PM
Are you up to service pack 4 . Mine is running with only one problem ( I have to download routes via FTP). Apart from that I have no other problems.

Yes, I was.:o

I'm afraid to say that all Trainz games have now been uninstalled and will not be played at all unless I can find a Win XP service pack or something. :eek:

Adam.

Stationbeem
February 15th, 2010, 01:14 PM
Link for XP service pack 3.....

http://www.softwarepatch.com/windows/windows-xp-service-pack-3.html